16 Pro + Win10 + UEFI problem installing

When you ran it from the Balena Etcher copy, did you try the "Something Else" option below the "Install alongside" or "Wipe drive and install" options?

As a SideNote: if you chose Zorin OS Pro - it comes with professional Installation Support from the ZorinGroup. Please keep in mind that hte ZorinGroup (The developers) consists of two people and as Zorin OS Pro was just released a few hours ago- they are probably swamped with requests so Please Be Patient.

No I didn't try the 'something else' option and I've lost the will to live for the night now. Spent all evening on it since I came home from work. It would mean flashing the drive using Balena again and then going through the whole thing again and it's late here.

Yes, I did send a support request to Zorin quoting my registration number and they just got back to me suggesting the same thing as you have, ie, use 'something else' option and manually partioning. Not sure I'm too thrilled at that idea because if the install routine can't see the Win 10 partition then who knows what could happen if I do things manually.

Have some rest (I could use some, myself... been troubleshooting Zorin OS, cars and other things all day so far...) Once you have more pep, we can walk through it monitoring to make sure nothing gets messed up.

1 Like

You're a good egg Aravisian, your willingness to help says much about you. I'll have another go tomorrow when my mojo returns. Cheers for now...

1 Like

I wanna say, I am no newbie, and a title like JUST zorin 15.3 trying to install zorin 6 does not worked !
I tried every possibility. redownloading the iso files, make the usb from a laptop tha tonly have zorin 15.3 on it, to try after to boot the 16 .. it failed .. then I use my windows 10 laptop with another usb, with etcher , rufus, in mbr in gpt, in UEFI in legacy just to say i tried it all, nada.. so someone lauch something to quick.. and with the level of quality the marketing as took the direction for, I would stop trying to help individualy everyone that will come with the same problem.. OH by the way.. what worked, is etcher making a usb on zorin 15.3 .. took the usb and boot it on my second laptop that have windows 10 and that worked.. so the usb is fine.. strange all this.. make me wonder, we my trusth is gone. (edit #1) sorry, I kept the screen at install zorin or try zorin on my wndows computer, i thought that was fine, but when i came to click try zorin its crash! so no can do also on y windows pc)

he need to go in the bios, remove PTT, and but secure boot at disable, whie his there, deselect s.m.a.r.t. and I readed you been there done that removed the fastboot.. under the boot secction where if its in legacy you decided of the order, if it's UEFI which boot will appear if you push F12, the section below, make sure there is nothing check about the legacy rom.. then save exit and tried again, but still wont work .. Rufus by default installed Zorin in mbr, btw for your infor guys, etcher when we can we shoudl go for that.. What it did to my wokstation that have only zorin 15.3 when I boot to install Zorin 16, is that I see ubuntu on first, on top, then the name of my sdd in second and in tird under the 2 other my usb.. UBUNTU? I tried, its my OS Zorin.. reboot tried the one with the name of my SDD, same OS that boot, and when i try to boot with the usb made on windows 10 with etcher, did not work, made by rufus in mbr and gpt for fun both, did not worked, when i tried etcher on zorin, did not worked either, used the image writer that come with zorin 15.3 nothing.. WELL nothing it boot a second to write error then my bios start is recvoery full scan from speaker to hardrive.. so I am going back to black...mad thought i woudl be windows free finaly

A quick update, several other users have had similar complaints- a far larger number than normal. This could just be the statistical odds following a release...

Or it could be that a package somewhere needs correcting.

Hi Aravisian, hope you had a good sleep after a long day? I finally got the 16 Pro to boot from the USB but had to enable Legacy ROM in order to see the USB drive. It's still in UEFI mode but has the option to allow Legacy ROM, without that it doesn't see the USB drive as a bootable option. I think it may be a Dell BIOS problem as you hinted at, though I'm on the latest version.

Anyroad, the install routine still doesn't see my Win 10 installation. I've disabled FastBoot, SecureBoot, ShinyBoot, DullBoot and TwoHoots. I had to revert to the Balena Etcher to flash the USB drive as when flashed with Rufus nothing happens, after boot to USB, except a blank screen.

I looked at the 'Something Else' option and printed out the manual partitioning guide that the Zorin guys emailed to me, it's from Ubuntu, except the pictures won't print out.

What concerns me is that if the Zorin install routine doesn't detect my Win 10 installation, why would the Grub (is that correct?) loader see it once I'm done faffing around with bizarrely named Linux partitions and having sphincter palpitations when I hit restart.......

I've ordered a new external 1Tb USB hard drive solely to do a full Windows backup, separate from the ones I already have. So I may wait until tomorrow until the drive comes and I've done that.

1 Like

No... lol
Can you try the tips in this guide (Will need to boot into Windows):

Turn your computer off, go to bed early!

I had already run chkdsk and even DISM to make sure all was OK. So it's a mystery.

One more thing. When I got to the stage of needing to partition, in the Zorin install using 'Something Else' option, my EFI boot drive is noted as something like sda1 but it doesn't show it as an EFI drive nor that it is the Windows Boot Manager. It says unknown. Which is a big worry for me.

However, my EFI drive is definitely the boot manager drive as you can see here:

The EFI partition should not be within the Windows Boot Manager. It is independent of the User Operating System (Whether Linux, Windows or Mac).

But if you look at 337Harvey's post:

https://forum.zorin.com/uploads/default/original/2X/f/ffb1d4ebe00f5b9b6649e5938052c6fc91142edf.jpeg
image

The EFI partition is Windows Boot Manager as you can see.

Yet when I am at this point in the install it doesn't even recognise that my system partition is EFI or Windows Boot Manager, it just says 'Unknown'.

This what worries me about using the 'Something Else' option, that I'll restart after partitioning for Zorin and there'll be no dual boot option because it doesn't see Windows at all.

ugh... nVME...

I can assure you that an EFI partition is not contained within Windows. This has to do with how the EFI partition works and is used that shows it must be independent of the Operating system.
By the way- that is a Small EFI partition. 256megs should be ok - many go for a 512 meg EFI partition to be safe. Only just under 40megs are used so you should be fine.
I might hazard a guess that Windows was installed first and it setup the EFI partition and then Labeled it as Windows Boot loader.

nvme0n1p3 is your Windows OS?
What is nvme01p4 doing over there? Is that the partition you have set aside for Zorin?

No, my setup is on an earlier post with a screen shot from Disk Management:

image

The one you are looking at was from a post I copied from 337Harvey, to show that his system recognises the EFI partition.

I have a 1Tb SSD partitioned into 2 x drives, one with Win10 (C:) and the other as a data drive (Z:) which I reformatted for the Zorin system to go on. It also has an EFI system partition and a Recovery Partition, both of those created by Dell. The Zorin install routine does not recognise my EFI system partition in the type column, it's just blank, whereas the Recovery Partition is noted as FAT32 and the Win 10 (C:) and data drive (Z:) as NTFS (both roughly 500Gb).

1 Like

You reformatted Drive Z, but it shows as ntfs. Have you tried reformatting Z as FAT32, then proceeding to try installing Zorin OS on it?

Thanks but that's not the issue for me, I can easily overwrite/reformat the NTFS partition at that stage of the Zorin install. At least the Zorin install recognises it and I could change it to one of the Linux file system types during that part of the install.

My problem is that the Zorin install does not recognise that I have an EFI system partition. It recognises all the other drives, ie, their formats but not the EFI one.

That suggests to me that I could have serious issues if I just go ahead and try to install Zorin as a dual boot system with Windows, using 'Something Else' option, when it doesn't recognise that a Win10 installation exists nor an EFI system partition.

I need to know that if I install Zorin, alongside Win 10, that it will actually work and that I don't entirely bork Windows and are left unable to boot into it.

It should... yes... But I am exploring all options here. I have seen it before where too much ntfs clogged the pipe.

I don't know. I would not even try to give you some confidence on that without having any- and then be responsible for any damages that may result - so I have been seeking to troubleshoot the issue, instead.

Aravisian, sorry I didn't mean to imply that I needed to know from you that it would work, it's a question I'm asking myself. Whether I take the risk or not because so far it seems like the only way I can get Zorin 16 Pro on my laptop is by using 'Something Else' option when it can't see the EFI system partition or Win 10 installation.

The only other option is to frag Win 10 altogether, and while that is the eventual plan, having also just got rid of Office 365 and moved to Libre Office, I just need to make sure that I can successfully transfer over all my emails from Thunderbird, and try some other things to make sure it all works for me.

I'm basically transitioning from closed, commercial systems and ones that vacuum as much data from me as they can and could care less about my privacy. I've wanted to move to Linux for some time and have waited for Zorin 16.

This... I can confidently say you can do. Other users on here are proficient with Thunderbird and can chime in.

No worries, I often beat myself up when I cannot resolve a users issue.
Chances are- it probably would be fine. But there is that chance...

That said- I have noticed other users saying, "I did not have this problem with Zorin OS 15, why am I having it on Zorin 16?"
I just wonder...

Have you tried installing Zorin OS 15? If that works fine - then just install Zorin OS 16 OVER it... Since grub would already be in place.