16 Pro + Win10 + UEFI problem installing

Thanks but that's not the issue for me, I can easily overwrite/reformat the NTFS partition at that stage of the Zorin install. At least the Zorin install recognises it and I could change it to one of the Linux file system types during that part of the install.

My problem is that the Zorin install does not recognise that I have an EFI system partition. It recognises all the other drives, ie, their formats but not the EFI one.

That suggests to me that I could have serious issues if I just go ahead and try to install Zorin as a dual boot system with Windows, using 'Something Else' option, when it doesn't recognise that a Win10 installation exists nor an EFI system partition.

I need to know that if I install Zorin, alongside Win 10, that it will actually work and that I don't entirely bork Windows and are left unable to boot into it.

It should... yes... But I am exploring all options here. I have seen it before where too much ntfs clogged the pipe.

I don't know. I would not even try to give you some confidence on that without having any- and then be responsible for any damages that may result - so I have been seeking to troubleshoot the issue, instead.

Aravisian, sorry I didn't mean to imply that I needed to know from you that it would work, it's a question I'm asking myself. Whether I take the risk or not because so far it seems like the only way I can get Zorin 16 Pro on my laptop is by using 'Something Else' option when it can't see the EFI system partition or Win 10 installation.

The only other option is to frag Win 10 altogether, and while that is the eventual plan, having also just got rid of Office 365 and moved to Libre Office, I just need to make sure that I can successfully transfer over all my emails from Thunderbird, and try some other things to make sure it all works for me.

I'm basically transitioning from closed, commercial systems and ones that vacuum as much data from me as they can and could care less about my privacy. I've wanted to move to Linux for some time and have waited for Zorin 16.

This... I can confidently say you can do. Other users on here are proficient with Thunderbird and can chime in.

No worries, I often beat myself up when I cannot resolve a users issue.
Chances are- it probably would be fine. But there is that chance...

That said- I have noticed other users saying, "I did not have this problem with Zorin OS 15, why am I having it on Zorin 16?"
I just wonder...

Have you tried installing Zorin OS 15? If that works fine - then just install Zorin OS 16 OVER it... Since grub would already be in place.

Installing a dual boot system is no easy task. If you were to install ZORIN OS without any other OS it would be just as easy as installing Windows 10. This is not a ZORIN OS problem but really you are entering into the complexities of a Dual Boot system. There are various other alternatives to consider some of which were discussed here : A Zorin and Pop_OS question - #39 by tessierp

From the issues you are describing, I am starting to wonder if this could be a Grub issue that is unable to detect Windows 10. This kind of problem has also been seen on other distributions and I am not sure if it is Microsoft just changing things and making it difficult to get the Windows OS detected. Not accusing here just wondering since I had read about these problems before.

To be honest with you though, with all the headaches a Dual Boot system involves, I would consider the alternatives suggested in the other post. Yes it does involve extra hardware but it is not super expensive and you will bypass all these issues. Since my transition to Linux will be progressive as I still need Windows for work and occasionally game, I really don't want to have to mess with a Dual boot situation. That is a personal decision but after a lot of talking and considerations it seems the less painful route. For example, lets just say you no longer want to use Windows or Linux in the future, you would have to deal with reinstalling the Windows Bootloader in the EFI or removing Windows from the Grub boot list. I personally just don't want to deal with that. For now, until I get the hardware I need to window Linux native without a dual boot, I'm running Zorin OS 16 in a VM.

But again this is not a Linux issue or the Zorin OS distribution for that matter. Whatever decision you make, be patient, you'll get there and you'll just become better at troubleshooting issues and there is always help from the community.

1 Like

Please note this response posted Here:

Aravisian, I think your post above might be it, my laptop is a Dell Inspiron. So I'll wait for the Zorin guys to release the fix.

Alternately, if the Dell fix doesn't work, I also downloaded the Zorin 15.3 iso so that I'll be ready to try your earlier suggestion of seeing if this works and then writing 16 Pro over it.

Please don't, you've been really helpful towards me and I can see how much assistance you give to others on this forum. I'll bet good money there's a ton of people here who hold you in high regard.

I am pretty sure that the Zoringroup has my picture posted on their wall.

They use it as a dartboard.

Hopefully the fix will be released soon allowing you to get your installation finally done. I wonder if you will be as impressed with Zorin OS 16 as I have been... I was trying out Ubuntu 21.04 (And 20.04) when I got my grubby mitts on the Zorin OS 16 Alpha build. It took me about ten minutes to know that Zorin OS 16 was going onto any of my computers I could cram it onto.

I watched some of the youtube video reviews in full screen and 16 Pro looks pretty fabulous. I've been waiting a while to move over to Zorin, since about version 12, and ditch Windows entirely and now is the time.

Would you have any recommendations for a Linux newbie like me in terms of books I can get in order to use the command line/terminal and general Linux use? It's not just the GUI I like, I'd also like to understand and use the terminal and discover the power of Linux.

I am not really aware of many books on it. The reality is: The terminal is all about Practice.

Using zsh with the addons "Word Completion" and "Word suggestions" helps a great deal.
Member Taha_mcp has started a project (Currently in development) of an online terminal emulator that can be a Reference Tool for terminal commands and practice point to ensure the use of the terminal - in a safe environment with no risk of mistakes on your system.

For me, when I moved over from windows, I had barely ever opened the command prompt on Windows. The terminal was scary. At first I complained that I wanted Easy Installations like Windows had (Somehow... I forgot the countless times Windows installations failed with some obscure error that I could find like no help on...)
After a few troubleshooting adventures (of my own mistaken making) and installations using the terminal, that fear began to subside. I began to play in the terminal. Like a kid.
And I never messed up my system by doing so. Ok one time we suspect I did a sudo apt autoremove that did harm... But never confirmed that. Either way, the fear was unfounded.
But the power it wields is certainly not. For such a basic looking thing... If Windows is Grand Central Station then the Linux terminal is The Q Continuum.
The best way to learn it is to get in it and Do Things.

Hi Aravisian, I tried the Zorin guys fix for Dell UEFI problem but having no luck so far. Maybe you can feed it back to them.

They note this:

  1. Navigate to General > Boot Sequence > Add Boot Option
  2. Select the "Boot Option Name" and insert "Zorin"
  3. Click on "..." in "File Name", select the Zorin OS Installation USB Drive and EFI / Boot / grubx64.efi

However, when I do this there is no grubx64.efi anywhere to be seen. The USB is recognised, along with the SSD, and I can select either one and have a look at different .efi files in different directories, including a Rufus one (I used this to flash the USB) but no mention of that particular grubx64.efi file.

I'm going to try Balena etcher to see if that makes a difference but the reason I used Rufus is, as you suggested, you can specify GPT and UEFI.

Secure Boot in BIOS is turned off by the way, as is Windows Fast Boot in Win 10 and I also disabled Hibernate in the registry just to make sure. POST Behaviour in BIOS is set to 'Thorough' as that's also recommended.

Edit: Should also say that I tried this, as suggested by Zorin guys:

"If the system can't identify the USB Drive at step 6, you can unplug & re-plug the USB drive to see if it changes inside the "File Name" > "..." menu."

In the screenshot below, you can see my path in the pathbar: /media/mech-1 (that's my username)/PNY (that's my usb)/EFI/boot
Within are the files. Can you follow that same path - /media/$USER/Your-USB/EFI/boot and ensure that those files are not present?

Err....probably not....I'm doing this in the BIOS Setup and so if the file isn't there I can't select it. I've navigated both the Boot and EFI directories on the USB ....again, from the BIOS Setup, following the Zorin guys instructions. When I click on the "..." for File Name.....I get lots of different types of .efi file showing and which I could select....but no grubx64.efi file....anywhere.

...and so you know, this is how I flashed the iso file:

1 Like

I meant by plugging the usb drive into a working system and just looking in the file manager...

As far as not seeing it from within the MB's settings... I am not sure... I would need to try replicating this just to see if I can spot something you don't... But I am not on a Dell (I uhh... I worked for Dell once, many years ago...)

By the time we suss this out- the corrected copy of Zorin OS 16 will probably have been released.:expressionless: LOL

I'll give that a go, just trying to flash it with Balena again but it keeps failing, Rufus flashes OK. I want to see if there is a difference when I boot with the USB in and try to see if the grubx64.efi is there when flashed by Balena. I doubt it but want to rule it out.

Yeah and I'll have even less hair than I do now :frowning: but hopefully my sense of humour will remain intact! I'm not going to give up because I really want Zorin as my OS of choice. Even if it means I have to vaporise Win 10 before I planned to.

1 Like

@Rory have you tried using Fedora Media Creator to create the bootable USB? I'm pretty sure FMC makes bootable media compatible with UEFI and secure boot.


Well, I appear to have a Zorin 16 Pro system up and running alongside Windows 10 on my Dell Laptop :slight_smile: am writing this in Firefox on Z16Pro....yabbadoo.

The grubx64.efi file was on the Balena flashed iso and so I could add Zorin as a boot option as per the Zorin guys fix. Strange that the grubx64.efi was not present when flashed by Rufus.

Anyway, all done. Dual boot to Win 10 works.

One quick question, once I check out the things I need to I'd like to get rid of Win 10 and just have Zorin on this laptop. Would that simply be a case of running the install routine again and selecting the option to wipe everything and install Z16Pro afresh?

1 Like

Yes, you can do it that way or...
You can use the partition manager to reclaim the space taken by Windows, expand the space allotted to Zorin into that - then Update grup and update initramfs.
When you are at that point, if you want to reclaim the space and keep your Zorin Install as is, you can start a thread if you would like a hand.

Aravisian, that's great and when I'm at the stage I'll probably start a thread as you suggest.

Many thanks for your help and patience with all this, it's sincerely appreciated and I'm grateful to you.

...and....damn.....Z16Pro is just so speedy on my laptop....and gorgeous....and I'm off to play!

1 Like