2nd screen: only mirroring possible

I just connected a second screen. The appearance on both screens is identical, isn't it possible to use them next to each other?

In settings/display, I don't see the individual screens. All the settings are to change orientation/resolution etc. on both screens.

Any ideas?

Do you have an option at the top that says Multiple Displays? The individual controls only appear once you've tweak that option to "Join":


1 Like

No, here's what it looks like on my screen.

It doesn't matter if the 2nd screen is connected or not, the settings look the same. What might be the issue? I am connecting the screen via HDMI. USB-C didn't work.

Gday @garfunkel
If the 2nd screen is not appearing in setting/display "As per your photo"
This indicates that the machine is not detecting the 2nd screen.
First with the 2nd screen connected please run the "software Updater" shut down the pc,restart & test.
If you still have no 2nd screen in display settings.
Please show us the output of the following

sudo lshw -C display

Is it possible that the screen is working while not being recognized by the system, perhaps because the driver is mindlessly sending output to the HDMI?

1 Like

Yes Zen, 100% correct.
It's like some cheap cables are built to mainly charge & & are very very slow to transfer or tether/etc.
So if the cable is at fault it will do funny thing's as we see, this also applies to bad or incorrect driver.

As it's the 1st time trying a 2nd screen i hope the update may work (this may take a 2nd update).
If the driver looks good then we should look at the cable & connection ports.

eg:
we'll need further machine info.?
is the HDMI cable, Passive/active/optic/etc?
distance to 2nd screen?

Great work Zenzen keep it up.

Added: even firmware could be looked at. :+1:

1 Like

I'm terrible when it comes to "low level" stuff like hardware, cables, bootloaders... I'm trying to learn as much as possible :smiley:

1 Like

*-display UNCLAIMED
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0
resources: iomemory:600-5ff iomemory:400-3ff memory:601c000000-601cffffff memory:4000000000-400fffffff ioport:3000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff

Does this help?

I restarted the computer, still got the same issue.

--

I used the USB cable with my MacBook, there it works fine.

Are you currently using MacBook?

Great thank you Garfunkel,
As you see "UNCLAIMED", this indicates that it's not working/setup, this is due to having no controller driver.

Could you please provide your computer spec's.
Brand/Model=?
Ram size=?
HDD or SSD & size=?
Is this a dual boot computer=?

When you said you restarted the pc, i assume you ran the "Software Updater" before restarting?

Its also possible that its a shared port, i had a netbook that the hdmi port would only mirror and even in windows was not separate from the built in lcd.

I would also check in updates -> additional drivers as you might need an additional propriety driver to use the hdmi - common with intel igpu and nvidia carded laptops ,

It's a brand new Starlabs Starbook (StarBook 14-inch – Star Labs®) with 16 GM RAM, 512 GB SSD.

Yes, I ran the software updater before.

Where would I get those additional drivers from?

If it is a Starlabs notebook, usually Intel which is included in the kernel. If it is AMD, that too is included in the kernel.
Have you raised your kernel?

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Reboot and test...

If you had Nvidia, you probably would know it...

Being StarLabs i think its intel, is Secure Boot disabled? that can cause issues with device detection

Additional Drivers is located
Software Updater -> Settings -> Additional Drivers
Screenshot from 2023-10-24 02-14-27

Sorry, I am new to Linux.

How do I see if Secure Boot is disabled? How do I disable it?

Strangely, when I go to the Software Updater and then click on "Software & Updates", nothing happens. Weird.

In your app menu, type in software and you should see an Application Listed that is labeled Software & Updates
Click on that application. It is not reached by going through the Software Updater application.

Secure Boot is a BIOS Setting reachable when you boot the computer and select an F key for it. Often it is F2.

In the BIOS settings, look for a Security tab.
I also recommend you check your kernel, as well:

1 Like

It shows the exactly same screen here. No additional drivers available.

I entered these commands, restarted the computer, now it's not working at all anymore. What can I do? That really sucks...

That is unexpected. :expressionless:
Don't worry, very easy to fix.

Reboot and tap esc or tab to show the Grub Menu. This is the menu that offers to boot Zorin
Or underneath that is the option of Advanced Options for Zorin.
Select Advanced Options for Zorin and on the next screen, arrow key down to the previous working kernel
Zorin on 5.15.0-83... or which ever it was. Might be up to -86 now.
Then boot up. Once you reach the desktop, you can remove the non-working kernel:

sudo apt remove linux-generic-6.03

sudo apt clean && sudo apt autoremove

sudo add-apt-repository --remove ppa:tuxinvader/lts-mainline

Sorry to take so long to reply - I was first testing that this removal method will work.

(Interestingly, the errors you showed in your photo are generally totally harmless. Something else with that kernel must have caused a problem that did not generate an error at that point).