Abrupt Screen Shut Off

Every 10-14 seconds or so my screen shuts off. I do a reboot and the problem sometimes get solved. At other times, I see the problem again.

Could anyone clarify what’s happening?

Is this happening whilst you are actively using the machine or when it is left idle?
You are on 15.3 Core if I remember correct?
Have you recently had a kernel update?

While using the machine. For example, while reading a blog post if I don’t touch the keyboard or move the cursor, the screen shuts off.

No kernel upgrades, I guess. But, I have this problem for a long time. Finally, I decided today to ask about this. By the way, I haven’t made any changes to the system to fix this issue.

After the screen shuts off and you then move your mouse or touch keyboard, what do you see?
I dont know if this may be of help

I don’t see the login screen. I see all things as is. The screen shuts off as If though I’ve put a 5-10 seconds timeout.

By that do you mean you can see windows that were last in use?
If so is it a frozen session you are describing, not a shutdown.
A picture, even from your phone to illustrate would help understanding me thinks.

1 Like

Yes. All windows and applications running, as is.

No. Not a frozen session.

If you are seeing all your Windows normally (not black screen, standby screen or login screen) and they are not frozen, then how is this regarded as a “shut off”.
Sorry but I do not understand what you are seeing or experiencing. Please post a screenshot or photo to illustrate.

Ok then. I did a reboot to temporarily fix it. When it happens again I’ll post a pic, or possibly a video of it.

1 Like

@zabadabadoo Here is a short video I filmed to let you know the issue I’m facing. The display light turns off after 13 seconds or so…


1 Like

Capraciousduck, are you running Zorin Core or Zorin Lite?

When the screen blanks out like it does in the video, does it re-intialize on its own or do you need to move the mouse or tap a key in order to wake it up?

1 Like

I am running the core.

Nope. It doesn’t wake up on its own. I need to move the mouse or press a key.

@capriciousduck Please confirm.

Yes, I am.

What do ya think, Zab, does he need Caffeine?

Have you checked all your power manager settings?

Yes. Although I set it to never I still face the issue.

@capriciousduck : Also check: Settings>Privacy>Screen Lock

@Aravisian : Caffeine would certainly overcome the problem, as it would automate the regular mouse movement.

A cat sat on the keyboard would have the same effect on the mouse, as mentioned on another thread :smiley_cat:

Re: Caffeine

1 Like

@zabadabadoo Yes, I checked. Scree lock is disabled. Isn’t there another solution to Caffeine-with which I am not familiar?.

@zabadabadoo That’s funny but I don’t have a cat, either a dog, but love to have both of their support to fix this issue :smile: