Acer laptop displays Acer --> Zorin --> Acer logos but doesn't boot up

Hi, I am new here. I installed ZORIN Lite 15.3 on my acer E5-571 which has a Nvidia GeForce 840m card. Originally I installed the normal Zorin and then the system will boot up but it will show "nouveau sched_error 20 [ ]" and then after waiting for a minute or so, it would display the desktop page and all apps work normally.

I read about the "sched_error" and it advised to update the drivers. So I did that. Then the on reboot, the laptop will display the Acer logo, Zorin logo and then Acer logo and stop. I decided to then reinstall Zorin but selected the one with "modern nvidia drivers". Installation was fine. It loaded and and installed on the hard drive of the acer.

However I still cannot boot up. The machine displays the same sequence of logos - Acer --> Zorin --> Acer and then stops.

I am not sure what to do. I tried to reinstall the original Zorin (without Nvidia drivers) but I can't even get into the installation screen.

Please help.

(1) I hope you remembered to double check the SHA256 checksum for ISO integrity before you made the burn. I also hope you didn't burn using Balena Etcher, but instead used Rufus or Unetbootin. If already on Linux, I recommend Popsicle.

(2) Did you go into the BIOS and make sure that SECURE BOOT and FAST BOOT were disabled? If not, it would be a good idea to do that now.

(3) After powering on your computer, hold down the LEFT SHIFT key to enter GRUB menu. Select advanced options from the menu, then go into terminal. Please input the following.

sudo ubuntu-drivers autoinstall

Then restart the computer after the install has been completed.

Hi StarTrekker. I didn't check the SHA256 for ISO integrity, but I have used the same USB to install on my other laptop and it worked fine. No problem as described.
2. I used Balena Ethcer as recommended by Zorin.
3. Yes went to BIOS and disabled Secure Boot and Fast Boot.
4. I tried holding the LEFT SHIFT key to enter GRUB menu but it won't do that.
I will try holding the LEFT SHIFT key again to see if it works; and let you know.

I tried holding the LEFT SHIFT key down whilst system booted up, but it did not enter the GRUB Menu at all. Instead it started to display the Zorin logo then the Acer logo and stopped there.

OK, in that case, try hitting the ESCAPE key repeatedly after you power on the computer during the boot sequence then, see if that gets you into GRUB.

This is what I am trying to do now. I press F12 to reinstall Zorin. Selected "safe mode" and I got into the usual desktop page that allows me to install the OS. However I managed to notice that BEFORE it got to that page, there were some messages that flashed very quickly and then disappeared. I managed to get some of the words so not sure if this is 100% accurate. The message said "integrity problem ... X509 certificate".

What is this all about?

OK, lets try running these commands if you can get into terminal...

Got into Terminal. Entered command "sudo fdisk -1" and I get this message "fdisk: invalid command -- '1' ". Tried again, making sure spaces and spellings are correct. Get the same message.

Just to confirm, it is "minus one" and not "minus [alphabet L]".

In GRUB menu, under advanced, I think there's a repair boot command. I am not saying it will work, I am just saying its something to try.

Since I got the USB to boot up in safe mode, I am going to try to reinstall Zorin to see if it will work and then will let you know outcome.

Its just got to work, cause you have the same name as one of my favorite characters in the show Star Trek Deep Space 9, he's full character name was Julian Bashier, he played the doctor. So lets hope the re-install and treats you right.

Hahaha. DS9 was a good show. I do love the new Star Trek Discovery and Voyager. The funny thing is that Enterprise (vessel NX-01) looked more advanced that the original KIrk's Enterprise in the 1960s TV series. I know they were produced at different times but it is just interesting.

Something to help lighten the mood, as I myself need the stress reducer right now lol.

Archers Ship

Kirks Ship

The "integrity problem ... X509 certificate" that I noticed. I discovered the resolution as listed below:

Apparently it is a problem with ACER laptops but doesn't cause any problems to the system, and can ignore it. Just FYI.

Cool. Will save these images.

Yes, I actually saw that too. But that was the reason I did not post it. There appears to be no resolution in regards to that, and its just some weird BIOS certificate issue that we are not able to resolve.

The reinstall still wouldn't boot up and gets stuck at the 2nd ACER logo display. I did press ESC when powering up and got into GNU GRUB

So what do I do next?

I was thinking about having you run boot repair under advanced options. If this doesn't work, you might have to wait on someone else to answer.

How do I run boot repair?