Activate radeon rx 6700 xt in multi-monitor after replacing nvidea card

I just replaced an nvidia 1660 ti wiht a Radeon rx 6700 xt. I have 4 monitors connected the software is NOT recognising the video card ID while only displaying on 1 monitor and not even showing an ID for the monitor. The software system says there's no driver to download as it should be directly recognised. The only Linux drivers from Radeon are for Ubuntu and that driver won't install as it recognises I have Zorin and not Ubuntu.

I'm running Zorin 15.3 with 64 GB RAM on an AMD Ryzen 5 3600 6 core processor.

Where and how do I change what needs to be changed so the system will look for the monitors properly, and look for the 4 of them.

1 Like

Can you reference this post here:

and see if that works for you?

Thanks for the response. However, just in case there's a good reason they limit that driver to Ubuntu I'll keep this as a last resort effort. I did wonder if it would be worthwhile editing the xorg file, but I don't even know where to find the correct file let alone what to put in it.

It's frustrating that there's a hell of a lot of support on the AMD Radeon site to help with Windows and Ubuntu, but everyone else gets nothing. Heck, even a simple management program would be useful - at least nvidia did that right with a small management program to help detect monitors and cards etc.

No, I think that this would not help you any.

What kernel version are you on?

uname -a

If above 5.4, can you try this driver upgrade?

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update

sudo apt full-upgrade

The uname gave a response of 5.4.0-77-generic #86-18.04.1-Ubuntu

I then ran the other commands you gave and a lot of stuff downloaded and upgraded - now what?

Thanks so far.

Can you reboot, then test your display settings for the monitors?

rebooted - no changes anywhere I can see, dang it.

Could you try downloading the Zorin OS 16 Beta and burning it to a USB (Rufus or Unetbootin... BalenaEtcher is Not Recommended) to make a Live Zorin USB.
Boot into it and test your Graphics on it?
If that works, it may point us in Two Possible Directions:

  1. ) Upgrade the kernel of Zorin 15.3 to a later kernel than is currently supported by Zorin 15.
  2. ) Replace Zorin OS 15.3 with Zorin OS 16.

I'm trying very hard not to have to do a reinstal. I suspect I could do a reinstal of 15.3 and fix the issue, but then I Have to go through and save all of my data and redo all of the personalised settings - I really don't want to do that if I can avoid it. But I may have to.

I know the feeling. I customize- A lot.
But, I also find it is never as bad as I dread it to be. You can back up your home directory, saving your customized configurations and settings.
I think we can first try the Live USB to test it graphics work on Zorin 16 Beta- and if they do - try installing a later mainline kernel like 5.9 or above, even.

According to the AMd Radeon website and the main Zorin website the card should just plug and play OK. However, I suspect the issue is I had an nvidia card in use until I swapped the cards earlier today. That's why I suspect I only need to find the right file and change a setting to have it recognise and work all 4 monitors OK. At the moment it only works the 1 monitor, and, of course, it had to pick the smallest one with the smallest font to use.

You mean smallest resolution?

Not exactly, just the damned hardest to read due to it being my parking monitor so the font is very small as the monitor is small, I could set it to have a larger font or smaller resolution but then it messes up the windows etc, so I just squint at the dang thing. What's easy to read on the 42 inch monitor is damn hard on the 20 inch monitor.

Funny how everyone is walking around with their nose glued to a cell-phone, isn't it?
Yes, the AMD drivers really should work out of the box. I do wonder if your AMD graphics card is too new for the 5.4 kernel you are using...

Editing a grub parameter may help... for example;

sudo nano /etc.default/grub

Arrow key down to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and add amdgpu.ssg=1 amdgpu.direct_gma_size=9 to the end. It should then look like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.ssg=1 amdgpu.direct_gma_size=9"

Press ctrl+x to exit, the y key to say yes to save, then the enter key to save as current configuration. The terminal will revert to normal.
Then

sudo reboot

and test.

I've just finished copying all of my data, so I'll have a go at the first option given of changing that etc file.

1 Like

just ran the amd-gpu program and it had an issue some dependencies and says there are brokne packages. I'm going to log off and reboot, and hopefully, be back soon with something working, otherwise I'll have to go the rebuild route. See later and thanks for the help, whatever happens.

Ernest

1 Like

You can try:

sudo apt --fix-broken install

I think your assumption is 100% correct.
Graphics card is an integrated part of the OS and I am not surprised to see such "hot swap" does not work.

What about fire up a live USB of Z16 to see if it works with kernel 5.8.x

1 Like

I second to that.
I always save my installer USB for just in case like this.