After I install Zorin OS, it can't boot from USB drives anymore(FIXED)

So, after I installed Zorin OS, I wasn't able to boot into any kind of install usb. I did change some setting in the bios but still nothing. So can someone help me?

Laptop: Fujitsu Life book S752

Note: No, I seriously need help I'm trying to dualboot my laptop with Windows 8, but I can't.

Note 2: Damn I'm dumb. I keep putting the install file system to NTFS! I had to use FAT32 for this to work. Damn I'm that dumb.

I think this thread should be under "installation" category, but I am not the administrator who can move the thread.
A similar question was asked a few days ago, which is also involved Fujitsu Lifebook:

You could try Boot repair par suggestion by zabadabadoo.

Also have you tried to factory reset the BIOS?

Please verify that your USB and your USB ports function. Then plug your USB in and load up the BIOS menu. Look around in the BIOS settings and you should he able to find a "Boot Order" or some similarly named option. Make sure, the USB port has the highest priority.
The other factor to check is that if the OS image has been correctly burned onto the USB. If you have access to another PC, please see if it boots on that.
Another thing to check is if your BIOS setting has been set to UEFI or Legacy mode. I believe from Windows 8 onwards, your BIOS needs to be in the UEFI mode before even booting a Windows live image (I could be wrong).
And finally, based on my experience and what I've heard from other people, it's recommended to install Windows first, then a Linux OS. You might want to consider that before finishing your setup process.

The manufacturer has a troubleshooting guide. I have not read through most of it - much of the top portion seems to deal with Windows so you may need to scroll down to manufacturer settings;

Yeah I did change some bios settings but still nothing.

Yeah, did that.... Nothing.

Yeah, about the boot repair.... That didn't work.

It says "fixed" in the title. Can you please share with us how you solved it, thanks.

Storm, he edited into the O.P. and I will quote the relevant portion, here:

1 Like

Yes always use fat32, if you're wanting to install another Linux Distro onto another drive I can highly recommend Mintstick It not only writes to your USB stick, it formats it to fat32 too. All you have to do is pop in your password and away it goes.

1 Like

It even did not occur to me questioning how you format the installation USB. I am taking it for granted that installer USB is in FAT32 format. A thing to remember if I want to help people who has such problem in future.

Thank you for the link!
I was looking for this app in Software but could not find it. I had this app when I was using Mint XFCE and was missing it :slight_smile:

Request to the Zorin developers: Is it possible to add Mintstick in Software?