After reinstalling light dm Zorin reverts to old 18 Ubuntu and Pw login loops

Background: for reasons I forget now, 3 days back I tried to install a program I thought I needed.

I ended up with the laptop freezing at DEV /SDA1 clean xxxxx fields xxxx blocks etc

However i could access the non graphic log in via cnt + Alt + f2

Some things I tried
After surfing and trying various things I ended up installing desktop- didn’t help and lightdm
.
I went for lightDm as I although I could access the repair screen it would still not load but hung after: "starting Gnome display manager.

That worked and the start up continued with a graophic log in interface.

Problem is, it is now a Ubuntu 18 screen and the login password just keeps restarting.

I rebooted, went back to ctl alt f2 and the screen, signed in using normal name and password.

Question:
How do I get my Zorin screen and the original password login back please?

Want to try for this one @Aravisian, @swarfendor437 ?

Cheers
p

Just in case it is relevant, it began when I wanted to instal Geany IDE via PPA.

Oh, and I have cleaned the blood off the wall now Aravisian :grinning:

Did you try sudo apt --reinstall install gdm3 ?

Are you experiencing Login Loop? Or is it that you want the original PW screen back?
Carmars instructions above for reinstalling GDM3 is the way toward getting your Login Screen back. Theming it back to Zorin will require another step than just installing.

To restore the Zorin Themed Splash screen, you must change the Plymouth theme.
In terminal enter

sudo update-alternatives --config default.plymouth

An editor will open in the terminal offering the avialble themes. To Select- type the NUMBER of the entry you want. For example, Zorin-Logo plymouth theme on mine is 0. So I would type a 0.
Once this is done, you must update the initramfs to see the change:

sudo update-initramfs -u

Are the other issues you were having repaired?
Also, I use Geany. It is very useful for editing .css files.

GDM3 login screen theme is located in /usr/share/gnome-shell/theme
I do not use Gnome or GM3, so you will need to look around in that directory for a zorin theme, if one is there. There should be a .css file in that directory that governs the GDM3 screen appearance.

1 Like

Hello, thanks, no I didn’t, but having now done so nothing has changed.

Before that I also used command line to remove ubuntu-desktop which was one of my first attempts. I also tried the Xauthority trick to regain password control. Both it and removing desktop also had no impact.

I will follow up with Aravisian now as I know he is predisposed to hurting himself~

Remove Ubuntu desktop… Did you install Ubuntu-Desktop?

If it helps, I could hurt you, instead :smiley:

Yes, I am experiencing login loop and I want the Zorin look back. As noted above Carmar’s idea failed.

Sorry one of my many dense periods: how do i know which number relates to which theme?

I ask before I do this as I don’t want to make the situation any worse, if that is even possible.
Cheers

Yes, did I not mention that in the original? Sorry.

I think I am hurt enough already but thanks for the offer!

I was not very clear there… Sorry.
The terminal screen tells you.

When you run the first terminal command, it will list the themes with a Number at the far left, then the Name of the Theme.
You only need to enter the number that corresponds to the theme to select it.

Ok, will try that, but I thought after i pressed send, I have no idea what the name of the theme i have is called a anyway, so it is a moot point.

Oh by the way I think what Carmar suggested I achieved by installing lightdm- that gave me the graphic login interface back

Maybe we aught not to have done that?

Missing firmware warning is unrelated.
I have gotten that, too, before. The only fix I ever found was to install a package that no longer exists.

Ok
But we are still no further advanced, still the 1804 screen and looping login

Am doing an update now, seems a a massive amount of packages being delivered.

You said you installed and removed Ubuntu-Desktop. I wonder if in that removal, it removed a part of Zorin-Desktop. You might try reinstalling Zorin desktop and zorin desktop core, before trying the usual Login Loop fixes

Everything is marked Bionic beaver which is that 1804 Ubuntu- is there a way to remove that? I can’t find it in any of the forums.

Since Zorin is built off of Ubuntu, it makes sense you would see Bionic packages.
If I might ask- are you running Zorin? OR is it a different distro that you installed Zorin packages on to?

so, something like apt-get install zorin-desktop ?

Removed light dm
Obviously, this also solved the ubuntu screen issue, now after the Zorin logo it goes to a #666666 grey colour before the command line log in appears.

I am going to try Carmar’s suggestion now

have you checked that xorg is still installed?

Seems to be a huge delay in our messages, took 26 minutes for yours to arrive.

Nope. Pure Zorin. Was win 7 which I completely ripped out then wiped the disk before installing Zorin.
So no to the next thought, it is not a dual boot either.