After update - cannot open my Zorin

Steps done before issue occurred.

  • Boot up Zorin OS 17 Core from boot menu (installed on SSD, while Windows 11 is on Nvme), no issue
  • Zorin opens with no issues
  • Open Terminal and do a routine sudo apt update, success (update window opened asking me to remove some old stuff)
  • allowed updater to do it, no issues
  • switched my nvidia driver to the priopietary, tested, success
  • rebooted PC

[issue started]

  • Boot Zorin OS 17 Core, wall of checks appeared
  • black screen with blinking cursor on the top left, few minutes and still the same issue
  • reboot PC and attempt: same results

Processor: AMD Ryzen 5 5600
GPU: Nvidia GeForce 1060 3GB (2017)
SSD capacity: 500GB

Are you able to boot again into grub menu,
select Additional Options for Zorin,
choose previous kernel generic version listed,
boot that and test/report back.

unfortunately no, nothing happens when I tried to load it.

What graphics are you using?

You should be able to access the Grub Menu and Recovery Menu - thereby giving access to network and terminal.
Enable networking in Advanced Options for Zorin by choosing a kernel under (Recovery), then arrow key down to Root - drop to prompt and run

sudo apt install --reinstall zorin-os-desktop

Welcome to the Forum!

Do you come in the BIOS? If Yes You could try from there to start.

I'm finally able to boot grub menu, and tried the previous version. so far, it gave the same results as the screenshots.

No critical issues had occurred while folowing the steps. During the boot, it still showed the same things as my previous screenshot. Still a horizontal cursor blinking at the top left corner of the screen screen.

here is an unusual part that happened. Before the solutions were provided by the others. I attempted to load a repair boot from the USB stick zorin os, but was giving me an UEFI issue with the bios.

I turned off the UEFI only, and then this happened.

i didn't install the boot on my nvme, but it shows there. In fact, I can load my linux there now, BUT I was supposed to load it through the SSD. That's where I'm stuck right now. The Repair boot doesn't exist in the normal boot, either.

I'm doing more tests atm

1 Like

in addition to being able to temporarily access it, I am currently stuck at 1024x768 resolution. I am currently remedying that one, as it might have been the cause of the issue...will update soon

Great news!

I was able to solve the issue. By temporarily booting up Zorin through the NVME (still not sure why that appeared), I decided to follow one of the solutions from @Aravisian from this solution. Did some tinkering first because nvidia-driver-535 and nvidia-driver-545 fixed the resolution, but permanently set the color to warm for some reason. Downgraded it to nvidia-driver-525 and it solved the color issue, and I can boot it up again from the SSD without the previous issue.

In other words: the update that I did to my graphics driver caused a boot-up error, and purge-install it fixed the issue. Thankfully, if it weren't for the NVME boot to Linux, I wouldn't have been able to remedy the situation.

1 Like

Once you are happy that things are OK, please mark the post that helped you (or your last post that exlained the fix) by clicking on :ballot_box_with_check:Solution under the post.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.