Alternative characters key problem


You need to reboot to make the change to system wide.

After the log-in, it will ask you to update the home folder names to the current language (Russian in your case).

Select "NO" for answer and tick "Do not ask this question again" box.

If you select Yes, you need to type folder names in Russian in Terminal which could be a big pain (been there done that in Japanese).

1 Like

I did this, but now the main language of the Zorin OS interface is English, I don't want it to be that way, since I am used to to work in English :slightly_smiling_face:
Other than that nothing has changed, there is nothing new in the input methods, like FCITX or anything else, the typographic layout still doesn't work

Something I did not know.
I can only tell you what I always do.

I install Zorin in English, install and change the language to Japanese. This will enable a Japanese keyboard layout.

I wonder if you want to change the language to Russian temporally to see if you can enable this alternative keyboard then changing the language back to English.

Just a thought.
Changing the UI language is a piece of cake in Linux.

1 Like

Okay, so the language is now Russian, but, as I already mentioned, alternate characters key still doesn't work

Thanks for confirming this.
I think you can put the language back to English now.

If you want to proceed further I can show you how to install FCITX. But there is no guarantee that it will work. Please let me know.

1 Like

For sure, let's try it

Open terminal and issue this command:
sudo apt install fcitx

1 Like

Installed it, changed to FCITX in settings, and again, no result

Should I reboot?

You could try.
Oooh, Russian alphabets look so cool :star_struck:

1 Like

As well as Japanese :smile:

1 Like

We all want to have what we don't have :smile:

1 Like

Unfortunately, something gone completely wrong
After I rebooted, Zorin OS just didn't boot up. Ctrl + Alt + F2 didn't work, and I couldn't write anything to the forum using any other device, so the only way left is to reinstall Zorin OS (there were also no other suggestions on the internet)
After reinstalling I got screen tearing, and another error trying to fix it. This made me to reinstall Zorin OS again
I don't know what happened, but this is really sad. I got another problem while trying to fix one

That is too bad.
In fact, there is an ongoing issue about this last kernel and NVidia graphics card problem.

I am afraid the case seems to be beyond my capability.
I will call for reinforcements:
@Aravisian @Kedric @zabadabadoo @337harvey @tomscharbach @StarTreker
Do you have any idea why this is happening?

I have completely no idea actually

Sorry, the question was for the other volunteers :sweat_smile:

Oh, got it :slightly_smiling_face:

Let's get adventurous.

Do not worry- the below can easily be Undone if needed.

But let's try the latest stable LTS kernel for Ubuntu 20.04:

Copy each into terminal to retrieve the packages:

wget -c

wget -c

wget -c

wget -c

Now, install all in one go with:

sudo dpkg -i *.deb


Completed every step
Do I need to reboot now?

Reboot and tap the Left Shift Key during boot to pull up Advanced Options For Zorin.
Choose the 5.8 kernel to boot from.