AMD HD 6570 seriously slow

First things first. Here is my system info:

user@acerbox:~$ inxi -Faz
  Kernel: 5.17.8-051708-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.17.8-051708-generic 
  root=UUID=27a59f37-5806-4060-affc-10219f1ca022 ro quiet splash 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 
  Distro: Zorin OS 16.1 base: Ubuntu 20.04 LTS Focal 
  Type: Desktop Mobo: Acer model: Aspire X3470 serial: <filter> 
  UEFI: American Megatrends v: P01-A1 date: 08/05/2011 
  Topology: Quad Core model: AMD A6-3600 APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Fusion family: 12 (18) model-id: 1 
  stepping: N/A microcode: 3000027 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 16769 
  Speed: 812 MHz min/max: 800/2100 MHz boost: enabled Core speeds (MHz): 
  1: 803 2: 803 3: 804 4: 800 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Sumo [Radeon HD 6530D] vendor: Acer Incorporated ALI 
  driver: radeon v: kernel bus ID: 00:01.0 chip ID: 1002:964a 
  Device-2: AMD Turks PRO [Radeon HD 6570/7570/8550] 
  vendor: PC Partner Limited driver: radeon v: kernel bus ID: 01:00.0 
  chip ID: 1002:6759 
  Display: x11 server: X.Org 1.20.13 driver: radeon 
  compositor: gnome-shell resolution: 1920x1080~60Hz 
  renderer: AMD SUMO (DRM 2.50.0 / 5.17.8-051708-generic LLVM 12.0.0) 
  v: 3.3 Mesa 21.2.6 compat-v: 3.1 direct render: Yes 
  Device-1: AMD BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:1714 
  Device-2: AMD FCH Azalia vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1022:780d 
  Device-3: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 1002:aa90 
  Sound Server: ALSA v: k5.17.8-051708-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: ASUSTek 802.11n NIC type: USB driver: r8188eu bus ID: 2-5:3 
  chip ID: 0b05:18f0 serial: <filter> 
  IF: wlxfc3497323b4c state: up mac: <filter> 
  Local Storage: total: 931.51 GiB used: 10.32 GiB (1.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST31000524AS size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: JC45 scheme: GPT 
  ID-1: / raw size: 371.88 GiB size: 364.98 GiB (98.14%) 
  used: 10.31 GiB (2.8%) fs: ext4 dev: /dev/sda3 
  System Temperatures: cpu: 32.9 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: radeon temp: 24 C device: radeon temp: 44 C 
  Processes: 226 Uptime: 31m Memory: 5.51 GiB used: 1.39 GiB (25.2%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 
  Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

As can be seen, I have two GPU's, an integrated AMD HD 6530D which uses shared memory, not a great gaming device, but enough for my humble needs. The other one is a AMD HD 6570.

The problem is when I plug the hdmi cable into the 6570 hdmi port, everything is super slow, totally unusable. Can't move windows and the mouse lags behind. Had the same problem with Ubuntu, Mint and Pop! OS on older kernels, so using an older kernel might not automatically fix the problem. Also the GPU could be physically broken, who knows.

Any advice on how to troubleshoot further? Having used Linux for decades, but not a super guru, I've never tinkered with my systems, since everything has always worked out of the box with my hardware.

Since the other GPU works, I'm not in a hurry but instead of 512MB of shared memory I could play a game or two with that 2GB GPU, if it would work. Thanks!

I get 60FPS with my really unimpressive built in GPU... would be nice to have a real GPU for some light gaming.

You may need to use the AMD Proprietary drivers:

Proprietary drivers? Is there an easy way to do some diagnostics wether my GPU is simply broken? Will try the AMD drivers later.

Downloading the drivers now. Do I need to run the amdgpu-install script as root?

Downloaded the script, says Unsupported DEB-based OS: Zorin

So this type of thing is why I have used Debian stable and Ubuntu for decades... Best support, although I am no expert.

Will boot into Ubuntu and try the script from there, just to see if those proprietary drivers are the issue, then figure out what to do with Zorin.

Yes, sorry for the delay...
The installer may complain that it is Zorin, not Ubuntu... If so, the workaround is to open the release file and change the Distro name.

OK, where is the release file?

I am trying to remember...
I believe /usr/lib/os-release
The only thing to change would be ID=zorin to ID=ubuntu
This must be done as root-

sudo -i


Then - Other locations > Computer > /usr/lib/os-release

Right click the file and open in text editor. After making the change - save the document, but do not close it.
Run the AMD installer.
Once the installer is finished, revert the document back to ID=zorin - this can quickly be done with ctrl+z to Undo Changes. Then Save the file again and you can close it out.

This... Is a Pain To Do.
AMD, for all their bluster of support for Linux, never bothered to configure their installer to check the release file and instead, just supports the Main major Distros like Debian, Ubuntu, Fedora...

I was faster, I found /etc/os-release - will that work? On the terminal I use nano, sorry bout that!

EDIT: /etc/os-release worked, installing now.

Yes, it should - I just prefer /usr/lib/os-release, since /etc/os-release is a Symlink of /usr/lib/os-release

Tried to install, but it now says:

E: Sub-process /usr/bin/dpkg returned an error code

Not a very helpful error message - does that mean it utterly failed?

It may be a dependency error. I agree - that is not helpful...
Can you try:

sudo dpkg --configure -a

type or pastuser@acerbox:~$ sudo dpkg --configure -a
[sudo] user-käyttäjän salasana:     
Tehdään asetuksia: amdgpu-dkms (1: ...
Removing old amdgpu- DKMS files...

Deleting module version:
completely from the DKMS tree.
Loading new amdgpu- DKMS files...
Building for 5.17.8-051708-generic
Building for architecture amd64
Building initial module for 5.17.8-051708-generic
Error! Bad return status for module build on kernel: 5.17.8-051708-generic (amd64)
Consult /var/lib/dkms/amdgpu/ for more information.
dpkg: error processing package amdgpu-dkms (--configure):
 installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
 amdgpu riippuu paketista amdgpu-dkms (= 1:; kuitenkin:
  Paketille amdgpu-dkms ei ole tehty vielä asetuksia.

dpkg: error processing package amdgpu (--configure):
 riippuvuusongelmia - jätetään asetukset säätämättä
Käsittelyssä tapahtui liian monta virhettä:
user@acerbox:~$e code here

Sorry, some of my native language in there...

I'll try and install Pop! OS alongside my Ubuntu and Zorin, then see what magick Pop did there to get it working, if I have time...

1 Like

No problem, at all... I am one of the more ignorant type that only speaks one language fluently.

We of small nations must master multiple languages. I lived in the Netherlands for five years and everybody there spoke English fluently, German, French in addition to their native Dutch. That is the only way to survive in this world.

Installing Pop! OS now, just to see if the GPU works there, did some partiotioning, good thing it is only my test machine, should have three distros at the end of it, let's see how that goes.

My gut feeling says it is soon time to edit some GRUB files, unless Pop! does it's magick spot on.

Installing Zorin gave the option to automagically shrink the Ubuntu partition and and install Zorin along side Ubuntu, worked like a charm. Sadly, no such option in Pop!

Pop!_OS does not support dual booting directly. It uses systemd-boot and os-prober is disabled by default. I had to manually add a boot menu entry and increase the boot countdown in order to dual boot with Windows.

1 Like

Yes, I messed up. I have Xubuntu and Zorin on their own partitions, but no way to boot to them. Pop it is now.

Looking at inxi from my Pop OS, it says the driver is amdgpu. System now shutsdown nicely. But my second GPU, the Radeon HD 6570 does not play nice when I plug the hdmi cable in, screen is lower resolution and impossible to move windows or do anything.

So I suppose I'll just let it be, now time to figure out how to bring back Ubuntu and Zorin, edit some GRUB? Or if Pop did some permanent damage, I'll just install Pop! first, then Zorin, should work.

So glad I have a spare old machine to run these fun tests.

Not giving up on Zorin, it looks promising and way more polished than my Cinnamon desktop on Debian. Only disappointment is the wifi problem I had and now GPU.

EDIT: for fun, I'm now seeing what happens when I have already Zorin, Ubuntu and Pop on their own partitions and try to reinstall Zorin. What will it do?

EDIT: No luck, Zorin found Ubuntu, but not Pop! I then installed Pop firtst and then tried to install Zorin alongside it, but Zorin did not recognize my Pop! installation. Whatever, if I want to demonstrate Ubuntu or Pop to friends, I can just boot those from USB. Now doing a fresh install of Zorin, will install the 5.17 kernel for wifi drivers, then see how much energy I have left to install amdgpu drivers...

EDIT: installing Pop! for a brief period taught me that the amdgpu proprietary drivers installed in Pop! did solve the shutdown issue, but not the weird and slow behaviour of the GPU. So either my GPU is really broken, or for some weird reason even the properly installed proprietary drivers don't work.

So I'm giving up on installing AMD drivers for Zorin, thank you all for your help and support, awesome forum ,love you guys!

Also noticed that the Zorin installer is way slower than Pop!'s. Also Pop! is not available in my native toungue Finnish, so it is something I can't recommend for friends yet. Let's see how things go with Zorin from now on. If it is stable enough, I might keep it :slight_smile:


Removed the troublesome GPU. That solved the GPU issue for me. Will continue about the shutdown issue in the other thread.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.