Annoying waste of time

Things that work great out of the box are getting popular :wink:. So far it never failed me.

I usually using a Balena Etcher for creating iso boot linux. Never have problems with that. The problem is cheap pendrive. I using Sandisk and Samsung never have problem with that.

1 Like

Yes, till the day it broke.

I lost 2 USB keys to Etcher.
Both were genuine Sandisk.


I know if my pendrive was died i always used HP USB Disk Storage Format Tool.
Besides i cannot sayed nothing wrong used Balena Etcher wrote iso Zorin Lite Pro and everything working, just some a couple minutes ago.

Well I also used a Sandisk stick

SanDisk Cruzer Blade

The another white sandisk are not good the red are good Cruzer Blade.

1 Like

I love the design from the samsung one :star_struck:

1 Like

For whats its worth - i always find when it dosent work it beaause the usb had not been wiped correctly - i have got into the habit of using gparted to delete the partition on the usb and re-partition it etc so its like a brand new usb drive normally works then .


I use Mintstick for that purpose.
It comes with eraser and writer.


On linux is popsicle od something. Tested working.

I also have used Etcher with no bad effects ..... in fact my Zorin 16 Pro is installed on it .... I guess it is just the luck of the draw ... LOL ....

The USB's were wiped and installed with DOS new even tried a new SSD

Add the pop repo:

sudo add-apt-repository ppa:system76/pop

Then you can install:

sudo apt install popsicle popsicle-gtk

Remove the pop repo when finished:

sudo add-apt-repository --remove ppa:system76/pop

1 Like

Good day Folk

After trying a number of USB ISO burners I found one that works MutiBootUSB, yes I have the version 16 real disappointed so far in my display nothing as good as 15 maybe something to do with the Navida card.

The next challenge is to get the web builder program running.
thank you all for your help.
Keep safe

Maybe a new thread for this issue.

1 Like

Thanks folks for your help solved the installing issue with MultiBootUSB, graphics resolved learning to love Zorin once more.
And thank you Aravisian for you time & trouble.
Stay safe


I didn't know that Popsicle isn't in the repositories of ZorinOs. I know that it's in the AUR.

It is a POP_OS application.
Just as most Zorin Applications are not in the POP_OS repository...