Applications freeze when attempting to save a file

I just installed Zorin 16 Core on a MacBookPro (8GB RAM, Intel proc). Everything seems to work fine BUT, when I try to save a t3ext doc, both in LibreOffice and OnlyOffice, the application instantly freezes when I press "Save". I can still open other apps but the offending app stays frozen. What can I do?

Hi, and welcome!

The fact that this happens with both office writer programs makes me think this is may be related to either the document itself or something else regarding the computer you're using.

Could you confirm this issue happens with any other files, perhaps even empty onces? Are you using any additional objects like tables, diagrams, etc?

Are you saving to a odt format (native to LibreOffice) or something else like doc, docx, etc? Can you reproduce this issue by switching to another format?

Are you saving to an external drive or cloud service? If so, can you reproduce this issue when saving directly to your local drive?

Could you share the version of LibreOffice you're using? Click on the top right "hamburger" button with the three lines and About LibreOffice, should show something like this:


Thank you. It seems that the problem is with any attempt to save a file, any file. For example, I open a blank file on LibreOffice Writer, type some text and as soon as I click on SAVE (or Save as, or even Export) bam!, the application turns grey and freezes. I also tried opening a text file within a random folder in the hard disk (a file with C++ code) with the default text editor and the same happens when I go Save as. I also tried to save a webpage on Firefox. Same thing.

LibreOffice is the latest version, I installed all fresh yesterday and did the first big update of the system. Maybe a permissions issue?

So, different applications all freeze whenever you attempt to write to disk? Then, we can rule out LibreOffice out of the equation...

You said that you tried to use the "Save As" option, but when did it freeze exactly: did you ever selected the location of the file or did it freeze immediately?

Are you able to create an empty document by right-click -> New Document -> LibreOffice Writer? Don't open it, just create it on the spot and see if that works. It doesn't have to be LibreOffice, just try to create any file.
After that, try to do a few ordinary tasks: Rename a file to something else, make a copy of an existing file, move a file to another folder, etc.

If you have an external hard drive, are you able to save files to it (assuming the "Save As" option allows you to pick a location)?

You may also try to run nautilus as an administrator and see if that makes a difference, in case it is a permissions issue:


I tried these things:

Opened Terminal and did sudo apt update and upgrade, just in case.

Then openes nano (the terminal text editor), typed something, saved (Ctrl-o). It prompted to write a file name, so I did and the file was created in my personal folder.

I went to the FIle manager, saw the new file, double clicked it and it opened on Gedit. Tried save it again (in Gedit) and it froze.

Went to the file manager, made a copy of the new text file (just Ctrl-c Ctrl-v) and a copy was created.

Opened an instance of LibreOffice Writer, clicked on Open and it froze immediately.

I wrote some more stuff below while you were answering. ANyways, I'll try nautilus. Cheers

Are you able to select a file location using "Save As" at all? If you can, press Ctrl+L and type this location /run/users/1000/test.odt. This is an in-memory filesystem, which means that if you can select and save files here the issue must be with the hard drive.

In the terminal you can type journalctl -xe which one way of checking for messages generated by programs when they misbehave.
Another option is ti check the log files such as /var/log/syslog. This is a lot of output and can be overwhelming, just scroll down to the bottom by pressing G (capital G) and start reading upwards.

This is a strange issue in any case, I think it's worth checking if the ISO you used to install ZorinOS wasn't corrupted during download somehow:

There has been an issue with the xdg-desktop-portal package recently causing it to be held back. This may affect certain programs.
Please open terminal and run:

sudo apt install xdg-desktop-portal

Reboot and test saving a file.

Did this, but no effect, unfortunately.


I tried the various suggestions offered to no avail. I also re-installed Zorin anew. In summary, any time I attempt to save, save as, export, or print as PDF in any application via the GUI, the application immediately goes grey and can't do anything in it besides exiting using the context menu (right-click on the icon). Creating and saving files in the terminal is possible, though, so the problem is not with the disk.
Because my goal is to install a friendly OS so my elderly mom can use it, I'll have to try another OS, although I liked Zorin very much.

For the record, the hardware is a MacBookPro circa 2011 with Intel processor (2 core I think) and 8 GB RAM, 500GB HDD.

I'll still try a few more things before giving up. Thanks all.

I'm afraid this is a new one for me, not sure what could be the issue other than perhaps the package mentioned by Aravisian above. Just to throw a few more ideas:

  • Try to switch between XOrg and Wayland. You can do so from the login screen, clicking on the little wheel icon as in the screenshots from this other post: How to install Wayland? - #8 by zenzen

  • Have you tried ZorinOS Lite, instead? Perhaps the issue is with the desktop environment. I would load a live USB and choose the "Try ZorinOS" option to see if you can reproduce the issue then, perhaps the bug is created while downloading some updates.


This is interesting...

See, I have Two monitors, always connected on a desktop PC. I also keep modal dialogues unstickied.
It is not unusual that if I open a file and Save as, export or similar, that the modal dialogue window appears on the other monitor than the one I am using, allowing me to still view my original file before committing changes. When this happens, the O.F. darkens (backdrop class). I wonder if your modal dialgue window is opening Off-Screen causing you to not be able to see it to proceed normally.
Doing a web search, I found:

Which led to:


Thanks. I'm adding these suggestions to my to-do list. I'm now looking into a possible cause, which is issues with NVIDIA. I learned that nvidia and ubuntu are not good pals and problems are common. I tried to have Zorin switch to the graphics cArd (GeForce 340M) instead of the default intel, but it gives an error when trying to install the driver. After this the system crashed and had to boot from the USB stick. There is an option "Try or install Zoring with NVIDIA drivers", which I chose but it's been 'working' on the USB for two hours.

Looking at this, thanks. Some clues point to issues with the NVIDIA card or nvidia drivers.

You can see which you are using from Software & Updates > Additional Drivers tab.
You can switch to a different Nvidia driver from the list provided and test which works the best. The Free Open Source Nouveau driver should be listed as well.
Remember that a reboot is necessary after changing Nvidia driver.

But I would actually just check what we covered above since your description matches the idea that the popover window is appearing off screen.

1 Like

My old graphics card. (@Aravisian do you remember? The reason that led me to the forum)
MX Linux Is the only distro that supports it.

1 Like

Bingo! Inexistent second screen was the culprit. It turns out that by default the system recognizes 2 screens. When I changed it to collapse the screens into 1 the problem went away. Thanks so much!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.