Asus T100 - Error NVram is locked

Good morning. I have same this issue, I have tried to disable secure boot already, try to repair boot in live mode, and trying to repair it, I still get this same error. I have checked and tried all tips I've found in this forum, but still having the issue. Someone could help me, please? Thanks

sprunge.us/8wcLY6

Your profile states you have "Lite" edition. So assume that was Z16.3 Lite.
So are you now trying to install Z17.1 Core in its place, or alongside another OS?
Which installation option did you choose?
Did you check the SHA256 of the downloaded .iso?

Can you take a look at the pre-installation advice here: Before you install

Did you check the SHA256 of the downloaded .iso?
Which USB creation tool did you use?
(Sorry for all these questions)

chroot /mnt/boot-sav/mmcblk2p2 efibootmgr -v before grub install
EFI variables are not supported on this system.


chroot /mnt/boot-sav/mmcblk2p2 uname -r
6.5.0-21-generic

chroot /mnt/boot-sav/mmcblk2p2 grub-install --efi-directory=/boot/efi --target=x86_64-efi
Installing for x86_64-efi platform.
grub-install: warning: EFI variables cannot be set on this system.
grub-install: warning: You will have to complete the GRUB setup manually.
Installation finished. No error reported.
Error: no grub*.efi generated for Zorin OS 17.1

It appears as if your BIOS does not accept EFI / UEFI support. Can you recreate the installer with Unetbootin and try again?

The NVRam lock status - if you have a laptop with a removable battery: remove the battery and all power sources, hold the power button for a 10-30 seconds to release all the stored voltages in the board. If you have a CMOS battery with a laptop setup it's tricky but, that can be removed to help release the lock status too. Desktops are easy to get to but, laptops need a bit of work to access, sometimes.

I also have this laptop/tablet. As I understand it, this is an UEFI system. I took pics of my "bios" I am not sure why I have 2 ubuntu's on there as I only have one OS installed.

I also have the issue of locked NVRAM when I try to install Zorin 17.1 core.

I have not taken my case apart, but as far as my research has come across, there is no CMOS battery and to reset the CMOS we would have to remove the system battery. Holding the power button for 30 seconds after shut down (even tried 1-2 minutes) did not work (for me anyway).

I have successfully installed 16.3 core on my system. I did try upgrading from there but that failed as well unfortunately. Fortunately, I was able to put 17.1 on my E6430, so when I get the chance, I will be going pro with that one. Which brings up a good (for me :crazy_face: ) question. Can the pro license still be purchased for 16.3? I will have to chase that squirrel later.

But, anyway, I am going to keep 16.3 core on my T100 until a remedy comes along.

I have come across a few posts that say that there are multiple things that can cause the locked NVRAM issue with multiple fixes. Does anyone know of a possible list of causes and fixes? This would be an interesting (for me) project going through the different fixes until the right one comes along, if it does.

BTW, I contacted Asus Support and their solution was to send the laptop back to them to have Windows put back on the laptop :scream: I am not done with that avenue yet. And Best Buy said they can fix it for about $200. Not an option for me.





I could not post the 6th pic showing that secure boot is disabled.

This is my first successful (mostly) venture in the world of Linux. I am excited to see what I can do.

P.S. If something came out wrong I apologize. I do not communicate very well. And I am an avid squirrel chaser :grin:

1 Like

So, I just found something (possibly?) here:

As I am an older person who is a noob to Linux, could someone please explain to me how to do this so I can try it out on my T100?

"This finally fixed it for me: mount -t efivarfs none /sys/firmware/efi/efivars

After that efibootmgr was able to write and even plain grub-install just worked. I assume ubuntu Boot-Repair would have worked after this, but as I was already trying to install grub manually, didn't try.

But, booted with Ubuntu 22.04 USB stick, chose Try Ubuntu and then:

Mounted my Ubuntu root partition to /mnt
Mounted my Ubuntu boot partition to /mnt/boot
Mounted my EFI partition to /mnt/boot/efi (have it on separate disk)

mount --bind /dev /mnt/dev
mount --bind /proc /mnt/sys
mount --bind /proc /mnt/proc
cd /mnt
chroot .
mount -t efivarfs none /sys/firmware/efi/efivars
grub-install

reboot"

I can boot from USB and restart. However, the rest is Japanese to me. And, just like Japanese, I am trying to learn all this as I go.

Thank you in advance.