Asus T100HA audio not working

Hi guys :slight_smile: I'm new with ZorinOS and I installed it on my old 2in1 tablet Asus T100HA and everything is smooth and I love it. But I don't know how to get the audio working.
On the audio settings I see speakers but I don't know if there is any command to type on terminal to get the real driver name.
Anyone can help me?:slight_smile:

Hello, to see your audio card;

sudo apt install inxi
inxi --audio

To adjust your audeo-card

alsamixer

Press f6 to select your card

1 Like

Hi Storm, thank you for your reply.
The output of inxi --audio command is:

Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  Imaging Unit 
  driver: N/A 
  Sound Server: ALSA v: k5.13.0-35-generic 

And then on alsamixer I don't know which one I have to selected:
Schermata del 2022-03-20 12-15-27
But I think there is no driver by reading the inxi --audio command it says: "N/A".

Hello,

Check first the additional driver app for drivers. If there are any install it and reboot. If there still no sound;

sudo nano /etc/default/grub

add;
915.disable_power_well=0

to the line GRUB_CMDLINE_LINUX_DEFAULT

so it says something like;

GRUB_CMDLINE_LINUX_DEFAULT="i915.disable_power_well=0 quiet splash"

ctrl+o =save
ctrl+x =exit

reboot

Do check alsamixer afterwards.

Ok I added the line and then rebooted. Seems like nothing changed, and audio still not working :frowning:

In the picture you posted of alsamixer, try use the the arrow keys to see more more options. Eventual post some pictures of it.

I'm afraid you have one of the notorious audio card that might not work with Linux. According to the Linux hardware site - there's no driver for your card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Low Power Engine Audio

Even the latest kernel doesn't have it.








I don't know, this is not the exact name of the driver. But I can tell you that with other Linux Distro (like Mint) it works automatically, never did something to get audio working, it just works. That's why I write here because I think there is a solution, there is (almost) always a solution in Linux :smiley:

Are you using headphones or speakers with your laptop?

Speakers. I tried also with headphones, Zorin detect them but still not working

You said that it worked on Linux Mint. Do you recall which version of the kernel it used? Was it the latest version of Mint? If so we might want to try a different kernel.

@zabadabadoo might have a look at this thread.

I don't remember and I'm not a real expert of Linux so I don't know how can I check that kerniel version. Btw, I was using Linux Mint "Una" I think

You can see the "MM" label under everything int he AlsaMixer Screenshot. I had an update mute everything... no idea why... And when I went into Alsa and Unmuted everything, sound began working again.

@ohhfem Yes I have seen that card mentioned on forum before and tried and failed to help the user.
However, as Aravisian mentioned, you can see many essential sound channels marked [MM] in your alsamixer screenshots.
I would start by unmuting them one by one by scrolling accross and typing "M" to unmute.

I also found this from a websearch using "sof-bytcht rt5645 Ubuntu 20.04":

sof-bytcht
Same. That one is utterly notorious.

OK I unmuted everything and when I turn a sound on the speakers where whistling for a while even I was at 0% of volume.
But then on alsamixer I turn off that voices on the screen, and now SOUND IS WORKING ON MY ASUS T100HA :money_mouth_face:


2 Likes