ASUS USB external monitor not being recognized

Hi everyone,

I have an ASUS travel monitor (USB) that I'm trying to connect to my X1 Carbon running Zorin. For some reason, the display is not showing up in the Display settings area after plugging it in. Any ideas?

Thanks in advance as always for any and all help...

Asus supplied a driver to Linux that may not work properly. Fortunately, there is an Open Source driver:

The driver shows that it is supported for Zorin OS including Zorin OS 16:

Zorin: focal

Install and troubleshooting are included in the link. However, please ask for anything you need clarified or for more troubleshooting here for live help.

1 Like

Thank you so much, @Aravisian. :coffee: I ran the install commands in Terminal but things seem to have stopped here:

[[ Installing EVDI DKMS module ]]

Is it safe to reboot or did something go wrong?

Thank you again for your help...

I would attach the monitor while notebook switched off then boot.

1 Like

After I rebooted, the desktop looks like this:

Any ideas?

I changed the desktop wallpaper and the other default Zorin options appear to be normal. It's just the original one that I used when installing the drivers that is distorted. It's still showing those black dots whenever I revert back to that original option.

That one is Weird anyway, Hope your Problem is Solved?


Can you please clarify: Is this a new issue and the ASUS monitor is still not being recognized
Is the ASUS monitor now being recognized, but you have the graphics issue on that monitor?

1 Like

This is a new issue and the ASUS monitor is still not being recognized, @Aravisian

I also disabled secureboot and ran the post installation command, here's what came back:

sudo: ./ command not found

Try This,


No go, unfortunately. Also, whenever I hit the Windows key + S to do a search, a lot of characters in the text that shows up are missing.

What's the easiest way to roll back the displaylink install?

I ran the following command:

cd displaylink-debian/ && sudo ./

Then chose "U" for uninstall. Everything seems to be back to the way it was before attempting to install the drivers, so that's good news. I still can't get the external USB monitor to work, however, so if anyone else has any ideas I'd appreciate the help.

1 Like

Can you please post the Model of both Monitors?

1 Like

Sure, @Aravisian:

ASUS MB169B+ (I'm only trying to connect one external monitor to my X1 Carbon at the moment)

I understand, now. The ASUS driver conflicted with the Lenovo driver.
I was quite puzzled.

That also makes this a bit more tricky... The trouble is the ASUS Monitor, not the Lenovo machine.
Due to ASUS attempting to retain certain aspects of Proprietary globs, they only released certain drivers to open source, not the full package.

If your primary machine was also ASUS, this would have been easier.

In this case, you may be able to handle both monitors by using a kernel that includes the patch for ASUS as well as the drivers for Lenovo.
Can you please run

uname -a

and relay which kernel you are on?
We need to see about getting you above the 5.15 kernel.

1 Like

Hi @Aravisian, here's the output:

Linux ThinkPad-X1-Carbon-Gen-8 5.4.0-125-generic #141-Ubuntu SMP Wed Aug 10 13:42:03 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Have you been running your regular Zorin OS updates and Upgrades?

sudo apt update && sudo apt full-upgrade

Recommend "full" upgrade to ensure essential files that require overwriting be overwritten.

1 Like

Yes, I've been running the updates whenever prompted. Just ran the update command in Terminal and got the following output:

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Can you please reference this post in regards to installing a higher kernel?

1 Like

If I use the TuxInvader repository, should I change 5.19 in the command to 5.4?

sudo apt update && sudo apt install -y linux-generic-5.19