Asus Zenbook Pro Duo 2nd screen display issue

Im using Asus Zenbook Pro Duo laptop. As well I cannot change brightness on eDP-1-1 always stays full bright

Linux zorinos 5.4.0-66-generic #74~18.04.2-Ubuntu SMP Fri Feb 5 11:17:31 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I have 2 internal display and 1 HDMI monitor.

Since I like to see scaled display, I have set my top screens to be 1080p and while the bottom display wont change to any resolutions other than 4K.

If I try to set the bottom screen to 1920x550 it will display multiple screen at bottom

THE ISSUE →

╰─ xrandr                                                      ─╯
Screen 0: minimum 8 x 8, current 7680 x 3280, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  59.94    50.00
   1680x1050     59.95
   1600x900      60.00
   1280x1024     75.02    60.02
   1280x800      59.81
   1280x720      60.00    59.94    50.00
   1024x768      75.03    60.00
   800x600       75.00    60.32
   720x576       50.00
   720x480       59.94
   640x480       75.00    59.93    59.94
eDP-1-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   3840x2160     60.00 +  59.98    59.97
   3200x1800     59.96    59.94
   2880x1620     59.96    59.97
   2560x1600     59.99    59.97
   2560x1440     59.99    59.99    59.96    59.95
   2048x1536     60.00
   1920x1440     60.00
   1856x1392     60.01
   1792x1344     60.01
   2048x1152     59.99    59.98    59.90    59.91
   1920x1200     59.88    59.95
   1920x1080     60.01    59.97    59.96*   59.93
   1600x1200     60.00
   1680x1050     59.95    59.88
   1600x1024     60.17
   1400x1050     59.98
   1600x900      59.99    59.94    59.95    59.82
   1280x1024     60.02
   1440x900      59.89
   1400x900      59.96    59.88
   1280x960      60.00
   1440x810      60.00    59.97
   1368x768      59.88    59.85
   1360x768      59.80    59.96
   1280x800      59.99    59.97    59.81    59.91
   1152x864      60.00
   1280x720      60.00    59.99    59.86    59.74
   1024x768      60.04    60.00
   960x720       60.00
   928x696       60.05
   896x672       60.01
   1024x576      59.95    59.96    59.90    59.82
   960x600       59.93    60.00
   960x540       59.96    59.99    59.63    59.82
   800x600       60.00    60.32    56.25
   840x525       60.01    59.88
   864x486       59.92    59.57
   800x512       60.17
   700x525       59.98
   800x450       59.95    59.82
   640x512       60.02
   720x450       59.89
   700x450       59.96    59.88
   640x480       60.00    59.94
   720x405       59.51    58.99
   684x384       59.88    59.85
   680x384       59.80    59.96
   640x400       59.88    59.98
   576x432       60.06
   640x360       59.86    59.83    59.84    59.32
   512x384       60.00
   512x288       60.00    59.92
   480x270       59.63    59.82
   400x300       60.32    56.34
   432x243       59.92    59.57
   320x240       60.05
   360x202       59.51    59.13
   320x180       59.84    59.32
DP-1-1 disconnected (normal left inverted right x axis y axis)
DP-1-2 connected 7680x2200+0+1080 (normal left inverted right x axis y axis) 340mm x 100mm
   3840x1100     60.02*+  48.02
   1920x550      60.06    48.08
  1680x1050 (0x1c1) 146.250MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock  65.29KHz
        v: height 1050 start 1053 end 1059 total 1089           clock  59.95Hz
  1280x1024 (0x1c4) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1280x800 (0x1c5) 83.500MHz -HSync +VSync
        h: width  1280 start 1352 end 1480 total 1680 skew    0 clock  49.70KHz
        v: height  800 start  803 end  809 total  831           clock  59.81Hz
  1024x768 (0x1ca) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x1cc) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x1d1) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

Have you tried setting the bottom screen resolution to 3840x2160?
Have you set your Grub default with “nomodeset?”
Are you using Nvidia-driver-390?
In your boot manager, are you set to AHCI? (Are you dual booting into Windows?)
Do you know if your Asus screenpad is 2.0 or 1.0?

On brightness, please see here:

1 Like

thanks for reply.

  1. yes. setting resolution to 3840x2160 works fine, but same doesnt take 200% scale, since all others are using 1080p with 100% scale.

  2. dont know about nomodeset

  3. I’m using latest Nvidia driver 450.102.04

  4. Yes, dual booting, had toggled AHCI so that I was able to install Linux.

  5. Screenpad 2.0 (Feb 2020)

Screenpad 2.0 is Better supported, so that is good.

The “nomodeset” setting is due to Nvidia Graphics being a bit balky on the unusual Screenpad design. I am not sure if you need it or if it will help you, honestly.
If you open a terminal and run

sudo nano /etc/default/grub

Then tab or Arrow key down to this line

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

Change to

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset”

This will allow the machine to boot without the Graphics Mode set.

The 100% 200% scaling may be an issue… that is an unusual setting you are trying to run on an already unusual machine.

1 Like

@Aravisian I installed this https://github.com/udifuchs/icc-brightness as you shared above, brightness is working now, but only on screenpad screen, not on top lid laptop screen. even if this works on main screen, Im more than happy to disable screenpad screen forever.

I don’t know how much help I can be. I have never used the Asus Zenbook and that is quite an interesting set up…
I prefer to give some kind of reply over no reply at all- I may point something out that another person had not considered and help point the reader in a new or right direction. That is not the same as knowing a lot of fixes though…
I think the 1 / 2 scaling is a bit trickier. That screenpad appears to be a touch screen pad - I am not sure, but it seems less like a Full Functional Screen and more like a Drawing pad that shows information on it rather than being an opaque touchscreen that relays the information to the monitor.

1 Like

yes both screens are touch screen. Bottom one is LCD and top one is LED.

on windows I use bottom one as drawing pad.

My eye are getting stressed during night working, since main laptop screen is always full bright.

This link to a bug report suggests that not using the Nvidia driver but instead, only the integrated graphics helped some users:

If you want to disable touchscreen, you can check your xinput

cat /usr/share/X11/xorg.conf.d/40-libinput.conf

Look for InputClass Identifier “libinput touchscreen catchall”.

If present, open a new terminal and enter

xinput

Look here for your Touchscreen and look to the right for something that looks like “id=4” (id=NUMBER) and note that number.

Then in terminal put

xinput disable (NUMBER)

Where (NUMBER) is the id=(NUMBER) you referenced above. For Example, if the screenpad is id=4, then it would be

xinput disable 4

1 Like

my laptop doesnt have option in BIOS to disable nvidia card.

I do not use Nvidia so you may know better than I, but I believe running Nvidia-settings should enable your to choose which graphics drivers are run.

there is a stetting, but switching to Intel disables HDMI output.

Ah, this must be that your HDMI port is in the Nvidia card. Do you have an HDMI port in the integrated graphics port (Two HDMI ports)? Or is there only one HDMI port?

has only single HDMI port on laptop

1 Like

It may be related to your two GPU issue - Asus Zenbook Laptop Brightness not changing - did you ever try those last steps I suggested?

My laptop doesn’t support changing BIOS mode, it doesnt have that feature.
I tried changing settings from nvidia to intel only via Nvidia server, but the issue persists.

@carmar followed this: HybridGraphics - Community Help Wiki

grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noveau.modeset=1"
updated and rebooted.

Getting below error. Hence I finally updated grub to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noveau.modeset=1 i915=modeset=0"

╰─ sudo ls -l /sys/kernel/debug/vgaswitcheroo/switch           ─╯
[sudo] password for ajinkya:
ls: cannot access '/sys/kernel/debug/vgaswitcheroo/switch': No such file or directory
╰─ sudo grep -i switcheroo /boot/config-*                                             ─╯
/boot/config-5.4.0-65-generic:CONFIG_VGA_SWITCHEROO=y
/boot/config-5.4.0-66-generic:CONFIG_VGA_SWITCHEROO=y

still brightness key wont work, it just works for DP-1-2 but not for eDP-1-1

One of the suggested solutions on my post was Bumblebee. Can you please try it and let us know if that helps?

1 Like

I managed to disable the Intel card via grub.

But still the same issue. Can you tell me what is Bumblebee ? what is Nvidia prime ? Im bit afraid to install it without know it.

As I understand it, Bumblebee allows NVIDIA and Intel GPUs to function together by allowing NVIDIA to do the rendering.
But given that you’ve disabled your Intel card and still having the issue, I doubt installing Bumblebee will help.