Attempting to hibernate results in screen going blank then back to normal, without powering off

First I followed this guide on how to create a swap partition using Disks (I ran into an issue where it said the partition was in use, so I booted from a USB and did that step from there).

It didn't work, so I followed this one on creating a swap file from a partition then this one on enabling hibernation, putting 18gb as the swap size (my RAM is 16gb)

None of them worked. The same thing happens after all of them, whether from a command or a GNOME extension: screen goes black for a few seconds then turns right back on to where it was; the laptop doesn't power off.

I've been at this for a week now and at my wit's end; if anyone has a mere suggestion please let me know.

Here's some info that might be of help:

Lenovo Ideapad 1i 15"
Linux gibby-ideapad-1-15iau7 5.15.0-69-generic #76~20.04.1-Ubuntu SMP Mon Mar 20 15:54:19 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

  • Info

CPU: 6-Core 12th Gen Intel Core i5-1235U (-MT MCP-)
speed/min/max: 498/400/4400 MHz Kernel: 5.15.0-69-generic x86_64 Up: 2h 01m
Mem: 2682.9/15725.6 MiB (17.1%) Storage: 465.76 GiB (25.9% used) Procs: 327
Shell: bash 5.0.17 inxi: 3.0.38

  • Drives:

Local Storage: total: 465.76 GiB used: 120.56 GiB (25.9%)
ID-1: /dev/nvme0n1 vendor: Transcend model: TS500GMTE110Q size: 465.76 GiB

  • Machine:

Type: Laptop System: LENOVO product: 82QD v: IdeaPad 1 15IAU7
serial: <superuser/root required>
Mobo: LENOVO model: LNVNB161216 v: NO DPK
serial: <superuser/root required> UEFI: LENOVO v: JKCN33WW
date: 09/26/2022

  • Upon entering systemctl status systemd-hibernate.service, terminal returns:

systemd-hibernate.service - Hibernate
Loaded: loaded (/lib/systemd/system/systemd-hibernate.service; static; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2023-04-20 11:46:00 +03; 1min 23s ago
Docs: man:systemd-suspend.service(8)
Process: 5686 ExecStart=/lib/systemd/systemd-sleep hibernate (code=exited, status=1/FAILURE)
Main PID: 5686 (code=exited, status=1/FAILURE)

Apr 20 11:45:58 gibby-ideapad-1-15iau7 systemd[1]: Starting Hibernate...
Apr 20 11:45:58 gibby-ideapad-1-15iau7 systemd-sleep[5686]: Suspending system...
Apr 20 11:45:59 gibby-ideapad-1-15iau7 systemd-sleep[5686]: Failed to suspend system. System resumed again: No such device
Apr 20 11:46:00 gibby-ideapad-1-15iau7 systemd[1]: systemd-hibernate.service: Main process exited, code=exited, status=1/FAILURE
Apr 20 11:46:00 gibby-ideapad-1-15iau7 systemd[1]: systemd-hibernate.service: Failed with result 'exit-code'.
Apr 20 11:46:00 gibby-ideapad-1-15iau7 systemd[1]: Failed to start Hibernate.

Something is interrupting the hibernation and waking the machine back up before it completes.

Can be the power-settings in the bios such as s3 settings, if you have wake-on usb enabled sometimes other devices can wake the machine such as printers.

Or could be an application or service running on your install. I hav heard of nvidia on-demand profiles causing issues with hiberantion on both linux and windows. do you have an nvidia card? if so, try performance or intel profiles and see if that helps

1 Like

I don't have any devices connected; disabled everything in BIOS anyway, still didn't work.

My graphics card is an Intel one, no nvidia at all.
I checked processes in system monitor; nothing besides system processes.

I really have no idea why this won't work.

With an exacerbated sigh I'm happy to inform the void that I finally got it to work. God, that was a painful week. Posting the solution if anyone is facing the same problem:

Follow the instructions here, word for word. I have 16 gigs of RAM, and put 20 gb for the file size.

But first make sure you remove the swap partition if you messed around with that; I dont know if there's an easier way but I booted a live USB (any linux distro with Disks will work, including Zorin - I had Mint laying around), open Disks, there should be a partition called swap (if there isn't then this isn't necessary, just follow the link above), remove it, then click on the partitions immediately touching it, then the gears & expand it to "swallow" the formerly-known-as swap partition.
Then do sudo nano /etc/default/grub and delete whatever additions you made, then the same for sudo nano /etc/initramfs-tools/conf.d/resume.
Finally do sudo update-grub then sudo update-initramfs -c -k all. Now you're good to go to follow the instructions in the above link. Again this is only necessary (maybe it isn't, but do it anyway) if you messed around with this hibernation stuff like I did. Good luck.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.