Audio and video breaks, application freezes , screen stuck

Hello there,
I recently installed Zorin OS. I have Intel i5 6th processor and AMD Radeon R5 M330 graphics card. There are few problems that i have

  1. First of all when I run applications in terminal using my dedicated GPU the application takes much longer time to open and freezes after it opens. I have to forcefully shut down. I run VLC on DRI_PRIME=1 and then when i played video it would show teared screen of green and white.
  2. When I play video with my reqular graphics (with vlc, parole or in my browser) it breaks in between sometimes and skip some seconds.
  3. When I open 3 or 4 programs at a time my desktop gets stuck freezes and i have to shut down forcefully.

Can anyone help me?
Thank you.

Which version and flavour of ZorinOS did you install e.g. Z15.3 Core/Lite etc, Z16 Core Beta?
Are you dual-booting alongside Windows?
How did you go about installing Zorin e.g. Something Else method?

Have a look at this checklist, (especially disable Secure Boot and Disable Fast Startup).

Another question: What video card do you have?

Have you set Software Updater to pint to "Main Server" instead of a country server?
Also check for Additional Drivers.

Assuming you have Z15.3 which is based on Ubuntu 18.04. I did find this if needed:

I have AMD radeon R5 M330 and amdgpu-pro dont work on my pc.
I am using HP-Notebook
Processor: Intel i5
Graphics as i mentioned
I have installed zorin OS lite latest version
I am using it since 2 days

My servers are on main servers and I didnt find anything on additional drivers.

OK so you have Z15.3 Lite and AMD radeon R5 M330 and amdgpu-pro.
You can have a look at the link I included in my previous post to obtain graphics drivers. Just read Ubuntu 18.04 for Zorin 15.3 in that case.

Maybe others on here @Aravisian @StarTreker may offer more help re your graphics problems.

Can you add this repository in terminal:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Then update and run:

sudo apt update

sudo apt full-upgrade

Reboot and test.

I had done that before. I forgot to install some of codec. I installed all and now its working fine. Thank you all for your resoponse.