Audio issues


sudo add-apt-repository ppa:ubuntu-x-swat/updates

I couldn't recall the PPA off the top of my head, so I did a quick google search and of course the first Google Hit was the wrong information...

1 Like

It should be updates as what the shell is saying I guess... I'm going for that

@Aravisian still black screen, black as my day is being now :smiley:

Maybe this can do something?

From the recovery menu - you will see an option for


I would say go ahead and try that...

You mean go ahead with the fsck or the reinstallation guide?

I would try the reinstallation guide first, then the fsck if that still does not work.

I will try tomorrow. My doubt is that his problem seems to be different since he was able to open a tty (I'm not), so I'm wondering wheter his boot process was ok.
The thing I don't get is why putting an option that literally breaks the system up...

It shouldn't and normally doesn't.
And the repair steps we tried above really should have worked. I have never seen them not work.

I am wondering if it is due to the 4070 card.

What do you mean with "due to the 4070 card"?

Also, one thing I forgot to mention: during the "recovery" there were two kernel versions I remember I could boot with (both normal and recovery): one was the 5.15.0-84, the other one was 5.15.0-83. I followed your steps on 84. Maybe this was a mistake? I don't know where to smash my head... Since I have removed Windows and past distros, I cannot afford to lose anything and I'm kinda scaried..

The Nvidia 4070 is a pretty new card.
You might try going back into Recovery Menu, enabling networking, then installing a Newer Kernel.
A Kernel is a large grouping of hardware drivers.

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

Once that is done... we get to repeat the above.
This is to ensure that the Graphics Drivers are properly synced with the kernel module:

sudo apt remove --purge '^nvidia-.*'

sudo apt clean && sudo apt autoremove

sudo ubuntu-drivers install

Once all that is done, there is One More Thing you might do...

sudo nano /etc/default/grub

Arrow key down to "quiet splash" and add teh nomodeset grub parameter
It should look exactly like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Tap ctrl+o to overwrite, then the enter key to save current configuration. Tap ctrl+x to exit the editor.
Proceed back out of the Recovery menu and try a normal boot...

1 Like

I do have the 1660, not the 4070

1 Like

So, just to know how to proceed when I go back home:
1- desktop reinstallation guide
2- if 1 doesnt work, fsck
3- if 2 doesnt work, your last procedure

Am I right?

I was wondering, isn't there a way to just put my system back as it was before the driver switch?

I really could have sworn that I saw a post from you that said you had 4070... Obviously, I am mistaken. And I see in you Nvidia-smi output that you have 1660.
Let's try just performing this step for now:

Alright, I will try this afternoon.

Moreover, I found another guy who had a similar problem and this was the solution, do you think it is viable? (the first point was just accessing a terminal which I'm already able to do from the recovery)

2. Uninstalling the wrong Nvidia driver

I used the command provided by Marmayogi to uninstall the incorrect Nvidia driver:

sudo apt-get purge nvidia*

The next time I rebooted Ubuntu, I was able to access the login page and GUI in ultra low resolution, like before I installed the wrong Nvidia driver.

3. Installing the correct Nvidia driver

Here I followed the instructions provided by Marmayogi in his comment to my question, except for the installation command of the Nvidia driver which was incorrect as it has changed (see the answer by Kerry Kobashi in this post for details):

  1. sudo add-apt-repository ppa:graphics-drivers/ppa
  2. sudo apt-get update
  3. sudo apt-get install nvidia-driver-410 (this is the new command, also check version number of driver first!)
  4. Reboot.

Another question I have is: since there are two kernel versions on the boot options, is it possibile that I'm running a wrong one?

Sorry for all of this, but I'm having a bit of panico :sweat_smile:

It is not likely that you are running the wrong one.
You can test running either one to see if you get different results. IF you do, we can lock that kernel in so that you do not have a repeat of the issue.

Yes, this is a Viable Potential solution.
We have tried pretty similar above already... But it may be that specifying the 410 driver may make a difference.
For the 1660, I would have aimed for the 470 driver.

I understand completely. Often, I get a bit of panic while trying to help other members on the forum. But as bad as it sometimes looks, it usually gets sorted out and resolved. having to Wipe and Reinstall is a rare end result.
I wish I hadn't said that, now... Probably jinx the whole thing...

For the driver version, it specifies to check the number.. And I think I'll try with the 535 since it was working :sweat_smile:
I will first try with the nomodeset, then with this guide, and then I will see... Hoping I will never reach this point

@Aravisian I'm in!!! I've booted from the other kernel (-83) and, even if I got the same errors mentioned before, I'm finally in my Desktop. However... I think with no drivers, since it feels like 200x200px res. How should I proceed?


even if it seems that I'm using the drivers, I cannot change my resolution


Have you tried the 470 (Proprietary) driver?