Balena Etcher error

This morning I downloaded "Zorin-OS-16-Pro-Lite-64-bit.iso". seemed to go fine, no errors.

I just tried three times to make a bootable USB with Balena Etcher, following the official installation instructions (that worked fine for me in the past). I keep getting this error after it finished flashing the drive and verifying the files, just as it seems to have finished at 100%:

I used Gparted to reformat the USB disk the second time in case that had been an issue.

Is there any easy way to check if the iso is corrupted before I redownload it? (It takes quite a while to download.). Thanks!

In spite of what is recommended in the official tutorial, the consensus here is against using Etcher.

Much people damage their USB memory because of that.
I use Mintstick for creating a bootable USB myself.


There are several times on this forum where I have seen to NOT use the Balena Etcher. If using Windows you can use netbootin. If you are using Linux you can use Popsicle. To check if your download is correct you need to use a program to do a checksum. The checksum is on the same page as where you click on download button. The checksums are at the bottom of the page.


There was no file size/checksum for me, this is the full download page:

Go to this page:


Thanks - I put that figure into Popsicle and it went green, so I assume all is okay with the iso. Will try again using Popsicle. Cheers!


You could check the SHA256 checksum. To check it first open up a terminal and then change the directory to the directory or folder which contains the .iso file. To do this enter cd ~/example/path/ in the terminal and replace example/path/ with the path to your file. This should not include the file, it should only have the folder in which it is contained in. Then type sha256sum "your-file.iso" in terminal and replace "your-file" with the name of the .iso file. Compare the checksum obtained with this:

The checksums are at the end.


Thanks for this detailed explanation, Jeslin :heavy_heart_exclamation:
Come to think about of it, I was so eager to try it out and I forgot to do this checksum :sweat_smile: myself.
But luckily all went well :slight_smile:


Well thought about installing 16 Lite with an iso. But then I changed my mind and decided to install it in my core version. I checked for it and couldn't find a package named zorin-os-desktop-lite. That is probably because I didn't do sudo apt update and sudo apt upgrade. So now I am in the process of sudo apt upgrading. It will take some time.

Or am I wrong and I don't need the sudo apt upgrade? I am not sure if that is the right package name. Last time I asked, Aravisian told me that it was what I needed to do to install zorin os 16 lite in my core.

1 Like

Popsicle worked fine from the same iso. I'll use that in future. Many thanks everyone! Not to try Lite Pro 16 when I get the time - very excited about Xfce. Gnome looks nice enough, but there are all sorts of small irritations, and things that can't be tweaked but where I don't like the default option. Interesting times! :slight_smile:



sudo apt install zorin-os-lite-desktop

1 Like

Umm... evrything went well except for the fact that it messed up my touch-pad scroll speed. I tried adjusting it but it did not work. Looks like I will have to get that fixed. It also affects my old xfce. :expressionless:

1 Like

Well, yeah... because it includes the Zorin Configurations, dockbarx and so forth.
I mean... You wanted to install it.
I figured you had a reason and knew what you were doing.

The XFCE you were running is the Same System and Same Capability.
(Sidenote: You are better off reconfiguring Zorin Desktop to your liking - I wouldn't recommend removing it to try to fix the issue. I remove dockbarx, right off, though...)


@Jeslin, how can you check multiple files in a folder ? In windows i had a .md5 checker. How can i do this in linux ?

Good day Folks

My issue began with a rebuild project, could and cannot install a Web Builder application 64-bit OS.

Getting to the bottom of the pile trying to find a solution, my thoughts were to update the OS to version 16.

Purchased and downloaded the Pro version had real problem with getting Belena Etcher working , overcame that issue burnt the image onto a 32 Gb San-disk.

Came up with the error illustrated by a previous contributor.

A long walk my thoughts were to burn a DVD, but the pro version is too big – downloaded the β€œLite” version burnt a DVD using Brusero, same error shows up.

The DVD will not launch properly either

As long as you are already on Linux, you can use Popsicle, its light weight, its simple to use, and has a built in hash checker.

If your still on Windows, well, you have the choice of Rufus or Unetbootin. Just don't use Balena Etcher, unless you want to etch your USB drive into its tombstone.

FrenchPress I tried to use your link above but it said page can not be reached ... ????

1 Like

Try this one:

1 Like

Nope same results ....

You can do something like this sha256sum *.ods *.txt *.odt. This will check the sha256 sum of all the files in folder or directory with the extension of .ods, .odt and .txt. You can also type in the name of individual files and the separate them with a space between them like this sha256sum 1.txt 2.odt. Same works for md5.