Battery not recognized Zorin OS 16 Core

I am facing exactly this same problem. I had bought a new Windows 10 Acer laptop, and removed the preinstalled Windows and replaced it with Zorin OS 16 Core. Now I am seeing that my battery is not charging. I had immediately replaced Windows with Zorin, so I won't be able to tell whether it had been charging on Windows. I went through the list of steps that Aravisian has suggested and I found that I had enabled UEFI secure boot earlier when I was facing an error "No bootable device found", and as the tutorial had said that it doesn't matter whether I left it enabled or disabled, I had chosen to keep it enabled. But as per Aravisian's answer, I have disabled it now. I also found that I had the same error as Catty when I tried executing the nautilus command, but this following directory is present:
/sys/class/power_supply/BAT1/
and I can see capacity files in that directory. But my taskbar battery status is still now stuck on "Estimating.." and when I go to the power settings, it shows Charging, but the percentage remains at 0%. Please help me. I specifically want Linux on this machine and thought that Zorin would be a good modern distro to use. But is it unusable?

This suggests that the software is working, but currently is not making heads or tails of the battery.
Calibrating it would be your best bet.

1 Like

If you leave the laptop running whilst connected to mains power for some hours, when you disconnect the mains power, does it run from battery at all?

1 Like

Hi Aravisian, but the excerpt which you gave is specifically asking me to "charge it as high as it will go, then run it until it dies". Problem is, I can charge this laptop for hours, but the battery indicator is persistently staying at 0%, and once I disconnect the charger, the laptop is shutting down instantly. There is no runtime for the laptop without being connected to a charging socket.

1 Like

No zabadabadoo, it isn't running at all on battery if I disconnect it from the power socket.

In that case, this sounds mechanical to me.
Software issues may cause an improper reading of the battery discharge rate- but it won't prevent the battery from charging.

1 Like

Ok Aravisian, thanks a lot for the help. I just wanted to exhaust any software related problems before taking it to a hardware store to get fixed. Pity, though, since this is a new laptop. Don't know why it's behaving like this out of the box.

In searching, I just found this:
https://jcoterhals.medium.com/wont-your-linux-laptop-charge-when-the-battery-s-drained-completely-this-may-fix-it-3dd7db3e8fd5

You are right to exhaust software possibilities first...
I was thinking of Linux Software... BIOS software did not occur to me...

Hi Aravisian, I tried finding the Flexicharge option in my BIOS. But it's not present there. But I also tried to google other options, including this:

But I don't have any Power options also in the BIOS where I can disable the built-in battery.
I also found this:

But holding down the power button for even a full minute did not change anything. The last thing I will try is to shut down the laptop and leave it charging overnight and then see if it starts without being plugged in. If not, I will be taking it to some hardware store, since as I am seeing in the forums, the official help centres don't actually help if they find that I have replaced the Windows with Linux.

1 Like

I am a bit concerned if you have a Lithium battery which has been completely discharged for some time. They do not like that.

1 Like