Black screen after "An error occurred, please run package manager"

Hi, I tried everything on this forum, at this point I would appreciate some help. I am running Zorin since December last year, all was fine generally speaking. The last days I got a red balloon near the clock with this message:

I applied everything from it, the balloon disappeared, I restarted Zorin and now it's a black screen after the PC is booting. I can see Zorn's logo and after that, all is black and remains like that. I tried from safe mode:
sudo apt install --reinstall zorin-os-desktop

Thinking somehow my desktop was removed, to no avail. What can I do now to find out what's happening?

By tapping the esc ot tab key after the motherboard splash screen, are you able to see the Grub menu?
Select Advanced Options for Zorin, then select an Earlier Kernel to boot up from and test if you boot into a black screen.
Can you also please relay what Graphics card you are using.

Yes, I have Zorin with Linux 5.13.0-40-generic and, both return black screens proceeding with any of them.
I ran safe mode-> root->lspci and I see: VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09).

Are you saying that you are able to boot into Safe Graphics?
What do you mean by Safe Mode?

Apologies for the confusion. I meant this screen:
I go to root there and write my commands.

Ah, recovery prompt.

In that same recovery menu, can you Enable Netowrking, first. Then back to the recovery menu and Drop to Prompt

sudo apt update

sudo dpkg --configure -a

sudo apt dist-upgrade

sudo apt clean && sudo apt autoremove

On the autoremove - Check what is going to be removed. Ensure no essential packages. If any doubts, please ask here.
Once the above is run, please try booting up normally and test...

Cool, I reached to the last step and it asks me this:

Looks safe... If it were me, I would click y on that.

If you recently removed a QT application... that may relate to this issue. It is up to you if you want to dive into that and suss that out if this still does not work.

It's still blank. I removed Oracle Virtual Box, Chrome, and Vivaldi from what I saw after I ran the commands from the link from my first message, these ones:

At this point, not sure what to do to proceed further.

Let's go ahead and try nomodeset... just to know...
Back in the Recovery Menu - Drop to Prompt

sudo nano /etc/default/grub

Arrow key to the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the nomodeset parameter to make it look like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
Tap ctrl+x to exit - then the y key to say yes to save, then the enter key.
Now, in the prompt, run

sudo update-grub

Try a normal boot...

Still no luck. Just to double check, I saved that file with this parameter:

Then updated grub:
Then rebooted, it still goes to a black screen :man_shrugging:

Let's revert back to how it was...

sudo nano /etc/default/grub

Remove the nomodeset... ctrl+x, y, enter...

sudo update-grub

I'm getting stumped.
You already reinstalled the desktop - which would include GDM3 and Gnome-Shell.

You are using Intel Graphics.

You cleaned apt, autoremoved and reconfigured dpkg...

Only other thing I can think of is any corrupted user configuration:

sudo -i

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bkp


mv ~/.config ~/.config.bkp

mv ~/.local ~/.local.bkp

mv ~/.cache ~/.cache.bkp

Hope there's no typo

You did not exit after the first command.
The .config, .local and .cache are in Home Directory, not Root.

As far as the first root command failure- I am at a loss. the xorg.conf file should be there... it is present on mine...
How much space is free on that drive?
How much Root space is free?

Not sure what to write exactly regarding home and root

Elevate to root:

sudo -i

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bkp

Exit Root Terminal:


Proceed in Home Directory:

mv ~/.config ~/.config.bkp

mv ~/.local ~/.local.bkp

mv ~/.cache ~/.cache.bkp

Maybe the Recovery Prompt only logs in on Root...
Try the Change Directory Command first. Change $USER to your actual home user name:

cd /home/$USER

mv ~/.config ~/.config.bkp

mv ~/.local ~/.local.bkp

mv ~/.cache ~/.cache.bk

For the First command with the error "Is not a directory" - this makes no sense to me. Let's come back to it later:

mv renames files or moves them to a different directory. If you specify multiple files, the target (that is, the last path name on the command line) must be a directory. mv moves the files into that directory and gives them names that match the final components of the source path names. When you specify a single source file and the target is not a directory, mv moves the source to the new name, by a simple rename if possible.
If a destination file exists and you do not have write permission for it, mv prompts with the name of the existing file. If you answer y or yes, it deletes the destination and then moves the source.
If the file being moved is a sparse file and the file system to which it is being moved does not support sparse files, mv warns that the resulting file will be larger. If the -i option was also specified, mv asks you if want to expand the file or skip it.

mv -- rename and move files and directories.

Am I still doing something wrong in here? :grinning_face_with_smiling_eyes:

Your Username on your computer is not $desktop is it?