Black screen at Live USB + regular install attempt

I have a Lenovo C930 with a 4K screen that I want to use as a dual boot machine with windows and linux. The eventual goal is to migrate over to linux so I can finally give up on winblows. The journey however is not going smoothly, literally nothing has worked on this install, even the attempted recovery of said laptop after the first install attempt failed repeatedly...

The first problem was when I tried to boot from the USB, whatever option I selected lead immediately to the black screen of doom™ This however was solved on the live USB by a tip from another user on this forum who suggested I edit the installer to force a 800*600 resolution.

After that the installation went fine, or so I thought. I rebooted the machine, removed the USB when prompted and immediately received round 2 of the black screen of doom.

Now under the install attempt with the USB key, I tried all of the suggestions here on the forum to no avail (until the last tip about the resolution) however with the full install, I have no interface to select anything with. It seems to be a genuine black screen with no information whatsoever about what is actually happening.
When I removed this installation, I was left with a Grub menu that was so small, I literally could not do anything with it, just a few microscopic lines of text at the top left and no amount of wrangling with various guides for repairing the bootloader to windows worked. Even the windows install media failed at every attempt to repair, reinstall or basically do anything at all useful :frowning:

What I want to know in this thread is, can somebody explain what is actually causing this problem? I tried this on another laptop a few years ago and it worked flawlessly, the only reason I stopped using it was because the laptop broke and got sent away for a refund. I would dearly love to daily drive this OS for a bit, but so far I'm utterly lost as to what steps to take to get past the black screen...

Can you please pop open a terminal with ctrl+alt+t and

sudo lshw -c video

and relay the output here?


zorin@zorin:~$ sudo lshw -c video
description: VGA compatible controller
product: UHD Graphics 620
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=2560x1440 visual=truecolor xres=2560 yres=1440
resources: iomemory:2f0-2ef iomemory:2f0-2ef irq:141 memory:2ffa000000-2ffaffffff memory:2fa0000000-2fafffffff ioport:3000(size=64) memory:c0000-dffff

I should point out that the resolution there seems to be off, I tried setting the resolution to half of 4k briefly so it was easier to work with while trouble shooting but it just resulted in my laptop "zooming in" rather than changing the actual screen resolution so all of my windows ended up stuck off to one side in no mans land ^^

What about changing the Refresh Rate, instead? Have you tried 3200×1800 resolution?
I believe that @StarTreker uses a 4k monitor or 4k TV connected; and may be able to provide assistance on that, too.

This is interesting as it is the Intel card.

Could be down to the fact that there is a problem with this graphics chip and Ubuntu 20.04 on which Zorin 16 is based - apparently fixed with Ubuntu 21.04:

How Zorin will cater for this I don't know.

That would be on the kernel and Zorin OS is using the 21.04 kernel.

As I understand it a lot of issues can happen with the Hardware Kernel (suffixed hwe) which can have major issues. What if that was removed as stated in a similar post you answerd? :wink:

1 Like

Yeah there is no discrete graphics on this particular model, I needed it to be useful for Uni, not something that could distract me with games lol

The refresh rate is something I haven't changed or considered changing either, think that would help?

1 Like

I think it falls well in the realm of possibility.

well in reducing the resolution to 3200x1800 it also changed the refresh rate from 60.01 to 59.94, I'll reinstall the OS and see if that has any effect. Hold my beer..

though I should point out that this is the live USB environment, I've never gotten the OS to boot without the USB so if i reinstall this after changing the settings while booted from the USB, will that carry over to the installation?

1 Like

So the install just ran exactly as before and as soon as I removed the media and tried to reboot it took me to the OS select screen (Zorin, Zorin advanced, Windows, UEFI Settings) which was in excruciatingly small text. Clicking Zorin results in the black screen, Zorin advanced results in 2 options Zorin (version number) and Zorin (version number) Recovery Mode. Neither work, recovery mode display initializing ramdisk in tiny text in the top left but even if I leave it for minutes, nothing happens.

A few things we can try...
Boot into your BIOS Settings. Move to the Security tab and check if you have PTT Security (That is TPM). Uncheck that.
Actually... let me see if I can find a more specific guide...

Test booting Zorin OS.

If still no good...

From the Grub screen with the tiny text, tap the e key to open the grub editor.
Scan for "quiet splash" and add dis_ucode_ldr inside the quotes to make it "quiet splash dis_ucode_ldr"
Then test booting normally.
If that works, we will need to install the intel microcode package:

sudo apt-get install -y intel-microcode

Or as a .deb:

No luck with the PTT change, editing the line in Grub 2.04 and then rebooting with f10/ctrl-x, both options just lead to the same black screen

Ok... Well that combined with the Tiny Print... makes me think Graphics.

Do you have a Different standard monitor you can use just for testing?

Oh... I almost forgot... I think this empty glass is yours... If you don't mine (burp) taking it back...

Lol, damn beer..

Connected a second monitor to the thunderbolt port via dongle but just received a no signal from the other screen.

This, I did not expect. But it definitely makes me think that the Graphics Drivers are at fault.
And without being able to boot into the Recovery Mode... I am not sure how to replace them - shy of creating a custom bootable Zorin OS .iso...

Have you tried installing other Distros?

1 Like

Not yet, first I need to be able to succesfully remove the distro I've test installed. When I followed a guide on how to remove Zorin OS, it bricked my laptop. Nothing I did fixed it until I found one random tip on youtube. I used to be very computer savvy years ago but I haven't kept my knowledge up to date. Also given that my choice of Zorin OS was based on the idea that it was user friendly, I'm hesitant to try again.

Hardware manufacturers in general are geared toward Windows.
MS Windows dominates with approx. 90% of the home desktop market. The rest is Mac OS.
Linux is in there somewhere...
While the majority of users have no troubles, occasionally, some people have hardware that Just Doesn't Like Linux on it.

You do not need to remove Zorin or any other distro.
Just install any OS onto the partition that contains Zorin, which re-formats and wipes the partition in the process.

I fear what that guide you found told you to do...

The guide basically had me reformat the area that Zorin OS was installed to without showing me how to remove the Grub 2.04 program and set the bootloader back to windows. Each step I moved to try to repair the bootloader always resulted in my getting an access denied error from the command prompt. Eventually, I found an updated guide on how to recreate the bootloader file and got it to work again.

ah... I think this may relate to current boot troubles...
I will defer to @swarfendor437 or @337harvey (currently in class) as they are more experienced in the Windows Bootloader and such issues.