Black screen on Dell Venue 11 7130 & other issues

I installed Zorin 16 on my Dell Venue 11 7130. Hoping it was te answer for a good Linux OS for a 2 in 1. Since I have recently tested on this same machine, versions of Linux Mint and, Cinnamon and Mate as well as Ubuntu, as well as Jing OS and others in search of the 2 in 1 OS. I was surprised that I had to boot from ISO to "Safe Mode" in order to see something more than a black screen.

I decided to do the installation hoping that the issue with black screen would take care of itself once installed but it does not. I have too boot recovery mode once installed. It did not. In fact I have only one screen resolution available which makes everything on screen way to small. The scaling in display settings is a joke it does not work, because once activated the start menu is no longer accessible.

Furthermore this unit has on the keyboard unit a Synaptics Touchpad but the clicker (button) does not work. If I use a Bluetooth mouse the clicker works on bluetooth mouse. Installing real VNC , a necessary staple for me there are more oddities with mouse like the Rectangle selection is being made. of course these issues may also be a result of safe mode.

I tried installing the x-swat repo and seeing if there were updates but none relevant to display

how do I resolve these issues?

What Graphics card are you using?

I know it is Intel based . lspcI lists it as Intel device 0a1e. Rev 0b

I tried using the F1 , alt and Ctrl keys while in black screen nothing happens.

For a start, you might try editing your grub and adding a parameter to instruct the kernel of your chipset at boot:

sudo nano /etc/default/grub

Arrow key down to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add the parameter i915.alpha_support=1 to make it:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.alpha_support=1"

Thanks but that does not work.

Strange how you can Put Ubuntu that boots fine on this same system, but the Zorin based on that same version of Ubuntu does not boot. Somebody really has messed something up.

Oh well I guess its back to Mint which has been my standby now since it was originally released. Lesson learned, to stop wasting time with these Linux distros that sound too good to be true. Throwing this one in the junk pile on top of Jing OS.