Black screen on first boot after installation

Hi there everyone!
I've been using ZorinOS for quite a while now on my laptop without any issues whatsoever - and I love it! That's why I decided to install it on my Desktop too now!

I was running Windows 10 up until now on my Desktop. I plugged in my Zorin USB drive, booted from it (selected "Try or install ZorinOS (modern NVIDIA graphics)" and it worked! Both of my monitors got detected, I could configure them in the NVIDIA Settings app and everything was fully functional. So I started the installation process: I have a SSD Boot drive and a HDD for file storage, so I decreased the size of the Windows partition on the SSD and created a new one for Zorin (so I can dual-boot). The installation process completed successfully, I rebooted and completed the last step ("remove the installation USB drive and hit enter"). It booted, I saw the grub menu where I could choose between Zorin or Windows, and after selecting Zorin, my screen went black. The fans suddenly started spinning loudly, and after ~ 30secs it got quieter, but the screen was still black (no cursor, no text, nothing). I waited for over half an hour, but nothing happened (the monitor did not go to standby).

Anyway, I tried rebooting a few times, but I always got the black screen. However, when I selected to boot into ZorinOS in Recovery mode in the grub menu and selected "resume", I got into Zorin and everything worked perfectly. The NVIDIA drivers loaded and everything was fine... I checked the boot logs and a few other things, but couldn't find the cause for the black screen.
I tried booting into "normal" Zorin a few more times and tried to follow different suggestions I found in this forum regarding similar issues (like setting "nomodeset" in the grub boot config and a few other things) - but nothing I tried fixed it.
I even went ahead and completely reinstalled Zorin, but it didn't help. Manually re-installing the NVIDIA driver didn't help either... I also tried disabling Fast boot in my BIOS, which also didn't help (secure boot was already disabled).

Booting into Windows still works perfectly, so there is no hardware error with the graphics card... I'm trying to get Zorin to work now for 3 days and I'm kinda desperate.

I have an Intel Core i9-10850K CPU, 32GB RAM and an NVIDIA GeForce RTX 3060 - I guess this should be more then enough to meet the minimum system requirements :sweat_smile:

I am grateful for any help as I'm finally trying to switch my last non-ZorinOS device to Zorin too :blush:
Thank you very much!

Can you see CLI by hitting alt+ctrl+F(4-5 or 6) after the fans cool down?

Thanks for your reply!
I tried that, but nothing happened. I tried a ton of different possible shortcuts, but I couldn't get to do anything on the blackscreen.

This is what I am using with no trouble. And given that Nomodeset and drivers changed nothing, I would discount the graphics driver as being the cause for now.

Is it eMMC or nVME?
Is your BIOS set to RAID or AHCI?

It's a 500GB NVMe SSD.
RAID is disabled and there is no AHCI.

Can you boot into Recovery Mode (tap esc or tab key after you see the MOtherboard splash screen to show the grub menu if you need) by choosing Advanced Options for Zorin
Arrow key down to Enable networking
Once enabled, back out to the menu
Drop to Prompt

sudo apt update && sudo apt dist-upgrade

Once finished, ensuring No Reported Errors, back out to the menu and try booting normally to test.
If any reported errors, please relay them here.

Okay, small update: I tried a ton of different things in the past weeks, but nothing worked.
However, I found out that from the 3 possible kernel versions I can choose in "Advanced Options for Zorin" (5.13.0-52; 5.13.0-48; 5.13.0-30) the last one seems to work fine - the first two versions (52 and 48) don't.
I have no idea why - for now I have configured grub to use the 5.13.0-30 version, so I can at least boot normally and use ZorinOS now.

Do you have an idea what the reason for this could be? Would be cool to use the latest kernel version eventually.

Thanks a lot for your help, @Aravisian!

Edit: When I try to boot into the two newer kernel versions (which don't work) with "Advanced Options for Zorin" (5.13.0-52 or 5.13.0-48), I get the following message: "Loading initial ramdisk". I left my computer for multiple hours once, but it didn't disappear - so it seems to be stuck at this step.
Again, booting in the default "Zorin" (without selecting "Advanced Options for Zorin"), I get no output at all, only a black screen.
Version 5.13.0-30 works fine.

It appears that there is a regression in the later kernels that is affecting you.
You can lock in the 5.13.0-30 kernel so that it default boots:

Thanks - I already did that. I can use Zorin normally now!

Do you have any idea why only this version works for me and no newer version?

I don't.
Kernel regressions are kind of an ago old problem... Usually, with bug reports, the kernel development team learns about and fixes such things.
But it is a bit of a lesson; "Latest and greatest" is not necessarily the greatest.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.