Black screen when trying to boot from Zorin OS 15 USB


I've created a bootable USB for Zorin OS 15 Core.
When I boot from the USB, I'm presented with 3 options (normal, safe mode and NVIDIA), all of which lead to a black screen.

I'm using a Lenovo Legion 5 laptop. It has a Ryzen 5800H and an RTX 3050 Ti.

I've disabled Secure Boot in the BIOS and Fast Startup in Windows 11.
I've also tried to switch from hybrid gpu mode to discrete gpu only.

I've googled my issue and read through threads that seemed relevant but couldn't find an actual solution to the problem.

Thanks in advance.

AMD and Nvidia. That is quite a combo...
The normal solutions of "nomodeset" would do little good as without an intel Graphics card to fall back to, it must have the Nvidia Drivers already in place at init.

What you may need to do is boot, then drop directly to the Recovery menu and from there to Enable Networking. Once you enable networking, bump back up to the Recovery Menu and arrow key down to drop to prompt.
From the Prompt terminal, locate the file 20-intel.conf or similar that should be in /usr/share/X11/xorg.conf.d/ and rm that file. (If you do not have the locate command, you can install it with sudo apt install mlocate). For example:

rm /usr/share/X11/xorg.conf.d/20-intel.conf

Once done, still in the Prompt Terminal, add the repo:

sudo add-apt-repository ppa:oibaf/graphics-drivers


sudo apt update && sudo apt full-upgrade

lastly (optional but worth trying) LightDM does a Much better job of handling Nvidia at init than GDM3 does. You may try

sudo apt install lightdm

and follow all the prompts.

Once done, please try booting into your desktop normally.

Thanks for the detailed reply.
What do you mean by "boot... and drop directly to the Recovery menu"? How do I do that?

I will also mention that Pop_OS and Fedora both work fine with my weird AMD - NVIDIA combo.

That may be because they got newer release (newer kernel and driver etc.) than Zorin OS 15. Zorin 16 will be released tomorrow-ish.

1 Like

Good point: The next option would be for yonyz to wait until Zorin OS 16 is available very shortly.

OK, I'll give it another try when version 16 is out.

Which might be a few hours from now...

Version 16 installs fine, though WiFi is unreliable, as with other distros I've tried. Not a fault of the OS of course, just the available driver. Thanks.

I wonder if a different USB Wifi Adapter may help you more.

I'm sure it would, but I'd rather not rely on a USB adapter for WiFi.