Black Screen while trying to install

While trying to install Zorin OS from USB, I can access the grub menu but get a black screen after selecting an option. I have an Intel Integrated GPU (UHD 620). I have tried the default mode, safe graphics and NVIDIA drivers mode. I had already checked the iso integrity and it was all good. I don't think it is a USB issue because I have installed some other Linux distributions using the same USB.

Have you turned off Secure Boot and Fast Startup. See this Before you install

1 Like

I disabled Secure Boot, Fast Startup and followed all the steps in the Before you install link you sent in your reply. I am still having the same issue, black screen after selecting "Try or Install" options. And now sometimes I even get black screen just after selecting the USB in the boot menu which is not letting me access the grub menu.

Which USB creation tool did you use. Not Belana Etcher? which has poor reputation with members here.

1 Like

Somehow it worked on about 7-8 years old 4gb usb. It is installing but stuck maybe.

Stuck here from half an hour. I have a lowe spec laptop maybe that's why it is taking time? My laptop cpu is i3 8130u, 4gb ram and a 1TB HDD.

Installation completed. Restarted. No traces of Zorin OS. Doesn't show up at Boot, BIOS and Disk Partitions. Literally no trace to be found.

Nevermind. It installed. It took up Ubuntu's name in the boot menu because I had it installed before. So the solution for the black screen issue is just to use a different usb drive and try to boot with legacy boot option enabled in the BIOS options. Thank You @zabadabadoo.

1 Like

That spec is perfectly adequate for all editions of ZorinOS as long as you dont intend to play heavy games or image manipulation etc, i.e. good for general use.