Blank screen on boot after updating to 5.15.0-113 kernel

Hey fellow Zoriners. I installed the recommended update from 5.15.0-107 to 5.15.0-113 today on my Zorin OS 16.3. Since then, all I get on boot is a black screen.

I already thought I had fritzed the whole installation, but with (very) carefully timed presses of the Escape key on startup, I was able to boot into the previous kernel, and things run fine again now (until I reboot, probably).

Question A: How do I revert to the old kernel?
Question B: Is anything known about problems with this new kernel?

The machine is a HP 255 G7 AMD Ryzen 5-2500U.

Thanks in advance

To set an older kernel to boot. See this should help: [HOW TO] set an older kernel to default boot

1 Like

Forget what I wrote earlier. I successfully reverted to kernel 107. Thank you.


Did you remember to run

sudo update grub

as per: [HOW TO] set an older kernel to default boot - #9 by Aravisian

Uh... maybe. :grin: Not sure what I did wrong. Works now.

1 Like

Sometimes you get a kernel that plays bad but the next one is good, so lets hope you can get a new kernel that works for you next time. (At least you now know how to roll-back and keep an old-but-good kernel),

I have the exact same problem, on my ThinkPad A485. The CPU is the same "AMD Ryzen 5 PRO 2500U", so I guess the 113 kernel doesn't like this CPU/GPU...

That's why I have some second though buying a AMD GPU, because of kernel regressions seems to happen often. With Nvidia you got modules which you can easily switch back and forth if current driver doesn't work independently of the kernel.