Bluetooth keyboard not connecting in Zorin OS 17 live

My PC won't connect to my keyboard, but it tries too.

My network card is Realtek rtl8821ce 802.11ac

I'm kind of a hurry here so if you want more info, then comment :smile:

Btw, i am trying to dual boot.

Do we assume your keyboard is bluetooth connected?
What is the make/model of keyboard?
Does WiFi work for internet etc or is the rtl8821ce simply not recognised?
Are you using Z17 Core or Z16.3 Core?

If you search for "rtl8821ce" here on the forum, you will find several threads for that device, including:


1 Like
  1. Yes
  2. A4 FBK11
  3. The Wi-Fi works, and it is recognized.
  4. Z17

EDIT: I have just re-read the title again. "...Zorin OS 17 live"
So you are you still running ZorinOS 17 from live USB as "Try Zorin"?
The rest of my post assumed you had done a install:

You say computer is trying to connect to keyboard, so is keyboard seen but not pairing? What are exact symptoms of "trying"?
Are any other bluetooth devices detected and can be paired, or is bluetooth effectively "on" but dead?
Equally, does your phone or other bluetooth device detect your computer?
There are plenty examples of bluetooth not working or not able to pair devices on Ubuntu 22.04 (the base of Z17).


Have you performed software/driver updates?
Have you tried booting an older linux kernel via grub screen "Additional Options" menu item?

1 Like

It only says connecting then it just doesn't pair. I tried to connect my PC to my phone, it connected. But my phone didn't detect the PC.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.