Wifi rtl8821ce driver installation

Can someone simplify how to install wifi drivers when there is no Wifi?

I have found topics to install the exact driver I am having trouble with, which is the rtl8821ce adapter on an lenovo 330 ideapad, but where are the installation packages coming from if there is no wifi?

And it seems like there was no solution.

MX Linux and Endeavor OS installs the driver but Zorin OS doesn't. I am currently using the MX Linux to post this question from said laptop, however, I prefer Zorin OS on the computer(my sister's laptop) as it is friendlier to use.

There are similar topics found by googling but the steps are a bit coded and unclear. I am looking for a brief description of each step so that I can understand the process a bit.

I can download from a different laptop and transfer to the laptop in question.

Thanks in advance.

You can download deb file for driver here:

If your in zorin 15.3, you could always install 16 core and that driver will be included in the kernel. I know how much a pain it is to get it to work!


They aren't. An active connection is necessary. You raise a Really Good Point - that a disclaimer could be placed on some instructions pointing out you must use ethernet or mobile phone hot spot to follow the directions.

It's Zorin 16 that isn't detecting the wifi connection.

Wow...i thought that driver was included. That's the driver for my card and it works fine out the box.

How can a hotspot be setup to be used? If the card can detect a hotspot won't it be able to detect WiFi? I turned on my cell phone hotspot but no detection happening. The MX can detect both the Wifi and the hotspot.

You can use MX Linux to download the files, then you can use a USB stick to transfer them to Zorin OS-
I am with 337 Harvey on this one. It should work out of the box. I wonder if something went wrong with the installation of Zorin.

Is there any options I should select during installation that I didn't select that can cause this? I have been installing back and forth several times with no luck. I also tried linux mint which didn't work either, but MX Linux and Endeavor OS is connecting to the WiFi fine.


I clicked on the links on the page but I am only being asked to download adons I don't need. Kinda like I have to download one before I can download the other I need. Maybe I have to try it again.

Not that I can think of.
What kernel is MX linux using?
Zorin is using 5.11

Download the file, then copy it to the USB stick. Boot into Zorin OS, copy the files onto Zorin OS.

I don't understand what you mean by this... The link leads you to this file:

Are you saying that when you try to install that .deb file, it states that some dependencies are missing?

System: Host: Kernel: 5.10.0-5mx-amd64 x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-5mx-amd64 root=UUID= ro quiet splash
Desktop: KDE Plasma 5.14.5 wm: kwin_x11 dm: SDDM Distro: MX-19.4_kde_x64 patito feo March 31 2021
base: Debian GNU/Linux 10 (buster)

Network: Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtw_8821ce v: N/A
port: 3000 bus ID: 01:00.0 chip ID: 10ec:c821
IF: wlan0 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 2000
bus ID: 02:00.0 chip ID: 10ec:8168
IF: eth0 state: down mac:

I did it wrong. The file was downloaded.

Is this is how to install the downloaded file?:

  1. Update the package index:
# sudo apt-get update
  1. Install rtl8821ce-dkms deb package:
# sudo apt-get install rtl8821ce-dkms

To install the .deb file, you must use the dpkg tool within your OS.
APT install is for accessing .deb files contained within repositories, using Debians Advanced Package Tool. Your Linux distro comes with apt and apt-get, both of which are different from APT. APT supplies the packages, apt and apt-get call upon APT to supply the package.
DPKG is the installer.
So, your command is apt-get install - means apt-get call on APT to retrieve package and install calls upon dpkg.

To install from a local .deb on your computer, you need only call on dpkg directly. dpkg -i (package-name) - in your case:

sudo dpkg -i rtl8821ce-dkms_5.5.2.1-0ubuntu3_all.deb

Perform the above command from the Same Directory that the .deb package is in, otherwise it won't find it.
So, if you moved the .deb package into Downloads, then Change Directory to Download Folder first:

cd ~/Downloads

For ease- you can just move the .deb package right into your home folder, then open a terminal which defaults to home with ctrl+alt+t, then apply the above dpkg command straight away.
If the above .deb package is the only .deb package in that directory, you can save yourself some typing by instructing dpkg to install all .deb packages in that directory and since it is the only one, it will be the only one installed:

sudo dpkg -i *.deb

Sometimes manufacturer does a "stealth" update of their product without any explicit indication.

I have RTL8188CUS (version 2) which is the only chipset I managed to make work in Clear Linux white it was in the beta. (It might change after that though. I did not check.)

1 Like

I wonder if it is easier for the beginners to install Gdebi and do it in GUI.

sudo apt install gdebi

Then double click on the downloaded deb file.

1 Like

I will try this but for now the sudo dpkg -i *.deb works, but it worked on linux mint. I decided to try zorin 15.3 lite because I noticed it boots faster on this low performance laptop. However, there are dependency errors I am hoping can be fixed to get the WiFi adapter to work on the Zorin 15.3.

Here is the error:

whoever@whoever-Lenovo-ideapad-330-15ARR:~$ sudo dpkg -i *.deb

(Reading database ... 242014 files and directories currently installed.)

Preparing to unpack rtl8821ce-dkms_5.5.2.1-0ubuntu3_all.deb ...

Unpacking rtl8821ce-dkms ( over ( ...

dpkg: dependency problems prevent configuration of rtl8821ce-dkms:

rtl8821ce-dkms depends on dkms (>=; however:

Package dkms is not installed.

dpkg: error processing package rtl8821ce-dkms (--install):

dependency problems - leaving unconfigured

Errors were encountered while processing:


Can I get some guidance on resolving this?

I checked dkms in Synaptic.
In Zorin 16, dkms version is 2.8.1-5.
You might try it in Zorin 16 and see if you can solve this unmet dependency.

Before I try it I would like to explain that I am trying to get a faster boot time. Zorin 15.3 lite boots faster than Linux Mint Xfce, but Linux mint Xfce boots faster than Zorin 16, hence, before giving up on Zorin 15.3 lite, I would like to ask if it's possible to fix the dependency problem to get the Wifi working on the Zorin 15.3?

I think it is possible but you have to ask someone like @Aravisian who is more knowledgeable for such matters.

If you are looking at speed, I might suggest you to have a look at MXLinux. It uses XFCE desktop and because of the absence of systemD, it works very efficiently.

I would love to try the MX Linux xfce especially because MX Linux plasma was easier to setup but I am wondering how easy is it to find and install software. This is my sister's laptop and she is one of these people who have no patience to learn about computers. I find Zorin and Mint is like Microsoft Windows and is therefore more familiar and easier to use.

My husband (former mac user) is happily using MXLinux for a few years now. He is anything but computer savvy.

XFCE desktop is much easier to manoeuvrer than GNOME for beginners.

Other option would be installing XFCE desktop on top of Zorin 16 Core. @Aravisian knows much better than myself when it comes to installing other DE.