WiFi adapter not recognized: WiFi driver ( rtl8821ce ) issue: Lenovo ideapad 330 15ARR

I cannot access internet through WiFi as:

  1. Additional Driver section does not provide rtl8821ce driver after zorin installation saying no additional driver available.

  2. tried manual installation of wifi driver by tomaspinho. but dkms error is being shown. help needed.
    Screenshot from 2020-09-26 19-27-30

Hi and welcome! Did you try these instructions? You need to scroll down to the reply with 45 votes:

yess… I tried this but “sudo apt-get install --reinstall git dkms build-essential linux-headers-$(uname -r)” gave the error which i’m uploading.

I suspect that because Zorin uses the bits of Ubuntu it needs may not include everything. I have tried installing the full Gnome desktop environment today and Zorin does not allow me to do it. Stated I had held or broken packages like yourself but when ran commands in terminal nothing was listed as being broken/held up. The other issue I noticed is that the maintainer is no longer able to support as per the link - at a bit of a loss too friend!

I’ve not done anything… It’s a fresh installation… I just checked the additional driver… there driver was not listed. so i went through the above link u provided.

You could try

sudo apt --fix-broken install


sudo apt-get install dkms-dev

Or try searching dkms-dev in Synaptic.
Or see this thread:

reinstalled zorin core… tried what u said… showing the following again.

what are those unmet dependencies that are shown?

I know that libdpkg-perl, gcc and fakeroot are all in the Ubuntu Universe Repo. I would install those, then do the

sudo apt --fix-broken install