Boot Problem

I've been using Zorin OS 16 Core for about 4 months now, and my experience overall is good and nice, and lighter than Win10. But, there's a problem that keeps happening. Weirdly, it's happening within a period of time let's say about a week and it appears monthly. So the problem is right here


This happens whenever I try to boot up my laptop. Not just that, sometimes I couldn't even get into the BIOS Menu before the Zorin Grub menu. If there's someone could help me out from this problem, I will appreciate it so much.

Device:
Acer(Laptop) Aspire E1
4 GB RAM
Intel Celeron B830 1.8 GHz
Dual Boot with Win 10

Can you please roll back to the previous kernel and test?

I'm not sure because I never do that before. If you may, could you explain how to do that please??

Yes, from the Grub Menu, which you see when you first boot your computer (If you do not see, try tapping the esc key when you see the motherboard splash screen and keep tapping it until Grub apears):
Select Advanced Options for Zorin
Arrow key to the option for Zorin on... and choose the earlier (lower number) kernel
Tap the enter key to boot that kernel.

Once you log in, you can double check that all went according to plan by running in terminal:

uname -r

1 Like

Okay, I'll inform you later after I try it. But, will there be any side-effect if I do this whether it's side-effect to my /home partition or even my Win 10 partition??

So, I just tried this method and here what happened afterward:

  1. After I applied using the 39 kernel(the previous kernel), my laptop managed to boot into Zorin OS and its desktop. Then, I want to test it one more time by turned off my laptop, and turned it back on. When my laptop tried to turn it back on, it stuck at my Acer screen, so I forced it to turn off by put out the battery.
  2. Then, I put the battery back in and tried to turn it back on, but this time, it actually booted up in no time to Zorin Grub menu and the OS itself.

I'm so sorry, I hate to say this but I think this method doesn't fix this problem completely and properly. I will give more information if this method really fixed my boot problem(whether I can't boot up into Zorin or even it takes too long to boot up)

EDIT:
omg, I'm so sorry, I didn't know this. Point no. 2 when I was in Zorin Grub menu, I chose Zorin OS. But when I opened up my terminal and checked just now, I'm using the 40 kernel again, not the 39. I didn't realize this at all. I thought it'd keep using the 39 kernel :pray:

1 Like

Zorin OS will, by default, always boot into the latest kernel unless instructed otherwise.
By booting into an earlier kernel, you can test if it helps resolve a regression that a later kernel introduces.
If that works, you can set the system to default boot into your preferred kernel, instead of the latest:

1 Like

This is the picture the first time I booted up using the 39 kernel this afternoon


During this screen, it took around 3 minutes to really got into the login screen. Is this a common thing to get pass this screen that long??

Oh, I'm really sorry if I'm bothering and wasting your time, but I want to know, is there anything that could cause this problem(the whole boot problem) besides just the kernel??

Thank you in advance😊

This looks like either your partitions are not mounting properly - could be due to a corruption in a block or sector - or possibly due to a hard drive failure.
Have you run fsck on that drive?

No, I haven't tried it before because I'm so afraid to damage my whole system :sweat_smile:

UPDATE:
Last night and this morning, it booted up without any problem and fast. But then, the problem came back this afternoon, and it took so long and efforts to finally boot up. I even put out and put back in my harddisk from the laptop. Do you think it could be a hardware problem too, like an actual physical damage to the harddisk plate or my RAM??

Yes, I do think that is possible. FSCK is one method of checking for errors. You can also run a S.M.A.R.T. test.
If you are comfortable removing the drive from the computer, I would recommend checking the connections and cables before considering it to be the drive itself. Also, clean the contacts for your RAM and ensure that they are fully seated.

1 Like

Ohh, speaking of S.M.A.R.T. Test, I was actually did a S.M.A.R.T. data and self-test using the Disk app, but there wasn't a single warning or notice or pop-up about harddisk damage. But there was only Airflow Temperature in the Attribute column indicates FAILING in the Assessment column. Or maybe I just didn't know how to read the detailed results.

Hmmm... Overheating? Overheating can cause a variety of issues...
You might try using Psensor as a quick launchable app and check your system temperatures when running.

I don't know about this but I think the heat has never been a problem to my laptop. Yes its fan makes noises for the most time, even when I still use Win 10. It's the same case when I use Zorin too, the fan makes noises but not as much as in Win 10.
Back to the first topic, my system has been unstable for the last 3 days. Sometimes it could boot up quickly without a problem, sometimes it couldn't boot up as quickly as it usually is or even worse it couldn't even boot at all unless I turn it off by force by putting out the battery then put it in. It's so sad though, my experience with Zorin has been fun and comfortable but I don't really want to go back to Win 10 that runs so slow because of this boot problem(well it's not like I can boot up easily to Win 10 too because the problem always occur as soon as I press the power button and stuck on my motherboard/laptop screen)

Thank you so much for your help, it may not solve my own problem but I think if someone has the same one, maybe it'll work.