Brightness always at 100% after reboot

The brightness level of my Asus Vivobook M3500Q (OLED display) gets set to 100% brightness after every reboot.
I tried to automatically run a script on startup with the command

brightnessctl -d "amdgpu_bl0" set 30%

This doesn't work without sudo. With sudo, it cannot run in the background as it asks for the password.
What else can I do? Maybe somebody can find the reason of my notebook forgetting the last brightness setting instead of helping the to set the brightness to a pre-defined level on every startup?

Does your Asus Vivobook M3500Q (OLED display) have NVIDIA® GeForce® RTX™ 3050 graphics as stated on their website?

What driver are you using?

1 Like

On Zorin-Settings-Info it says AMD RENOIR (renoir, LLVM 15.0.7, DRM 3.49, 6.2.0-39-generic).
I did not select "install zorin with modern NVIDIA drivers". Maybe this would have installed the correct drivers?

No additional/manual driver installed. It is an OLED Display.

You do have your sudo password, right?
If it is a script, you can right click the script and under Properties, select Permissions and set it as executable.

1 Like

The script is executable, but it still asks for a password in the terminal if sudo is written. Without sudo it says it doesn't have permissions.

If you placed it within the Root directory, it would need elevated privileges.

Since the script you posted is referencing amdgpu, I assume you placed it in /sys/class/backlight?
Instead of using a script, have you tried a Grub parameter like acpi_backlight=vendor?


I have placed the script in /home/user directory. I wasn't able to create files in /sys/class/backlight, even when I started nautilus with sudo rights.

I don't know how to add/change Grub parameters but I'm currently fine with setting the brightness manually on every start. Thanks for your help though! I guess it's just a lacking driver which might be provided sometime in the future.

It's very easy, so if you would like to try it out, you might not have to wait (or might experience annoyance if it does not work).
You can add or remove a grub parameter by adding an entry or removing an entry from the Grub File.

sudo nano /etc/default/grub

Arrow key down to the parameters:
You can see two parameters already included in the quote marks: quiet and splash.
Add the parameter acpi_backlight=vendor inside the quote marks:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
Now tap ctl+o to overwrite, then tap enter to save as current configuration. Tap ctl+x` to exit the editor.
Now, you must update grub for the changes to take effect.

sudo update-grub

That is all there is to it. The parameter I am suggesting here is a Generic Parameter and may not be the right one you need. You can test it, in case it works but if not, we can try refining it. I will be away for many hours today.

Thank you for your detailed instructions.
I followed them but unfortunately the brightness setting is completely gone after reboot. It is at 100% and cannot be changed. I had to undo the changes to get the settings back. Are there other parameters I can try? :slight_smile:

You can try:




Are you one Zorin OS 16 or Zorin OS 17?

Which kernel are you using?

uname -r

Thank you. Unfortunately, both parameters didn't work.

I'm on the latest version of Zorin 17, kernel 6.2.0-39-generic

Let's try upping your kernel to 6.6.5:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.06

Reboot into the later 6.6.5 kernel and test brightness controllers (stock).

After reboot I get the following error message when I select the 6.6.5 kernel (translated):

Loading Linux 6.6.5-060605-generic ...
Error: Wrong Shim-Signature.
Loading intitial ramdisk ...
Error: You have to load the kernel first.
Press a key to resume ...

I disabled Secure Boot and was able to boot into 6.6.5. Unfortunately, the problem still exists.
Now, when I shut down, the Zorin logo freezes. How to safely get back to the old kernel?

sudo apt remove --purge linux-generic-6.06


sudo apt clean && sudo apt autoremove

Boot into the previous working kernel.

(I actually did not know that the TuxInvader has an unsigned kernel).

I was able to remove the kernel and boot into the old one again.
Will probably have to wait for a fix for the initial problem. Thank you for trying to help me!

34 posts were split to a new topic: Screen Brightness reverts after using some applications

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.