Brightness Control Not working

As a newcomer to Linux I am trialling Zorin 16 on a 10+ years old Samsung RV510 64 bit laptop. The trial is direct from a USB stick. I already have Linux Mint Mate 20 dual booting with MS W10 on the RV510.
My problem with the Z16 trial (and an earlier attempt with Zorin 15.3 Lite) is that I cannot change the brightness either with the Power slider, or using the laptop Fn driven keys although these show the brightness icon when I try them but they do nothing to the brightness setting, just like the slider. However brightness control works fully in Mint Mate on the RV510. Z16 brightness also works on a 4 years old HP laptop when run from the USB stick.
I have searched and found that there was/is a problem in Ubuntu regarding brightness and tried some of the solutions (without really knowing what I am doing in Terminal) and had no success but most seem to require a reboot which will wipe any changes I make.
Any suggestions for a simple fix which does not require a reboot? I really don't want to replace Mint Mate with Zorin 16 (or indeed 15.3 Lite) on this laptop and then find I can't change brightness. Otherwise I shall have to stay with Mint on this laptop which is a shame because I do like the look of Zorin.

I don't get these 2, you boot into zorin 16 live and the controls for brightness don't work for you in live enviroment. But you want a fix but don't want to install zorin...why need a fix in the first place if you want to stay on mint ?

1 Like

As I said it's a USB driven trial for Zorin which I would consider installing in place of Mint, provided I can resolve the brightness control problem whilst operating off the USB stick. If I can't do that then I won't fully install Zorin on this laptop, since I could be replacing something that works with something that doesn't.

This can be driver related as zorin live does not use amd or nvidia drivers. A fresh install would make more sense.

  1. This laptop has a MESA DRi Intel GM45 Express graphics chipset
  2. There are no additional drivers available to me.
  3. I am 99% sure Mint brightness control worked when I trialled it off a USB stick (before I decided to install it).

A reboot is not a hindrance.

You can boot up Zorin LiveUSB, then tap the e key at the Grub menu to Edit Grub.
Find "quiet splash" on the screen and add the following parameters to it, so that it looks like (No Typos Allowed): "quiet splash i915.modeset=1 acpi_backlight=vendor acpi_osi="

Then exit the grub editor and proceed to boot normally.

If it works in that mode, then once installed, you can permanently edit grub

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 acpi_backlight=vendor acpi_osi="

ctrl+x to exit, the y key to say yes to save, then enter key to save as current configuration.

sudo update-grub


Many thanks Aravisian. Your solution worked. I can now carry on with my trial. One minor detail the Grub menu required 'Tab' not 'e' to edit. Finally I assume Zorin 15.3 Lite will require the same mod to get that to work should I find v16 is a bit resource heavy for my old laptop.
Thanks again.


Thanks for making note of this detail, as this could spare others a headache.

It usually is just e at the grub menu. Some may need to tap esc or tab to see that, though.
It is supposed to be tab if using EFI and esc if using MBR (Legacy)... But with enough experimentation, you will find that it sometimes is the other way around.
I've gotten into the habit of just saying "Try both."

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.