Zorin Forum

Screen Brightness Control Missing Zorin OS16 - Macbook Pro

Gnome is cool when coming to Linux (And I think KDE is as well I may be incorrect)... It's a learning curve so to speak. But as pointed out by @Aravisian once you get to know moving forward to other editions that give you full options is REALLY the way to go. XFCE seems to be the next step (but I'm checking them all out)

1 Like

So I had problems with Mint - something i did today messed up the bios/startup. Reinstalling Mint did not help. reinstalling Zorin Lite 15 did. So now I got a good working copy of 15. BUT when I go to update the drivers so I can get the wifi working in the Additional Drivers section - the wifi drivers are no longer there.

Every time I have installed Zorin i have needed to install 2 proprietary drivers - one for NVIDIA and one for Wifi. But now it only wants to install the NVIDIA driver. So how do I get my wifi back.

I feel like I am going around in circles here... :slight_smile:
But Im an ex windows guy so its a lot less circles than windows so....

Any ideas on the wifi?

Can you please remind:

sudo lshw -c network

2 Likes

*-network
description: Network controller
product: BCM4322 802.11a/b/g/n Wireless LAN Controller
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:02:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:17 memory:d3200000-d3203fff
*-network
description: Ethernet interface
product: NetXtreme BCM5764M Gigabit Ethernet PCIe
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:03:00.0
logical name: enp3s0
version: 10
serial: c4:2c:03:24:b6:ea
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=5764m-v3.38 latency=0 link=no multicast=yes port=twisted pair
resources: irq:29 memory:d3100000-d310ffff

sudo apt install firmware-b43-installer

sudo apt install linux-firmware && sudo reboot

If you have no Ethernet connection... Let me know...

I tried the first and got this -

mac@mac-MacBookPro:~$ sudo apt install firmware-b43-installer
[sudo] password for mac:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package firmware-b43-installer

*** Then I tried the first part of your second line and got this

mac@mac-MacBookPro:~$ sudo apt install linux-firmware
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-firmware is already the newest version (1.173.19).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
mac@mac-MacBookPro:~$

*** If I'm right that means the correct driver is already there?

But I have no ethernet - and when I look at the options in the bottom right network connection section the ethernet bits are still greyed out.

One interesting things - when I get to the boot screen it gave me 2 options - one was zorin and one was zorin with advanced options. I have never seen those 2 options before. When Ive booted before it just booted.... so why 2? I'm going to try booting advanced and see what happens...

Its so weird as I was able to install the Broadcom drivers as part of the 2 required prop drivers before...

But as before when I search for additional drivers the Broadcon wifi ones dont come up - like they are not needed - or the hardware doesnt exist... but yet we know they are there...

This is why you got:

The above commands are based on you using Ethernet to access the web to install the packages.

Here is a link to the .deb file - you can download it on a working computer, then transfer it via usb and install it.
http://archive.ubuntu.com/ubuntu/pool/multiverse/b/b43-fwcutter/firmware-b43-installer_019-4_all.deb

I will try it again - I was using tethered internet from my phone... I will try it again and/or get the deb file. I will let you know shortly.

2 Likes

In that case, also check that in Software & Updates that your Download from is set to Main Server.
Always be on Main Server.
The regional servers are supposed to hold all the same packages as the Main Universe... They don't.

1 Like

Feel like Im going around in circles here -
Im hooked up to Ethernet cable now...
Retried the original commands you sent. This time they did appear to download the drivers. Rebooted. Still no wifi.

Went to the Updates. Changed source to Main. Looked for drivers - this time it came up with both the Broadcom and Nvidia drivers. Looked promising. Applied changes. Rebooted. Still no wifi.

went looking for the driver link you sent. Downloaded it and clicked. It comes up with an Install buttom - shows me what it will install. i click on Install. It shows a line that says Installing 0% but it wants my password to authenticate. I enter my password and it just goes back a screen to the Install button. So its not letting me manually install them...

I will keep trying. Thanks for all your help so far.

1 Like

No need for the .deb, you already installed via terminal.
I think for now, we can focus on not the drivers but Modprobe.
You may need to remove the driver from the Module Prober and add the Broadcom driver.

modprobe -r b43 bcma

modprobe -r brcmsmac bcma

modprobe -r wl

modprobe b43

sudo nano /etc/modprobe.d/blacklist.conf

And
blacklist brcmsmac as well as blacklist wl then Reboot and test.

Okay so I finally gave up and went to bed, and when I came back I reinstalled Zorin core. Once it loaded up it had the Broadcom drivers already in and wifi was available. So you guys might find that interesting... no wifi on 15 Lite but Wifi on Core 16. Same computer. Maybe a quirk with MacBook Pro installs.

I still have no screen brightness controls but my screen is okay ish. I can live with it. I wouldnt have it super bright anyway. And I'm wondering if again this is a quirk of Core 16.

And thanks again for your help.

2 Likes

Another solution:

Plus Zorin 15.

You will have both WiFi and brightness control.

1 Like

Those are old school wifi dongles? Like back in the olden days? Cool.

But how do I get brightness controls back? I haven't had brightness controls in 15 Lite or 16 Core with my MacBook Pro.

(Note: I do have brightness controls with the same install on MacBook Air or my old Gateway Windows machine)

Oops, I misunderstood that you did have a brightness control in Zorin 15.

[edit]
Video from 2016.
This might help:

@webtasmo Did the solution suggested by @FrenchPress work?

Unfortunately no it didnt work. I even tried adding the exit = 0 as well, both times rebooting. But nothing.

Just so you guys know, the other controls on my mac work such as volume control and keyboard backlighting...

1 Like

Just so you guys know I finally got the wifi working on Zorin 15 Lite. I followed the instructions here - networking - Installing Broadcom Wireless Drivers - Ask Ubuntu

Still working on the brightness controls though...

2 Likes

You may try the grub parameters that worked in this thread:

"quiet splash i915.modeset=1 acpi_backlight=vendor acpi_osi="

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.