Screen Brightness Control Missing Zorin OS16 - Macbook Pro

Hi, I have searched this site for information on the screen brightness. I recently switched 3 computers to Zorin OS 16 - An old windows PC, a Macbook Air and an old Macbook pro of Zorin Core 16.

On my windows machine and Mac Book Air I have a beautiful bright screen and I have the controls under the Power setting with all options. Plus the keyboard brightness buttons work as usual.

However on my Macbook Pro I have a dim screen and under the Settings > Power I do not have an option to change the brightness. Also my brightness shortcut buttons do not work. I have tried all the tweaks I have found on this forum (Gnome Tweaks etc) but still nothing is working... No matter what I do I dont get access to any controls.

Also of notes, when I had it running with Mac OS I had the brightness controls, the screen was adjustable and it was a lot brighter than this.

Any help would be most appreciated.

about my mac

Ensure that Secure Boot is disabled in EFI settings. mokutils may not find the brightness controller.

Also:
Can you please try:

uname -r

Find your kernel, then reconfigure it (if needed, replace linux-image-5.11.0-40-generic with what you actually have):

sudo dpkg-reconfigure linux-image-5.11.0-40-generic

You may try the acpi_osi=linux grub parameter added to grub.

Workaround:

sudo add-apt-repository ppa:apandada1/brightness-controller

sudo apt update && sudo apt install brightness-controller

uname -r brings back --> 5.11.0-40-generic

Tried running a few of those scripts in Terminal but nothing really changed.

How do I access the Bios EFI settings in my MacBook Pro running Zorin? I know how to access boot stuff in Windows but not sure abut Mac/Linux

(Note: Just so you know - my experience level is that of a script monkey - I know enough to easily install various OS and play around with terminal, cut and paste commans etc, but I am in no way an expert)

Sounds about like me.

Did you install and launch Brightness Controller?

Did you try the Grub parameter?

I do not know...I have never used a Macbook. You might try a web search looking for that.

Will this help?

Hi, Thanks for the link but the problem is my Mac is no longer a Mac it is only runs Zorin 16. I didnt set it to dual boot. And apparently from what I have read on Macs you need to boot into the Mac OS and use a utility program to change the boot stuff.

I also tried the Brightness Controller. Moving the sliders does nothing and the Advanced options are disabled.

1 Like

Not sure what this means? can you give me code to copy/paste in terminal?

No problem. I just didn't want to bloat the post...

sudo nano /etc/default/grub

Find this line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and add acpi_osi=linux so that it is:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux"
Tap ctrl+x to exit, then the y key to say yest to save. Then enter key to ssave as current configuration.
The terminal will revert to normal.
Now, run

sudo update-grub

Try a couple reboots to test.

:sob:

When you boot and see the grub menu, it has an option to boot into the bios at the very bottom of the list. Choose that and attempt to boot into bios. Then check and see if there is a secure boot entry under the security or boot tabs and make sure it's off.

I've never used a macbook myself, so wouldn't have the faintest idea how to access the bios on it. I'm stabbing at the dark hoping it will help.

2 Likes

Does a macbook even come with secure boot ? I thought it was always Microsoft related.

If you cant access the bios use these commands.

Install mokutil sudo apt-get install mokutil

Check the status of SecureBoot mokutil --sb-state

In case it is enabled run command sudo mokutil --disable-validation

1 Like

Welcome to the forum !! I just want to thank you for being so thorough in providing information of your system... something that is very important in resolving issues.

2 Likes

Hi, Thanks for all the help. Whilst deciding which OS to install I was 50/50 Mint vs Zorin. I liked Zorin so far so have been using that. But out of curiosity I tried Mint on the Macbook pro and it enable the brightness controls. as this computer is for one of my kids an they will only be using Firefox for school then I'm just gona stick with the Mint install for that one and keep Zorin on the others. It is a weird glitch...

Another interesting fact - whilst troubleshooting I tried using Zorin Lite which is currently OS 15. That had a "settings" box that had Boot Options as one of the things you could play with. It had all the Grub options and stuff. It seems they got rid of that option for OS16.

Unfortunately i was already half way through installing Mint when I saw that so I didnt get to try it.

Thanks again for everyones help.

2 Likes

Actually it is a GNOME desktop that removed all those functions.
Zorin Lite is using XFCE desktop which is way more customizable.
We are all waiting the release of Zorin 16 Lite which is supposed to come soon.

2 Likes

@Frenchpress already addressed this. But I will point out, I use Zorin OS Lite for the same reason.
We are all eagerly awaiting the release of Z16 Lite. :wink:

2 Likes

Interesting... So are you saying the prevailing wisdom amongst most Zorin users is to stick with the Lite editions?

No... It is more a matter of preference. Some prefer Core and some prefer Lite.
I prefer Lite because I find it to be a Fully Featured Desktop Environment, unlike Gnome.

ZorinGroup did a Phenomenal job of restoring much functionality to Gnome... For me, it is not quite enough.
Lite (XFCE4 Desktop) is more centalized, modular and contains everything a desktop needs. It is a lightweight desktop, so runs smooth and fast on any computer I install it on. I prefer having the options for configuration.

2 Likes

Gnome is cool when coming to Linux (And I think KDE is as well I may be incorrect)... It's a learning curve so to speak. But as pointed out by @Aravisian once you get to know moving forward to other editions that give you full options is REALLY the way to go. XFCE seems to be the next step (but I'm checking them all out)

1 Like

So I had problems with Mint - something i did today messed up the bios/startup. Reinstalling Mint did not help. reinstalling Zorin Lite 15 did. So now I got a good working copy of 15. BUT when I go to update the drivers so I can get the wifi working in the Additional Drivers section - the wifi drivers are no longer there.

Every time I have installed Zorin i have needed to install 2 proprietary drivers - one for NVIDIA and one for Wifi. But now it only wants to install the NVIDIA driver. So how do I get my wifi back.

I feel like I am going around in circles here... :slight_smile:
But Im an ex windows guy so its a lot less circles than windows so....

Any ideas on the wifi?

Can you please remind:

sudo lshw -c network

2 Likes