Brightness controls broke during fixing Grub boot loader

I had a problem with my grub boot loader.
@FrenchPress and @Aravisian helped me fixing it.
But during the fixing process - it took a few atempts - after a restart my brightness controls didn't work anymore. Whether the buttons nor the slider in the settings and the screen was shining like the sun.
I searched for a solution myself and found this

for some reason that "acpi_backlight=vendor" was not there and I added it.
It fixed the brightness problem so we continued with my other problem.
Now my Grub bootloader is fixed and since then the brightness does not work again. At least this time it seems to be stuck with my usual brightness and not highest or lowest setting.
My grub file looks like this now

I am not sure when exactly it broke the first time during the fix of my other Problem.

Thanks in advance!!

This worries me, because as we noted in the other thread, that grub parameter was incorrect and was therefor not being read by the system.
I have doubts as to whether that actually fixed it, or that something else (maybe related to why it stopped working) is going on there.

You may try
"quiet splash acpi_osi=" just like that and see what happens (Don't forget sudo update-grub).

Otherwise, there is a separate Brightness controller app that can be installed:

sudo add-apt-repository ppa:apandada1/brightness-controller

Let me know if that repo is bad, my memory is getting worse as I get younger.

sudo apt update && sudo apt install brightness-controller

1 Like

True. That is kinda weird. But I did not do anything else as an attempt to fix it.

Okay I did the first thing you said
"quiet splash acpi_osi="
and now I am on Windows cause I could not start Zorin anymore. :joy:
See Picture

Tap the esc key before reaching the Grub Menu after rebooting to pull up the Recovery Grub menu...
Select Recovery Menu, then arrow key down to Drop to prompt.
Hit enter
Then in the terminal, (you have gotten so much practice at this... it should be a breeze...)
sudo nano /etc/defaultgrub
remove the acpi_osi= to make it just "quiet splash" then exit, save...

sudo update-grub

Try booting normally...

1 Like

If I don't come back please plant a tree for me :sweat_smile:
okay, lets go... see you on the other side :muscle:


It is getting more interesting and I am still on the same side :upside_down_face: namely on Windows.
This is what I got when I pressed ESC before grub showed up

bottom entry says "enter setup"

I really should make a point not to read your posting while sipping my coffee :coffee: Another choking alert :rofl:

1 Like

I will start a fire next time before I spit a joke in here. So just sit next to a window while drinking coffee and when you see smoke put down your mug immediately :wink:

finally I was on the helping side here deploying the best solutions here - thumps up to me :+1:

1 Like

still have my Zorin ISO stick ready here - keeping that one now till I die - seems safer...

Oh, yes.
You always hang on to those installers.
They are indispensable trouble shooting tools.
For example, if you want to change the partition size, you need to boot your system externally from those installers.

1 Like

okay I am back on Zorin 16 and the Brightness works at the moment.

What I did? I used my live usb stick with Zorin (made a Windwos 11 one as well just in case) and started it. Got some error lines but it started anyway.
Then I did a boot repair. I had to open a Terminal and copy/paste 3 lines to delete Grub. After that it told me to copy/paste an other line in to the terminal to install grub.
Then it repaired...
In the End I got a little window that said "boot repair failed" and some info how to restart and contact Mail. Also gave me a command for windows in case Grub does not show up but instead it boots directly into windows.

Well: I restarted. Removed the stick and landed in the Grub boot menu to choose Zorin or Windows. Chose Zorin and here I am...

Here is my Grub file. Funny enough that acpi_backlight=vendor is gone

I don't know what causes the Brightness Problem. I didn't have it since installing Zorin and it only first appeared while I was trying to fix my mentioned Grub Problem...

Have you ever try a USB live session and see if this function is working or not?

By USB live session you mean writing the iso on a usb and choose to try or install?

Every time I did that the brightness controls worked without any problem. Not even a hiccup

So it is your installation, which got a problem.
I just wanted to double-check.
The problem is that I am using a desktop and brightness control is a physical button on the monitor for me.
I will ask other volunteers who I know are using laptop.
@Storm @StarTreker

1 Like

The Buttons (FN + F7 or F8) didn't work either. But I guess that is different from the buttons you have ... although they just give a electronic signal as well, don't they? It's not like a person sits in your PC and puts more wood into the fire to get a brighter screen...

Sorry I meant a physical button on the LCD monitor itself.

It depends on the keyboard I think.
For me, F7 and F8 are multimedia keys (I use Apple magic keyboard).

Yeah you wrote that correct but I don't know how that is different :thinking:

Nice image for a cold winter night :snowflake:
Actually we say "file up computer" in Japanese language sometimes.

A classic issue that Linux distro's have, is that they are all usually broken when it comes to changing screen brightness. So, this is what allowed me to change screen brightness.

    sudo add-apt-repository ppa:apandada1/brightness-controller
    sudo apt update && sudo apt install brightness-controller

Once installed, I can use the APP to change my screen brightness. After each start of the computer, all I have to do is enter the APP, and it auto saves for the current session. Point is, its a work around, it works for me on my Zorin install.