Brightness Issue

[ have HP Victus with nvidia RTX 3050
After installing Zorin OS Max brightness is very low and slider is also working opposite , when 100% then brightness is low and When 0% brightness is High]
Please help; I really want to switch to Zorin.

You might try adding the grub parameter i915.invert_brightness=1
If you have not installed Zorin OS and are using LiveUSB, here is a quick guide on how to add a grub parameter on LiveUSB:

If you have installed Zorin OS, you can boot up as normal, then run

sudo nano /etc/default/grub

and add the parameter after quiet and splash as so:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.invert_brightness=1"
Once added, tap ctrl+o, then the enter key to overwrite and save changes, then the ctrl+x shortcut to exit the editor.
Now in terminal run,

sudo update-grub

Reboot and test.

The cause is due to the manufacturer including ACPI tables (values for the brightness interface) that conflict with the set ones in the kernel.

Not working

I want my max brightness issue to be resolved , Max brightness is very low. Brightness Slider is inverted i am okay with it .

Let's try a different tactic in case the fault is in the Gnome Extension.
Add the apandada1 repository:

sudo add-apt-repository ppa:apandada1/brightness-controller

Update and install Brightness Controller

sudo apt update && sudo apt install brightness-controller

Launch Brightness Controller from the app menu and test if it gives Greater Brightness and if it is inverted or not.

okay So in Brightness Controller App Brightness slider is working fine i.e. not inverted but if i set brightness = max in App then to that is low as compared to Max brightness of windows

Thank you for your time. Please help me fix this max brightness issue. I am stuck in this issue from a long time
you can refer my detailed problem here -

This still sounds, then, like an ACPI issue.
Lets return to that...

sudo nano /etc/default/grub

Try the parameters:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Tap ctrl+o to overwrite, then the enter key to save the current configuration. Tap ctrl+x to exit the editor.
Now, you must run sudo update-grub for the changes to take effect.

Test the brightness...

1 Like

Not working
When it boots it shows this error -

And then boots with low brightness

The first AE errors are harmless and can be ignored. Or you can get rid of them by adding loglevel=3 parameter to the grub file.
The Caching errors can also be ignored or removed by modifying the /etc/modules file... I cannot remember off the top of my head the exact edit to make. I will need to look that up.

One more time... Let's try:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"
Then ctrl+o, enter, ctrl+x and sudo update-grub
Reboot - test Brightness.

IF that too fails... lets revert your grub to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" or to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=3"
Be sure to sudo update-grub after.

This is one pernicious issue. No wonder it has been driving you crazy.
Doing a search I saw:

And I see you posted on the Manjaro forum having found someone else with the same issue.

This bug report has been submitted:

And you would do well to add your issue to it as more reports get more attention.

I tried all three methods above when i tried loglevel =3 it's stuck on boot logo and not booting into the system

That is very odd. All loglevel=3 does is reduce the warning messages to tier 3 or higher. It should not have any effect whatsoever on boot...

What about

What effect did it have?

1 Like

Not worked .

i tried recovery mode
Selected advance option and then selected recovery mode it boots up with full brightness And i am not able to low it down now. It's too much bright now

Please post the contents of or a screenshot of your Grub File.

Selecting "Recovery Mode" will send you to a Recovery Menu. This does not boot into the desktop.
Selecting Advanced Options... then selecting a different kernel will boot into the desktop.
Which of these two above did you do?

i did all the things you mentioned in desktop

When you selected Advanced Options for Zorin - what step did you do next?
Did you select the Recovery Menu or did you select to boot from a kernel?

I selected third option