Brightness Issue

And with that kernel, the screen was Bright - even too bright?
Was the Brightness Controller Application or the Brightness Slider gnome extension not working at all?

in this kernel brightness slider is inverted as well as max brightness is very low
but in recovery mode max brightness is too bright and i cannot adjust it
i did all the steps you mentioned in desktop kernel

This is not clear to me what you mean.
Please state whether you mean the Recovery Menu or whether you Booted into a kernel.

Which kernel?
Did you get a different result on the 56 kernel than you had on the 72 kernel?

i did all the steps you mentioned in 56 kernel
72 kernel is not booting into desktop it get stucks at boot logo

At which point is the screen too bright?

it's too bright in 72(recovery mode)

Recovery Mode is not a Desktop Environment. Can you please Take a photo of the Too Bright Screen as you see it and post it here?

okay let me restart


When i select 72(recovery mode) it opens up system with too bright screen :point_up_2:


This is the max brightness when i select 56 generic

Ok, you are selecting the 72 from Advanced Options for Zorin - then booting into the desktop, correct?
If you do not select the 72 from Advanced Options for Zorin - does boot just hang and not proceed to the desktop?

Your Linux Default line is different in these screenshots from:

Did you revert the grub back to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"

? If so, why? You had previously said that neither acpi_osi=Linux nor acpi_backlight=vendor worked.

1 Like

let me explain again
If I select 56 generic, it boots into the system with the max brightness very low and an inverted slider.
if i select 72 recovery it boots into system with max brightness to bright and i can't adjust it
And yes, you are correct; if I didn't select the above two, it does boot but hangs and gets stuck at the boot logo and doesn't boot into the desktop.
yes i reverted back not only to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
but to every step you mentioned in order to remove the doubt that I might have done something wrong on the first try. But nothing worked in second try even

hmmm...

Let's try something. Revert grub to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Be sure to run sudo update-grub afterward.

Now;
If you cannot boot without entering Recovery first and you have the brightness issue, this may be due to the Nvidia Drivers.

sudo dkms remove nvidia

sudo apt remove --purge '^nvidia-.*'

sudo ubuntu-drivers install

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Reboot and test.
If no change - launch Software & Updates and select a different Nvidia driver. Try the 470 or try the Nouveau Open Source... See if any work properly for screen brightness.
I realize that this is tedious, with lots of rebooting but... It's the only way to narrow it down.


this is the error in first command

I skipped first step
sudo dkms remove nvidia
and successfully run all other,
They are Not working
Then i changed driver to 470 nothing happened
Then change driver to nouveau after setting driver to nouveau there is one new issue -
After booting into desktop after few seconds it hangs and go back to boot selection menu again and brightness issue is also not resolved.

That is fine - it only applies if you installed nvidia drivers using DKMS.

RTX3050... I am using the 3060 and never had any real trouble. Graphics... touchy things.

Yes many drivers are already installed
There are different versions of nvidia even .

Maybe problem is in hardware!
Hp :smiling_face_with_tear:

This worked for me

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.