Cannot Change Resolution after installing update today

I had my resolution working just fine on my Dell 34 inch screen, then installed updates today and it has downgraded to 1024x768. I've tried reading through the forums and tried changing the Nvidia driver.

Is anyone else experiencing issues after installing updates recently?

1 Like

I have a gtx 1070 card and from the nvidia settings or from linux settings i cant downgrade either. My default display is set at 3840x2160. I installed every new driver, tried a different distro all have the same result. In windows 10 i could lower it, why it is not working in Linux i dont know. Not sure if it has to do with my G-Sync monitor. Game settings i can change to whatever i want.

My wifes 10 years old hp machine with intel graphics can set resolution and select whatever she wants.

Now back to your post, do you have a built in intel gpu ? Maybe that card took over after installing the nvidia driver ? Can you post the output from this command in terminal sudo lspci|grep VGA

I just installed update on my desktop without any issue.
I have GeForce GTX 1050 Ti and using a proprietary driver.

If I try to lower my resolution on POP OS, I will get a black screen. I find Linux prefers to run in my native screen resolution.

But I seemed to have been able to change resolution on my Zorin machine, when I was forced to in dual monitor mode. This is cause the notebook screen is 1366, but the 24" monitor is 1080P. But oddly, in dual monitor mode, it wanted to run in 1280.

On a modern machine with a 1080P notebook screen, it should match the same resolution of the external monitor, but who knows. Anyways, were getting slightly off topic here.

Why he can't change resolution?

I just checked my NVidia settings panel.
I could decrease the resolution for both of my monitors:

1 Like

Well i cant, will post a screenshot later.

Yes, if the OP has an Nvidia GPU, they should use Nvidia XServerSettings to change such values maybe, more successful then trying to use the OS Display manager.

1 Like

Even if i change the resolution in the nvidia x server settings i get a black screen. I don't want to try it out because if it fails i have to do a hard shutdown.

1 Like

Yep, same here, not fun, not at all.


I am having the same problem. It seems like every few updates for Zorin my graphics get messed up.

Re-install your Nvidia driver, this has currently been the recommendation for folks who have Nvidia GPU's. If you have an AMD GPU, you probably will have to do the same.

1 Like

What is the best way to reinstall the driver?

CTRL ALT T to enter terminal, then input the following command.

 sudo apt reinstall nvidia-driver-470


Your Tech Support Guru

I tried that. It seemed to go through the motions, but I still cannot change my screen resolution.

Have you tried adding the resolution you need with xrandr?

This is all new to me, but I just ran xrandr -q and what I get is "Failed to get size of gamma for output default screen 0 minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768

I just tried installing the Nouveau display driver and everything is back to normal. Automatically updated to 3440x1440.

Are the open-source drivers more reliable than the Nvidia proprietary?

For gaming no, maybe you should try to install the nvidia driver manually to see if it works ?

That is because zorin does not come with dkms. So if there is a new kernel out and you do a upgrade you have to reinstall nvidia drivers. If you install dkms before you reinstall the nvidia driver then after the next kernel upgrade dkms takes over and you dont have to reinstall the nvidia driver.

How do we know if dkms has been installed or not?