Cannot edit menu items

I am trying to add a new menu. I have right clicked and selected edit menu which brings up the "Main Menu" window. If I click "New Menu" button a "Directory Properties" dialog opens. After entering a name the OK button will enable but nothing happens when I click on the button. The cancel button will close the window but OK does nothing.

Also, how do I move menu items to a different menu?

The new menu category will be created, but needs to be filled in order to appear within the Popup Application Menu.
Being filled means that there must be applications included in that category.

A category for an application is designated by that applications .desktop file.
For example, the gnome-boxes .desktop file has:

So if your category name matches any in that list, then clicking that category in the menu editor should show a list of applications that can be displayed in it with checkboxes. Check the boxes for any application you want placed in that category.

If your category name is truly custom, for example "Sheepsleep", then you can see how no applications .desktop file will include that...

But you can add it to the .desktop files Categories line, save the .desktop file, then it can appear.

1 Like

Sorry I don't know what you mean. If you are saying it won't allow me to add new menu because the name is not unique then this is not the case. Even if I type a load of random characters in the dialog it won't do anything when I click okay.


Coming from Windows, I must say I am less than impressed with Linux. Something as trivial as this being so complicated is baffling.

Edit: interestingly a live usb image of Linux Mint allowed me to add a new menu no problem so at least I know I'm not trying to do something that isn't possible.

Try another menu editor:


1 Like

Similar problem with those apps.

With the one installed with Zorin I have a bit more info. I have run it from the terminal (alacarte) and notice an error message appears when I click on the okay button. The error is below

Traceback (most recent call last):
  File "/usr/share/alacarte/Alacarte/", line 186, in on_response
  File "/usr/share/alacarte/Alacarte/", line 176, in save
    util.fillKeyFile(self.keyfile, self.get_keyfile_edits())
  File "/usr/share/alacarte/Alacarte/", line 272, in get_keyfile_edits
    Icon=get_icon_string(self, self.builder.get_object('icon-image')),
  File "/usr/share/alacarte/Alacarte/", line 58, in get_icon_string
    filename = editor.icon_file
AttributeError: 'DirectoryEditor' object has no attribute 'icon_file'

The error suggests that the add is failing on clicking okay because there is no icon set for the menu being added. However the Directory Properties dialog doesn't have the option to set an icon. Only "Name" and "Comment" as in my screenshot earlier. So I don't see how this has ever worked in Zorin OS.

Also there is no cut and paste buttons like you get in the same app on Linux Mint.

I just tried with both Lite and Core editions, on Zorin OS 17. It work fine on Lite but I also don't see anything happening when I try the same on Gnome. I wonder though, is it a bug with Core or just this specific version? Unfortunately I don't have a VM around to try, right now.

1 Like

@zenzen I am glad you posted this because I was getting baffled as I am not experiencing this issue or any troubles. But I am using Zorin OS Lite.

@Outlander, you can try MenuLibre

sudo apt install menulibre

and see if it allows you to set the directory.

I will comment on this a bit below.

We all feel this from time to time. I have been a Windows OS user for the majority of my life. And I do recall it baffling me entirely and stuff that should work, just not working. Installations not working and strange error messages that result that really do not help troubleshooting.
Any system can have hiccups or errors (bleepingcomputer dot com...)

GnuLinux can be very rewarding, even if there are moments of troubleshooting or frustration.

In the item properties, click on the icon shown. That allows you to assign a new icon or change the existing icon.

What I thought was a default icon is nothing. So I wasn't even trying to add one. Of course, then I could not add any new menus or menu-items, as there was no icon. Not sure why it couldn't just have a default icon.

Thanks to all on the thread above, which was a big help for me.

This was the solution. Thanks. It really isn't obvious that you need to click on that folder icon and then select an icon file (which are a pain to find I might add). I think this is the thing for me. Linux is just so complicated compared to Windows even to do such simple little things. I don't have the time for this really.

It is still a pain because I now want to move some items from other menus into the new one and, unlike Linux Mint, it doesn't have cut and paste buttons in the menu app. Why is that? It seems to be the same application and yet Zorin can't cut and paste menu items but Mint can.

That's a matter of perspective, really. The reality is that Windows is not Linux and Linux is not Windows, so it's natural to meet some resistance as old habits die hard.

I've been using Linux daily for a few years now, and I struggle to get something done in Windows that'd take me seconds otherwise in Linux. And not because "Windows is complicated compared to Linux" but because I'm not used to it anymore.
I had the exact same issue when I first used MacOS, and then again with Linux, after decades of using Windows.

Now, a lot of work has been done in recent years to make the desktop experience on Linux much better, but there is still plenty of room for improvement, such as in this particular example. One reason for this is precisely because of what makes Linux great: modularity. The same technology can be implemented in different ways which makes it highly flexible, which is why it may look and behave differently in Zorin OS Lite than it does in Zorin OS Core or Linux Mint.

With all that said, you should definitely use whatever works best for you. Personally, I don't use the main application menu anymore, ever since Windows Vista, and later Windows 7, made the search functionality so good that it basically made the menus a thing of the past. Just hit Super/Windows key, type what you want, and Enter.