Cannot log in to zorin when I open the lid


When I open the lid of my notebook, appears a message "click or press a key to unlock".
I click on the keys but nothing happens. To log in to zorin, I need to click on the power button to turn off the computer, and then click again to restart the computer.
This is very annoying. Any help regarding this issue?


Is your keyboard working at that point?
For example, does the keyboard work to enter TTY?
Or is the driver for it not loaded and the keyboard is 100% unresponsive?


When I open the lid the keyboard is 100% unresponsive. After turning off the computer and turning it back on, I can use the keyboard and type the password to log in.

Then it sounds like sleep or suspend is not allowing keybaord to re-init on wake.
Do you have Secure Boot disabled in your BIOS settings?
Are you using a USB keyboard rather than the builtin keyboard? Have you tried it, if not to test this?
Have you checked firmware is up to date?
Have you tested using Wayland and using Xorg (X11)?

I dont know how to disable or enable the secure boot. I did a clean install of zorin and I didn't change these settings.

I have now connected a keyboard via USB and I can write and log in, with the keyboard that I connected via USB, but with the builtin keyboard I cant.

The firmware is up to date.

Sorry, I just got to Linux today , I dont know what is Wayland or Xorg.

This is a BIOS setting on all computers and not GnuLinux specific. You can look up how to access your manufacturers BIOS settings on the web - it varies depending on the maker.
The Secure Boot option will be in the Security tab. Secure Boot acts a bit like a bouncer at an exclusive club - rejecting anyone whose name is not on the list of expected attendees. It is built for Windows, though efforts were eventually made to permit GnuLinux access.

Wayland is a new protocol for desktop display management. Xorg is the tried and true reliable protocol we have been using.
Everyone is very opinionated on the wayland vs. xorg debate... So, I will not go into details there... But the short of it is that it is that Zorin OS 17 is the first Zorin OS edition to default to Wayland. It is often worth trying using the reliable Xorg to see if that gets things working.
You can switch between them from the Login screen. Instead of entering your password and logging in, click the gear icon and select Zorin Desktop on X
Then proceed to login.
If you do not see the gear icon, then click as if to log in as another user, then the gear should appear - after setting your desktop, then login as yourself as normal.

Already tried the two options, and the problem persists.

And unfortunately cannot enter BIOS settings, tried all the shortcuts and cannot acess it.

Im afraid I cannot solve this. But thanks for trying to help.

This may also be a kernel issue, where the sleep message is sent, but not ended upon wake.
Trying out a different kernel is usually an easy thing to do - which we can try to see if that helps.

If you list out your make and model and specs, we can take a closer look.

Its a Macbook 12-inch Retina Early 2015. 1 GHz , 8GB RAM. Intel HD Graphics 5300. Do you need more info? many thanks for your help

You may have some luck with an earlier kernel. Be aware that when you install an earlier kernel, in order to boot into it, you must tap esc or tab at boot to show the Grub Menu (If it is set to not show by default) and then select Advanced Options for Zorin, then Zorin on 5.15.0-83 to boot into it. Otherwise, it defaults to the newest kernel. If in testing, the earlier kernel works properly, you can set it as your default boot.

Install the earlier kernel:

sudo apt install linux-image-5.15.0-83-generic linux-headers-5.15.0-83-generic linux-modules-5.15.0-83-generic linux-modules-extra-5.15.0-83-generic

Boot into it and test...

Sorry the time you are wasting with my issue, but Im new in the linux scenario, tell me just one thing, that command I should put in terminal app? And then I should restart the pc ? Thanks

Yes, that is a terminal command to install the list of packages shown in the command. Be sure to watch the terminal output in case there are any errors. The beauty of putting installs into the terminal is it is verbose and keep you informed.

Once successfully done, reboot the PC.
Enter Grub Menu upon reboot and select Advanced Options for Zorin in order to choose the earlier kernel to boot from. It will appear as a List; you will be looking for
Zorin on 5.15.0-83

Hello, After reboot, I dont have the Advanced Options for Zorin.

You must enter the grub menu. At boot, try tapping esc or tab (EFI Boot) or if using MBR boot (Legacy), hold left shift key.
This should pull up the grub menu.

This time I managed it, the terminal command was entered successfully, I restarted the machine and went to Zorin Advanced Options, and chose Zorin in 5.15.0-83.
But the problem remains. When the computer restarts I can use the keyboard, but after closing the lid, and opening again the keyboard and the trackpad no longer works. I can only log in successfully if I restart my computer again.
It's a shame I can't resolve this because I really liked this operating system.

We have established that changing the kernel will not make a difference, so now we can try Grub parameters to see if that resolves it.
you can edit grub file with

sudo nano /etc/default/grub

If you prefer GUI:

sudo -i


Navigate to /etc/default/grub and right click the grub file and select open with > text editor

Move to this line

and add the parameter i8042.reset:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"
If using the terminal ttext editor (Nano) then tap ctl+o to overwrite, then enter to save configuration, then ctl+x to exit the editor.

You must run sudo update-grub in terminal now for the changes to take effect.

If the above parameter does not work, here is a list of parameters that you can try:


I tried all the parameters, but unfortunately it didn't solve the problem.
I follow all the steps.


I tried all the parameters, but unfortunately it didn't solve the problem.
I follow all the steps.

Did you remember to run

sudo update-grub

after making any changes to the grub file?

Did you reboot?

Yes. Rebooted every time. Is there anything else I can do?