Canon Pixma iX6850 does not print from LibreO

Connected via USB,
Zorin 16.3 Pro recognized printer by model number.
"ready"... in LibreO, iX6850 selected as default.
screen reports print job sent...
(no reaction/sounds from printer, i.e. print head reposition, drawing paper into feed, etc)
then, several minutes later, "printing completed"...
nada, nix

User/Settings/Printer "Ready" > "Test Print"
"Processing"... "Completed"

Same-same, nada

As I have stated elsewhere, the latest Linux kernel can identify printers and you should see somewhere that it is a driverless printer which means you need to install Canon's Linux driver from here:

Scroll down until you see the link for Linux driver 4.10




"your file couldn't be accessed"


dead end
(ended up at "

Stumbled across:
sudo add-apt-repository ppa:thierry-f/fork-michael-gruz

sudo apt install scangearmp2

sudo apt install cnijfilter2


plug and pray

At "printers", shows:
canon iX6800 series ver. 4.10
still no printing...

have you tried installing the Canon Supplied Linux Drivers?

1 Like


Printers was showing
Canon iX6800 series ver.4.10
Canon iX6800-2
canon iX6800 serie... S+Gutenprint v5.3.3

in the lower left, next to time/calendar, a small printer icon with "1"
Tried printing from all 3 printer options... no luck

Is the printer connecting through WiFi or through a hardline cable?

USB cable
fwiw, printer works without problems with yet-to-be deleted Win10-64Pro machine

Can you please test connecting via WiFi and test printing?
Sometimes, that (for reasons I do not understand) gets things working.

1 Like

Still no luck...
First, "kitchen" PC I am trying to print from is connected to the 'net via wireless ("router")... which is why printer is connected directly via USB.
Printer appears to be connected to router via Wireless.(Blue indicator)
Unsure if Kitchen PC will find printer wireless over router?
Yet-to-be-deleted Win10 -64 pro PC, connected via Ethernet cable, to router... also does not "see'/"find" iX6800. have never used wireless to connect my printers...fwiw.
Also, printer generated "Network Configuration Page"
Thank you for your patience,

I could say the same. Printers are, by far, my weakest subject.

They are fickle, finicky and testy little creatures that when they are not ignoring drivers, are being toner bombs.

Have you tried

sudo apt install printer-driver-gutenprint

You might try attempting a print job, then afterward, running

tail -f /var/log/syslog

and see if there is anything logged that may provide a clue.

Agreed... (and thanks)
over the last 50 years of my computing experience(s)
printers, far and above wireless connections, has always been...

results of your recommendations:
printer-driver-gutenprint is already the newest version (5.3.3-4).
printer-driver-gutenprint set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

failed to launch javaldx - java may not function correctly

again, really appreciate your patience,

This is unrelated... But you should be able to handle that with

sudo apt install default-jre libreoffice-java-common

Do you have cups-backend-bjnp installed? If not, can try installing that.

Do you have ippusbxd installed? If you do, remove it and then reinstall your printer drivers and test printing...

do not know if cups-backend bjnp is installed...
CUPS-BRF-Printer does show up under "Printers"

would you type the context to "remove ippusbxd" ? (for copy/paste to terminal)
Haven't the faintest idea if it is installed... or, what that is.

You can run:

sudo apt install cups-backend-bjnp

and it will install if it is not installed - or say if it is already installed.

You can see all installed software by using apt list --installed command.
By using a pipe (|), you can pipe specific output. Use grep to specify what that... in our case at the moment, the specific package is ippusbxd.

apt list --installed | grep ippusbxd

Aggravating as the printer may be - it is helping with learning.:wink:

I believe Ippusbxd is a package that checks to automatically setup Printer Drivers. The automaton may be interfering with your manual install process.

"pipe"... no joy one my keyboard...

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

ippusbxd/focal,now 1.34-2ubuntu1 amd64 [installed,automatic]