Can't copy/move files to external drive Z16 pro

Okay, so the noob in me is in full force today. I'm trying to copy some files onto my external drive, but it won't allow me. Yes, I've checked the permissions which say I have full write privileges, but I can't create a new folder in it, and I also can't copy a folder to it.

In terminal I get this error: cp: -r not specified I can't find the answer on google. Can someone here explain, please?

1 Like

If this is what you are entering into the terminal, that may be why the error.
There should not be a ( : ) colon.

No, that is the error I am getting back on terminal. I'm only using sudo cp with the file names after it. Here is the copied terminal text...

`char@char:~$ sudo cp '/timeshift' '/media/char/2CCEFF02CEFEC2DE/aaScans'

[sudo] password for char:

cp: -r not specified; omitting directory '/timeshift'`

It's asking you to specify recursive copy, I think.

sudo cp -r '/timeshift' '/media/char/2CCEFF02CEFEC2DE/aaScans'

Uh huh. I already did. This is what it gives...
cp: cannot create directory '/media/char/2CCEFF02CEFEC2DE/aaScans/timeshift': Read-only file system

The thing is though, under "properties" - "permissions" it is set to my user & "create and delete files"

Media is a mounted file. It may have mounted in read-only state. It is supposed to mount as r/w by default... Have you tried unmounting and remounting it?
This guide may help (Ignore ntfs and the commented portions. Change the example /dev/sdb1 to be your actual drive directory):

If that is not working, you may need to check your fstab.

This is so very over my head. I just don't understand why I cannot simply plug in my external drive and use it like I do my flash usbs?

Why do I have to go through all this coding messing with my partitions? I don't want to risk that... especially after yesterday and nearly losing my entire computer to a "simple" bug fix.

I have zero clue what I'm doing here. Things that should just be simple in Linux, are not.

1 Like

I feel your pain because... I don't just mean it should do that... I mean that in Linux, as it is, it is supposed to do that. It is coded to do that.
I have an external HDD, as well. I plug it in and I have read and write permissions. I copy files back and forth all the time. It works by plugging it in.
Something in your case isn't.
You might try using the terminal to just double check that permissions are granted. The terminal never misses even though a GUI app can. Fill in the blank...:

sudo chmod 777 /media/____

If the external is formatted to ntfs (The nt file system is exclusive to Windows Only), Linux can read it, not sure if it can write or not... What format is the external drive?

I'd never copy files from one disk to another via terminal before chance to learn more I guess.

That returned

read-only file system

But my understanding from researching pre linux install was that I could use external drives as the go-between for my dual boot. No matter how much I dislike Windows, I am unable to ditch it because of work. But I'm trying to do as much of my work here on Linux as possible.

As a side note: I do have access to my Windows install in the folders here and can copy and add files (just not delete/move files) so I'd imagine it would be no different for an external drive, no?

Yeah, I'm just having a rough go of getting things to work for me in Linux. I have no idea why. I realise my computer is "too new" and high-end for Linux's software. But the basics are what are killing me. If it weren't for you helping me all the time, I'd have ditched Linux days ago.

I'm sorry. I have no idea what you're saying here.

Does the drive work on other OSes?

Sometimes drives no longer work.

Thanks @a_user . Yes, it still works. It isn't corrupted or anything. But it is about 4 yrs old. Could this play a factor in the issue?

Is the HDD formatted to NTFS?

You might try (Again, fill in the blank)

sudo mount -o remount,rw '/media/_____'

If the external hdd is ntfs, I am not sure if this is even supported anymore but, you may try:

sudo ntfsfix /media/_____

This one above may be useful if the external drive was unmounted on Windows while the files were still locked.

I have experienced this exact issue as well. I remember not finding any solution to it. But, a clean re-install solved the problem and I have not encountered it ever since.


Thanks @Aravisian I'll give this a go later today... fingers crossed.

Oh god... a reinstall? Well with the issues I'm having with my graphics card, bluetooth, sound, and now the external hd... I'm thinking you may be right... :sweat:

1 Like

Yeah don't worry about it. On my first Zorin install I was also a bit careless with how I handled my system but from that point onwards, I took more care of my system to ensure its nice, clean, and smooth.

1 Like

I haven't been careless. It's that I have a very high-end computer that seems to disagree with Linux in many ways. Gah! It's a struggle to get everything working correctly. This is the 3rd distro I've tried in 2 weeks. Really want to make it work.

Just did a fresh install and still, the external hd issue remains. :woozy_face: