Can't play any video or music from Spotify or Firefox browser

In YouTube it just says to reboot. Spotify says “Cant play the current song”.
I have managed to get this log using spotify --v:

Gtk-Message: 15:36:10.598: Failed to load module "gail"
Gtk-Message: 15:36:10.598: Failed to load module "atk-bridge"
Gtk-Message: 15:36:10.602: Failed to load module "canberra-gtk-module"
MESA-LOADER: failed to open radeonsi (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load driver: radeonsi
MESA-LOADER: failed to open kms_swrast (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load swrast driver
MESA-LOADER: failed to open radeonsi (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load driver: radeonsi
MESA-LOADER: failed to open kms_swrast (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load driver: kms_swrast
MESA-LOADER: failed to open swrast (search paths /snap/spotify/42/usr/lib/x86_64-linux-gnu/dri)
failed to load swrast driver

I have tried installing the missing modules but it says that they are already installed.

Edit: forgot to say this happened after latest update (06/10/2020)
Edit 2: Manage to get this usinb spotify --show-console :

Play track (playback_id xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)
19:55:58.741 I [audio_player_queue_impl.cpp:939 ] Unpause driver (0x7f43fxxxx740)
19:55:58.742 I [head_file_streamer.cpp:208      ] Requesting head file from CDN url: https://heads-fa.scdn.co/head/beacc9fb58383858de566e8da9f6a6d18c751d22 
19:55:58.742 I [connectivity_manager.cpp:344    ] Playing music set to 'true'
19:55:58.742 I [connectivity_manager.cpp:149    ] Scheduling emission of signal.
19:55:58.758 I [connectivity_manager.cpp:140    ] Emitting signal.
19:55:58.870 I [libvorbis_ogg_decompressor.cpp:408] track gain: (-8.49Db), track peak: (1.00905dB), album gain: (-8.55dB), album peak: (1.01806dB), normalization: trackgain
19:55:58.871 I [audio_player_queue_impl.cpp:766 ] Opening driver (0x7f43f888b740)
19:55:58.871 I [audio_player_queue_impl.cpp:767 ]     sample rate: 44100 Hz
19:55:58.871 I [audio_player_queue_impl.cpp:768 ]     channels: 2
19:55:58.871 I [audio_player_queue_impl.cpp:769 ]     sample format: 32-bit-float-pcm
19:55:58.871 I [audio_player_queue_impl.cpp:770 ]     stream type: default
19:55:58.871 I [audio_player_queue_impl.cpp:771 ]     audio content type: music
19:55:58.871 I [audio_player_queue_impl.cpp:772 ]     paused: false
19:55:58.871 I [audio_decompressor_process.cpp:267] Opening sink for playback.
19:55:58.871 I [audio_decompressor_process.cpp:268]     codec: vorbis
19:55:58.871 I [audio_decompressor_process.cpp:269]     bitrate: 320000 bits/s
19:55:58.872 I [audio_decompressor_process.cpp:270]     sample rate: 44100 Hz
19:55:58.872 I [audio_decompressor_process.cpp:271]     channels: 2
19:55:58.872 I [audio_decompressor_process.cpp:272]     sample format: 32-bit-float-pcm
19:55:58.872 I [audio_decompressor_process.cpp:275]     duration: 154421 ms
19:55:58.872 I [audio_decompressor_process.cpp:428] Restarting decompressor.
19:55:58.872 I [audio_decompressor_process.cpp:429]     pos: 7541 frames
19:55:58.872 I [audio_decompressor_process.cpp:430]     offset: 4193 bytes
19:55:58.885 I [audio_decompressor_process.cpp:562] Starting playback.
19:55:58.885 I [audio_decompressor_process.cpp:564]     min limit 4000 ms.
19:55:58.885 I [audio_decompressor_process.cpp:565]     compressed buffer: 123344 bytes
19:55:58.885 I [audio_decompressor_process.cpp:567]     decompressed buffer: 0 ms
19:55:58.885 I [audio_decompressor_process.cpp:569]     sink buffer: 1021 ms
19:55:58.885 I [audio_decompressor_process.cpp:570]     final source buffer: false
19:55:58.890 I [audio_player_queue_entry.cpp:359] Entry (0x7f43fxxxxx8) is not buffering
19:55:58.890 I [audio_streamer.cpp:1091         ] Encrypted data 64k-latency: 2 ms. Play latency: 150 ms
19:55:59.057 D [connect_state.cpp:182           ] ConnectState::updateCluster: didUpdateCluster 1. Cluster timestamp 1602014159017
19:55:59.072 I [request_accounting.cpp:461      ] High request latency: https://heads-fa.scdn.co/head took 309 ms
19:56:03.034 E [pubsub_subscription.cpp:619     ] aq: LWS got LWS_CALLBACK_CLIENT_WRITEABLE
19:56:03.113 E [pubsub_subscription.cpp:619     ] aq: LWS got LWS_CALLBACK_CLIENT_RECEIVE_PONG
19:56:34.039 E [pubsub_subscription.cpp:619     ] aq: LWS got LWS_CALLBACK_CLIENT_WRITEABLE
19:56:34.533 E [pubsub_subscription.cpp:619     ] aq: LWS got LWS_CALLBACK_CLIENT_RECEIVE_PONG
19:56:40.128 3 [playlist_be_pl4_context.cpp:353 ] [spotify:playlist:37i9dQZF1E4WbdX4rBsvcE] Synchronization starting: GET (from revision 0,726f6f7400000000000000000000000000000000) 
19:56:40.206 5 [playlist_be_pl4_context.cpp:226 ] [spotify:playlist:37i9dQZF1E4WbdX4rBsvcE] 'GET' request complete
19:56:40.206 3 [playlist_be_pl4_context.cpp:481 ] [spotify:playlist:37i9dQZF1E4WbdX4rBsvcE]  synchronization error: Hermes error code 404 (404 - not found)
19:56:40.206 3 [playlist_be_pl4_context.cpp:515 ] [spotify:playlist:37i9dxxxxxxWbdX4rBsvcE]   - list does not exist or access is denied.
19:56:59.778 3 [playlist_be_pl4_context.cpp:353 ] [spotify:playlist:37i9dxxxxxWTSkZ0cxkrLT] Synchronization starting: DIFF (from revision 1602013091,0000000002b23bbb8c4e4f76389a0b27e02bba83) 

I think I found the issue: https://bugs.launchpad.net/ubuntu/+source/curl/+bug/1832882

Though the package is no longer available tried installing the libcurl3 7.72 but it did not installed, and Cant force version in synaptic because it does not find it.

Hi Stevendotcom.
Did you use the terminal instructions under " Install via command line" -> " Debian / Ubuntu" (bottom of page) at: https://www.spotify.com/us/download/linux/ to install Spotify? I’m not referring to the Snap.

Just installed the Debian/Ubuntu version and it did not work. Also tried removing Snap’s Spotify and its stuck at “Save data of snap “Spotify” in automatic snapshot set #2

Could you please use Synaptic to Completely Remove all Spotify from your computer?

Then copy and paste the following into terminal and report back your results:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 4773BD5E130D1D45

sudo add-apt-repository “deb http://repository.spotify.com stable non-free”

sudo apt install spotify-client

Then, in terminal test by running spotify (look for any errors in terminal if it starts):

spotify

It throws Error: need a single repository as argument while trying sudo add-apt-repository “deb http://repository.spotify.com stable non-free”

Ok, instead try

echo deb http://repository.spotify.com stable non-free | sudo tee /etc/apt/sources.list.d/spotify

Now I could install but it shows the same error once I try to play music, the log using –show-console is the same. It does not play videos from youtube either, so the problem does not seem specific to spotify

Looking this issue up- it seems common and it seems the ‘fixes’ have a lot of variety…

All we can do, really, is start trying each fix…

Tried everything, didn’t worked. Also when I try to access the location of downloaded songs through Spotify’s button “Change Location” it simply crashes

It only displays “segmentation fault spotify --show-console”

Also tried with netflix.com, and it didn’t worked. Then I tried downloading a video and it did played. I don’t know if that helps to narrow the problem.

I can make a quick reply- but then have to run.

Don’t worry.

FYI, it didn’t work, it opens but it cannot play the music. It does give the error libcurl.so.3 cannot open shared object file so it might be because libcurl3 it is not installed. Tried using this, and it shows like it was installed, but the error is the same.

Going to dig a bit more tomorrow but college does not passes itself.

This thread has a proposed solution:

Hi Stevendotcom, I think if you installed originally the snap package you may need to follow these snap removal instructions to completely rid your machine of this leaky piece of software (security issue):

Or first try the method for spotify like AZorin advised another user about another snap package: