Can't play Windows only games on Steam even though I have Steam play enabled

I have been trying to play windows games through stream but nothing works. I have tried many version of it, checked my drivers, tried to look if I had any 32bit libraries, checked the compatibility of the games.

Go to the Software and type GameHub - Download that and then run it and let it log you into steam and it will list all your games i had a similar issue but since i installed this everything works fine just run the games thru the hub not sure why they dont run direct from steam but this solved my issue

Have you got Wine Installed ?

1 Like

Did you download the proton in steam ?

Please read the tutorial here

Why using that while you can download the official steam client for linux ???

I have got the main Steam client for linux - but no matter what i do no games will run via the steam client - and after downloading Gameshub if i go thru that all my games work so im not sure what steam is doing etc - i have stream play on and ive tried all the version of proton including gloriuseggroll and nothing works - i have the latest wine install and wine tricks - but for some reason after installing games hub they all run when i go thru that

Because you probably did not install steam proton.



Weird because it should work, if a game does not run you can always try a lower proton version.

1 Like

yes ive tried different version and gone in to setting on steam and set the individual games to run on a specific proton version - all that happens in steam is say the game is running and then is just cycles back to launch again, it never actually starts but like i said since i installed the games hub it seems to correct what ever going on in steam ,but thanks anyway for the info

2 Likes

I am still wondering why you need an alternative app to run steam games. Did you read my tutorial prehaps ?

Did you download these 2 applications/tools as well ?

  1. Steam Linux Runtime - Soldier
  2. Steamworks Common Redistrubutable
1 Like

Yes i have them both - the way im looking at it - somewhere along the line either the path or directories have got messed up some where and steam dosent look in the right place either for wine or proton and what ever this app dose its find the correctory directories or paths cause what i notice is when it launches a windows game thru steam it dose nothing - steam will say running and then it will just end , where as if i run the game thru the app steam will launch and then wine will launch follwed by the game so that why im thinking its the path or directories i installled wine manuallay not from the store cause i wanted the latest wine version.

1 Like

Do you install these games on a ntfs partition ?

hi bud - ive tried doing them on fat and ntfs and still dont work also having another issue as well know im trying to add my games to a second ssd - so i add the directory to steam ,download it via steam and the game wont run either on the second drive and its the same game i already have installed on the main ssd as Zorin Os - so i just dont get it at all and ive also copied games from original install folder to second hard drive and the same games that run on Main drive dont run on second ssd so i just dont know whats going on with it

1 Like

I really don't know what is going on on your end. It's very weird to me.

yes i know and this is not the first time steam been like this either - i have pop os on another ssd and that does exactly the same as well regarding the steam directory it will not launch games that are in a different directory other than where the main OS

I am running Pop! OS 21.04 and upgraded to 21.10 and i don't have ANY issues with steam. I configured 3 drives for steam and they all have 1 game installed and it works perfectly fine. I wonder if you use steam flatpak ?

I will check that - i did find this in reddit -

  1. Open Disks
  2. Select the disk that contains the steam games folder.
  3. Select the basic data partition and click on the settings icon below it.
  4. Select edit mount options...
  5. Disable user session defaults
  6. Make sure Mount at system startup is checked.
  7. Under the Symbolic Icon Name, there is a line that starts with nosuid,nodev, .... Add to that line " ,uid=1000,gid=1000 " at the end of the line. (Without the quotes).
  8. Hit OK to save the custom settings you've just applied.
  9. Reboot your system. and VIOLA! (It should fix the problem)

but i tried it worked once but didnt work after a reboot