Can't turn on keyboard backlight on Asus Laptop

I'm not sure, if "General Help" is the right place to ask but I have an issue with my laptop. I installed Zorin 16.3 Pro on my Asus laptop (UX461UN) from 2017 because it was getting slow and sluggish even on a fresh Windows 10 install and I want to transition to Linux.
Unfortunately, for some reason, I can't turn on the keyboard backlight for years already and had hoped to somehow get it fixed on Linux. I believe this problem started years ago when this laptop was having overheating problems and I sent it in during its warranty to get it repaired. I hadn't used my laptop much back then but suddenly realized the keyboard backlight didn't work anymore (was after the warranty had ended) with the keys showing abnormal behavior (the function key shortcuts would just open the pre-installed mail client (fn+f3) or open the main browser (fn+f4). Interestingly, this doesn't affect the leds of the capslock or flightmode being turned on.
After a little research, I found out how to view any installed backlit devices but unfortunately, the one that I was looking for ("asus::kbd_backlight" or anything similar) isn't in that list. Trying different approaches mentioned here or here also don't work. Probably because the keyboard backlight device just isn't there anymore for some reason.

Sorry for the long post but I had to give some context. Does somebody have an idea that could help me get the keyboard lighting to work again?

Short summary:

  • Asus UX461UN doesn't have keyboard backlight probably since being "repaired" for a different reason.
  • The corresponding function key shortcuts have totally different functions.
  • Assuming it should be this one: the device "asus::kbd_backlight" doesn't seem to be installed or available.
  • This is a fresh Zorin 16.3 Pro installation

Thanks in advance for any help!

Have you yet tried the Grub Parameter acpi_backlight=vendor?

Be sure to remember to run sudo update-grub after changing the grub file.

Thanks for the quick response. I tried adding it according to the how to but it didn't do anything...
On another note: is it possible to change the function key shortcuts somehow? I think maybe that could work but I can't find the fn keys in the keyboard shortcuts settings.

Are any regional language keyboard layouts set?

Only English US so far

And you had the computer worked on at a shop - was the keyboard replaced? Have you tested it using WIndows OS?

Have you tried through Settings? There should be a slider to adjust brightness for keyboard under display brightness, somewhere - not directly under display brightness it in my Settings.

Also have a ZenBook (aptly named ZorinBook :smirk:) - is your Fn sticky-keys enabled? Usually Fn+Esc - mine has an LED on the Fn button. If the LED is on, then I have to use the Fn key plus the F1-12 keys. If it's off, then Fn sticky-keys are enabled, and I can change brightness or volume without pressing Fn+F1-12. If that helps.. I do have another laptop with a backlit keybaord, Toshiba - doesn't work anymore, not since Win10 updated. Not even Mint works anymore.. But, if Fn sticky-keys (probably not even the right terminology lol) are enabled, and I use the Fn key plus something, it just acts as normal function keys. That's what makes me think maybe it's enabled - could be wrong!

I sent it to Asus themselves but I don't know what they replaced. I believe it was the mainboard which wouldn't explain the keyboard issue though.. I had Windows on it until today and yes those 2 buttons always showed the same behavior

Nice name, I might have to borrow it for mine as well now haha

But no, there is no way to "stick" the fn key. Also, the keys all work and do what they should. It's just the fn + f3/f4 combo that for some reason opens the mail client or firefox, respectively, instead of changing or even just turning on the keyboard lighting...

No worries - have at it! I really wish I had a laser engraver :wink: it would absolutely have to be permanent at that point. Managed to find a metallic 'Powered by ZorinOS' sticker for now haha

Alright - so I did have to modify one action for taking a screenshot. My keyboard has a click-n-grab screenshot button that does work in Win, however in Zorin it did not work the same .. BUT - I did figure it out - I just can't remember how I came up with this, but the Fn+F11 combo for screenshot turned out to be Shift+Super(Windows key)+S - and I got the selective screenshot cursor. Had to look at my shortcuts to even remember that combo lol but, when I hit Fn+F11 - click-n-grab! I'm going to see if I can try hunting down the key combos again... there may be one for each F button the correlates to an Fn+something action :sunglasses:

Which F-button is your keyboard brightness? Mine is F7, only one key - off, low, med, high, repeat..

(edit) Did find some stuff on possible firmware mismatch.. I'm not sure what hardware you've got though - can you use lspci to maybe see the keyboard?

(edit edit) What do you have in /sys/class/leds/? There should be a asus::kbd_backlight directory - in there should be some files. Take note of the brightness file content; if you modify the brightness file from a 0 to 255 - does that turn it on? You can try this with echo 255 | sudo tee /sys/class/leds/asus::kbd_backlight/brightness to see if this works. If so, that could be used for a shortcut.. If not, you can change the 255 back to a 0 or the original entry as noted in the file before modifying. I see my setting is 3 in the brightness file when on the brightest setting - I don't know if this would be the same for yours though :person_shrugging:

Haven't really progressed so far but with libinput I could at least see that my FN + F3 and F4 combos are actually showing something like mail-key and www-key (or something like that), respectively. How to re-bind those I couldn't find out yet.
Apparently, it's possible with this driver but I have no clue and google is also of no help in finding out what the event numbers for the backlighting functionality may be.

As for your edit: no, I don't have the kbd folder in there... I understand that it should naturally be there but is there a way to install that somehow? Maybe this would at least let me turn the lighting on or off with the terminal..

1 Like

Are you on the standard issued Zorin kernel -- 5.15.0-88-generic? I've been reluctant to try updating to a 6.x.x kernel myself, having a 'newer' setup - when was your machine manufactured? I think my ZenBook was a '21 production - another laptop I picked up in 2022 likes only 6.2.x and above, nothing from 5.15, or 5.19 though, no keyboard backlight at that.

There is a guide in the forums on updating the kernel, safely - here - might just be kernel support missing; that's usually my case with missing usability...

I'm going to do a little more research on this - there has to be an actual answer somewhere out there :thinking: -- apart from kernel and extra setup stuff manually installed. .

You can also run

sudo apt remove --purge xserver-xorg-input-all

if you are using libinput.

1 Like

See if this guide helps:

  1. open a terminal.

  2. sudo xmodmap -e 'add mod3 = Scroll_Lock

  3. enter your password.

  4. press the scroll lock key to see if your back light comes on.

  5. If it does, you can either enter that command every time ubuntu boots, or have it run automatically at startup.


Do you have this in Settings --> Power?:

Right under Screen Brightness there may be a Keyboard Brightness slider - if it's not there I'm assuming it's not being recognized.. or.. possibly, and I'm really hoping not - when it was repaired, they may have missed a ribbon cable somewhere, or hopefully not replaced with a non-backlit keyboard :grimacing: .. Check settings though; I'm interested if it is there, could it be turned on from there :thinking:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.