Cant update firefox

Hello Zorin people,

I have been running the default firefox (ff) 82 on zorin 15.3 since October 2020. I would like to update ff to the latest 85. However it does not automatically do this and under preferences in ff there is not option to allow auto updates. I am running as administrator, or at least I think I am as I am the only user created during the Zorin install.

I have installed ff from the zorin store which gives me the latest v85, that gives me a bit more info in that it tells me I do not have admin privileges to update it and that option is greyed out.

I have also installed ff 85 by downloading the tar from mozilla. That instance of ff does allow for auto updates.

All three work.
In synaptic, v82 can only be marked for removal. It seems to be tied to the ubuntu base os.

I would like to update the v82 instance to the latest as it has bookmarks and auto login cookies. If it werent for this (in)convenience I can easily delete and go with the manual install.

This behaviour is strange as I have also installed Zorin on a laptop and it seems to auto update the default ff. I cannot tell what is the difference between the laptop and this desktop version that is giving me problems.

Anyone have any ideas on what is wrong or how can i update the default ff version?

Many thanks
sj60

Check your updater settings.
For me, Firefox shows as 85.0.1 on Synaptic, so likely update issues.

1 Like

Thanks for your reply!
The first screen pic listed under the Other Software from your link Software Updater settings - I do not have any of these entries in mine. Screen shots in mine are below:

Software & Updates_001

Software & Updates_002

How should I go about adding those show in your screen shot?
I do not know the ATP’s for the “Recommended updates”, “unsupported updates”, and “Important security updates”.

thanks!

Use the Add button to add repositories or try this. If you use the first method, add all the repositories shown in the pics on that update settings thread but ignore the wine and cdemu ones.

I think I am missing something. When I select the Add button I am greeted with a request to insert a url (APT) address for the repository I’d like to add which unfortunately I do not know. No list is made available for me to select from.

Can you open Software and Updates and on the first tab that opens, you will see “Download from:” Select Main Server.
Enter PW to configure, then exit and reboot, then test in terminal with

sudo apt dist-upgrade

Unfortunately nothing was upgraded.
Also the Download from has always been from the Main Server, and selecting it again does not require my pw to validate.

I have also tried to add a volume but I do not have a CD of Zorin as I installed from bootable usb, so it does not accept the usb.

1 Like

How about the second method of the sources.list? Or, whatever Aravisian recommends.

Then we have eliminated that as a possible cause.:wink:

If I insert my USB installation media for Zorin, it still reads it as a disk that I can open, access and manage.
So we now have Two Odd things about your installation.

What happens if in terminal, you run

sudo apt install firefox

Does it only claim FF is the latest version?

Here is the Repo for FF:

sudo apt-add-repository “deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu bionic main”

Here is the key

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A6DCF7707EBC211F

running sudo apt install firefox tells me that the latest v82 is already installed, and it stops there.

Accessing the repo results in the following error:

Error: need a single repository as argument

is there a piece missing/added in this address?

agh…
Try this one, instead, sorry

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa

Thank you @Aravisian for your help.
odd thing:
before I ran your latest code, I entered your original repo address that gave me the error into Software & Updates, Other Software. This then ran but flagged me that it needed the key. Using the terminal I then ran the key. Back into Software updates, I reran the updater and it then installed and updated FF to v85.

So I am happy to report that this round about way updated my FF. However I assume Zorin is not getting updated as some of the APTs are not listed in the Updater. Another hurdle I need to address.

Agreed, because FF updates on mine and I assume Carmars- therefor that makes you the odd one out.
We need to check your sources.
The Zorin sources you listed above looked normal. And as they are the same sources the rest of us have, they are unlikely to be the culprit.
Since you added the repo, FF should now get available updates but if not- you may need the second repo I posted above.

that does describe me to a T in pretty much many things :laughing:

1 Like

When you open software and Updates, what does it show on Updates tab?

This is what it shows:

Software & Updates_003

And this for Other…

Software & Updates_004

“Other”
All of that looks as it should be. I cannot vouch for repos you added such ans suldr/debian extra but the Zorin Repos are right.
Not sure why FF was being a pita, but you might just keep an eye on it and see if it starts updating now that you have added repo for it.

1 Like

FYI. I got FF 85.0.1 via Software Updater yesterday, so sj60 is odd one out.

Assume FF was installed from apt not Snap, yes?

Not sure @zabadabadoo wrt apt or snap-- mine is the FF that came with Zorin. For some reason it was not updating. And as I mentioned above, I am worried that Zorin is not updating either as I have not seen it updating in the past month at least. I had a laptop that updates regularly Zorin and FF- as it would indicate this on boot up. Both this PC and the laptop were installed from the same USB iso. I gave that laptop away the other day so I no longer have it to compare in detail. So like you said, I am the odd one out !!!