CD Ripper "fre:ac" used to work, but now it doesnt. I get this error


I then tried to install FUSE & it appears to be installed now. But I still get the same error. I dont know why fre:ac stopped working, it recently worked fine. This is the portable AppImage version of "fre:ac".

After this, i tried another solution, i installed fre:ac via the GNOME software program database. But it wont recognize my cd drive in my laptop for some reason. The AppImage of it used to work fine & did recognize my CD drive.

Here are some solutions to fix the AppImage problem.
I tried this solution, it didnt appear to work (link #1)

I then found this solution for debian (Link #2)

Their solution is: " add a new line with fuse in /etc/modules ."

I need some guidance on how to do this, or if its even a good idea to do with Zorin.

Also any other possible solutions are gladly welcome & appreciated.


It is harmless, so your worst case is that it won't resolve your issue.
To apply the suggested fix, access the /etc/modules file and paste fuse on a new line at the bottom.
It should look like

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

If doing this in a text editor, you must first elevate to root, then launch the file manager or text editor elevated to root in order to change the file.
Or you can use nano:

sudo nano /etc/modules

arrow key to the bottom and paste fuse
Tap ctrl+o to overwrite, then the enter key, then ctrl+x to exit the editor.

1 Like

@Aravisian , thank you. I did exactly what you said & it still gets the same error. I also tried to run the fre:ac AppImage using sudo in terminal & I still get "Cannot mount AppImage, please check your FUSE setup."

It used to work great, i have no idea why it stopped working.
This sucks because i need to rip a CD, but have no way to right now.
I use fre:ac because it has two features: the AccurateRip feature,I always use the "AccurateRip" feature to make sure all data was copied, no info was scratched/damaged. Also, "fre:ac" can download the tracklist for the CD from the online CDDB database.

Have you rebooted or run sudo modprobe fuse to load and start the module?
You can check Fuse for setup problems by opening a terminal and running fuse_tester
Have any permissions changed? Ensure that the appimage permissions include executing as a program.

1 Like

I rebooted, but the AppImage still gives me same error. I then did terminal: sudo modprobe fuse

I then tried to run the AppImage, but still same fuse error.
I then did command: sudo fuse_tester
And the results were:
sudo: fuse_tester: command not found

Does fuse -v or fuse --version tell you which version you have installed?
You may need to contact the fre:ac maintainer for more detailed troubleshooting on this one...

1 Like

Still no progress, here are the instructions: (LINK)

I just followed the following instructions & it still didnt work:

"For example, on Ubuntu (<= 21.10):

sudo apt install fuse libfuse2
sudo modprobe fuse
sudo groupadd fuse

sudo usermod -a -G fuse $user

Should i type "user="$(whoami)" exactly? or interchange something in it?

Also, I dont understand the alternative AppImage solutions here below, can you help me run the AppImage using these methods? i extracted the AppImage into a folder, but it doesnt say what to do after that!

"If you don't want to install FUSE, you can either mount or extract the AppImage.

type-2 AppImage

To extract the contents of the AppImage, simply run the AppImage with --appimage-extract.

type-1 AppImage

If the above does not work, you may still have an older type-1 AppImage. To mount the AppImage and run the application, simply run

sudo mount -o loop Some.AppImage /mnt

A type-1 AppImage is an ISO, so

sudo apt install libarchive-tools # Or any other method to get `bsdtar`
mkdir AppDir
cd AppDir
bsdtar xfp /home/me/Downloads/Some.AppImage

You can use user="$(whoami)" just as written without substituting anything.
The "$(whoami)" is a self-identify command.

This would be done in terminal with the prompt to run the app image, followed by the additional parameters. Let's say that the appimage is named "example":

./example --appimage-extract

Using the above example, we can use:

sudo mount -o loop example.AppImage /mnt

this is /mnt followed by *the location of the appimage or the path to it. So, given the example above, let's place our example.appimage in the root /opt directory. Then to run it:


1 Like

Thanks! here are my results, not working:

user@user:~/Downloads/Programs$ sudo mount -o loop '/home/user/Downloads/Programs/fre:ac is a free audio converter and CD extractor,-1.1.6-linux-x86_64.AppImage' /mnt
[sudo] password for user:
mount: /mnt: wrong fs type, bad option, bad superblock on /dev/loop19, missing codepage or helper program, or other error.

user@user:~/Downloads/Programs$ sudo mount -o loop '/home/user/Downloads/Programs/squashfs-root' /mnt
mount: /mnt: failed to setup loop device for /home/user/Downloads/Programs/squashfs-root.

user@user:~/Downloads/Programs$ sudo mount -o loop '/home/user/Downloads/Programs/fre:ac is a free audio converter and CD extractor,-1.1.6-linux-x86_64.AppImage' /mnt/opt
mount: /mnt/opt: mount point does not exist.

Jessie, you must follow the instructions. As I stated above, I was providing example names and locations. I do not have access to your computer and I cannot see where you keep your files or what their names are.
Did you get the above instructions from this page?

I highly recommend asking about your issue here:

Zorin OS comes with fuse preinstalled and if this is determined a Zorin OS issue (A recent update perhaps), we can alert the ZorinGroup to it.
We are not experts on fre:ac ; I never even heard of it until you started this thread... And those at the fre:ac Help & Support forum would likely be much more helpful than our guesses.

This likely was the Snap or Flatpak wrapped package and... I can see why it would fail to recognize anything outside of its sandbox.

You might try rolling back the appimage to a previous version: fre:ac 1.1.6

And see if it is working.

1 Like

Thanks for your help. So ur advice to roll back the version helped. I also tried the most recent release. All other versions dont have the FUSE problem at all. So then, i figured out what was causing the fuse problem, its when i rename the AppImage. For example if i change: "fre ac 1.1.7-linux-x86_64.AppImage"

to: "fre:ac is a free audio converter and CD extractor-1.1.7-linux-x86_64.AppImage"

It wont start at all. But i dont get the fuse error. What causes the fuse error humorously enough is if i rename the appImage & put a comma in the file name. So it appears fre:ac works now. :slight_smile:

1 Like

I'll try to solve this: what's the output of flatpak --list

1 Like

Thanks for the offer to help :slight_smile: , flatpak --list didnt work, but "flatpak list" did.

Name Application ID Version Branch Origin Installation
RetroShar… …share.retroshare-gui 0.6.6 stable flathub system
GPU Scree… ….gpu_screen_recorder 2.0.0 stable flathub system
ClamTk ….gitlab.davem.ClamTk 6.15 stable flathub system
OBS Studio com.obsproject.Studio 29.1.1 stable flathub system
XnView MP com.xnview.XnViewMP 1.4.4 stable flathub system
Pidgin im.pidgin.Pidgin 2.14.12 stable flathub system
Mini Syst… ….mini-system-monitor 1.7.0 stable flathub system
Monitorets ….jorchube.monitorets 0.10.0 stable flathub system
A Photo T… …hola.aphototoollibre 1.0.5 stable flathub system
fre:ac org.freac.freac 1.1.7 stable flathub system
TAP-plugi… …nuxAudio.Plugins.TAP 1.0.1 22.08 flathub system
SWH …nuxAudio.Plugins.swh 0.4.17 22.08 flathub system
Freedeskt… …freedesktop.Platform 22.08.11 22.08 flathub system
Mesa ….Platform.GL.default 21.1.8 20.08 flathub system
Mesa ….Platform.GL.default 21.3.9 21.08 flathub system
Mesa ….Platform.GL.default 23.0.2 22.08 flathub system
Mesa (Ext… ….Platform.GL.default 23.0.2 22.08-extra flathub system
Intel …Platform.VAAPI.Intel 20.08 flathub system
Intel …Platform.VAAPI.Intel 21.08 flathub system
Intel …Platform.VAAPI.Intel 22.08 flathub system
openh264 …op.Platform.openh264 2.1.0 2.0 flathub system
openh264 …op.Platform.openh264 2.1.0 2.2.0 flathub system
GNOME App… org.gnome.Platform 43 flathub system
GNOME App… org.gnome.Platform 44 flathub system
ZorinBlue… …theme.ZorinBlue-Dark 3.22 zorinos system
ZorinBlue… …heme.ZorinBlue-Light 3.22 zorinos system
ZorinGree… …heme.ZorinGreen-Dark 3.22 zorinos system
ZorinGree… …eme.ZorinGreen-Light 3.22 zorinos system
ZorinGrey… …theme.ZorinGrey-Dark 3.22 zorinos system
ZorinGrey… …heme.ZorinGrey-Light 3.22 zorinos system
ZorinOran… …eme.ZorinOrange-Dark 3.22 zorinos system
ZorinOran… …me.ZorinOrange-Light 3.22 zorinos system
ZorinPurp… …eme.ZorinPurple-Dark 3.22 zorinos system
ZorinPurp… …me.ZorinPurple-Light 3.22 zorinos system
ZorinRed-… …3theme.ZorinRed-Dark 3.22 zorinos system
ZorinRed-… …theme.ZorinRed-Light 3.22 zorinos system
KDE Appli… org.kde.Platform 5.15 flathub system
KDE Appli… org.kde.Platform 5.15-21.08 flathub system
KDE Appli… org.kde.Platform 5.15-22.08 flathub system
KDE Appli… org.kde.Platform 6.4 flathub system
QGnomePla… …Theme.QGnomePlatform 5.15 flathub system
QGnomePla… …Theme.QGnomePlatform 5.15-21.08 flathub system
QGnomePla… …Theme.QGnomePlatform 5.15-22.08 flathub system
QGnomePla… …Theme.QGnomePlatform 6.4 flathub system
QtSNI ….PlatformTheme.QtSNI 5.15 flathub system
QtSNI ….PlatformTheme.QtSNI 5.15-21.08 flathub system
QGnomePla… …ePlatform-decoration 5.15 flathub system
QGnomePla… …ePlatform-decoration 5.15-21.08 flathub system
QGnomePla… …ePlatform-decoration 5.15-22.08 flathub system
QGnomePla… …ePlatform-decoration 6.4 flathub system
Kdenlive org.kde.kdenlive 23.04.1 stable flathub system
i2pd website.i2pd.i2pd 2.47.0 stable flathub system

When did you install it as a flatpak?

when he installed it from the gnome software store.

So, for making fre:ac recognize (is it written like this?) your dvd drive, you should install flatseal:
(Run this command in the terminal, accessible with the keyboard shortcut CTRL-ALT-T, or by opening the 'Terminal' app)

flatpak install flathub com.github.tchx84.Flatseal

Then open the flatseal app and giving fre:ac the needed permissions. Then you'll be able to use the version of the app you downloaded from the Software Store.

1 Like

Thank you, @Aravisian, for correcting my mistake. Sorry if I get something wrong sometimes, but English isn't my native language.

1 Like

Well, you did specifically ask:

1 Like

I know, I was excusing myself for the ignorance of such a stupid problem.

@Nicolaco_08 , thanks for the advice! :slight_smile: Unfortunately it didnt work.
here are all my option that "Flatseal" offers me: